Bug 78732 - Add keyboard shortcuts for Clone formatting
Summary: Add keyboard shortcuts for Clone formatting
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators Clone-Formatting
  Show dependency treegraph
 
Reported: 2014-05-15 08:58 UTC by Alexander
Modified: 2019-12-15 16:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
just a tool button picture to be clear (5.72 KB, image/png)
2014-05-15 08:58 UTC, Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2014-05-15 08:58:21 UTC
Created attachment 99072 [details]
just a tool button picture to be clear

Problem description: 
Want to copy format of a fragment (e.g. by Ctrl+Shift+C like in MS Word) and then to select another fragment and to insert the copied format (e.g. by Ctrl+Shift+V). Cannot adjust Impress for functioning this way.

Was directed to here by link 
http://www.libreoffice.org/get-help/bug/?LOversion=4.2.4.2&LOlocale=en-US&LOmodule=PresentationDocument ("File an enhancement request") so it's not a bug I think.


Operating System: Windows 8
Version: 4.2.4.2 release
Comment 1 A (Andy) 2014-11-01 07:37:11 UTC
Is my understanding correct that you would like to have also a shortcut for the FORMAT PAINTBRUSH function?

But what I have not noticed before is this tooltip.  What does "(double click for multi-selection)" mean.  This tooltip is not clear/intuitive for me.
Comment 2 Alexander 2014-11-01 08:22:06 UTC
To Andy,

I often need to set the same format to several separate text fragments. In MS Word I can copy a selected fragment's format (it's always copied when "Format Paintbrush" button is pressed) and then iterate in selecting some text fragment and applying the copied format options (MS Word uses Ctrl+Shift+V by default). It's so much logical I think. In LO I can do it only with mouse that is very inconvenient.
Comment 3 A (Andy) 2014-11-01 08:33:02 UTC
Thanks for your fast reply, for me a shortcut seems to be a good idea.

(tested with LO 4.3.3.2, Win8)
Comment 4 Dan Dascalescu 2018-12-05 23:26:10 UTC
A keyboard shortcut/accelerator for "Clone formatting" in Calc would be very useful indeed. I copy formatting all the time, and have to hunt for the mouse :(
Comment 5 sdc.blanco 2019-12-15 16:19:54 UTC
You can do this for yourself.

1.  Tools > Customize > Keyboard 
2.  Use Category 'Edit' and Function 'Clone'
3.  Choose your preferred shortcut key and click Modify

Works in Impress, Calc, Writer.

Tested in Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_DK); UI-Language: en-US
Calc: CL

Will close as WORKSFORME