Download it now!
Bug 78754 - VIEWING: Table Borders Appear Distorted
Summary: VIEWING: Table Borders Appear Distorted
Status: RESOLVED DUPLICATE of bug 81643
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-05-15 19:01 UTC by Joel Madero
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
FileToOpen (8.68 KB, application/vnd.oasis.opendocument.text)
2014-05-15 19:01 UTC, Joel Madero
Details
Image Showing Perfect Borders (View only, print still small gap) (10.84 KB, image/png)
2014-05-15 19:02 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2014-05-15 19:01:53 UTC
Created attachment 99120 [details]
FileToOpen

Table borders on master appear distorted.

Steps:
1. Open attached file with master

Observed: Corners are being distorted

Expected: Borders look clean

Notes:
1. Borders are a bit of a mess (see bug 38635) in general but there is one version that I fortunately came across during bibisect (with 4.3 bibisect package) that looks perfect (but it still prints with a slight separation at the corner)

2. Printing with 4.3 is much better (just that slight separation)

Bibisect:
d7078f40ea1c0e9f2ff1f6c29a19f6385130386d is the first bad commit
commit d7078f40ea1c0e9f2ff1f6c29a19f6385130386d
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun May 11 03:38:01 2014 +0000

    source-hash-3034b144d0062e9c4394b901aded43fec117ed11
    
    commit 3034b144d0062e9c4394b901aded43fec117ed11
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Tue Jan 21 12:22:35 2014 +0100
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Tue Jan 21 12:25:20 2014 +0100
    
        OfficeBean example does not work on OS X (where officebean.jar is not built)
    
        Change-Id: I18c9d0fa0a74cbbdad43bd99d87dc6414a0264d2

:100644 100644 5dd420896fae2b5044048deb9a71598d3d741138 9e1f3c5fa2f448236193288c5944c23614f7384e M	ccache.log
:100644 100644 7659db9e2154632a45523aeb7532787e77dccb43 bd7bdda54adab50bc28d3004f63989cb1e918cc2 M	commitmsg
:100644 100644 845a0da3ea8bfc62bcc5e882cca9635f1215b718 0e5478ad12a5a0df40a416f5007568bcced28edc M	make.log
:040000 040000 d1aeaaac55ba3ddaf838046f99adf343aaeeb0e4 e80ab87c6308a3789ba3b6de928a379175541feb M	opt


# bad: [ea24c76037fa8056fb1ed916f4d5e765ebc71f8f] source-hash-46cfcd5a05aa1d13fecd73f5a25b64b8d8dd6781
# good: [6ab7f53af36f13bbefdd4e4fcbd3d1ea432a77d9] source-hash-22029c7e17b4cb48acb058d47ec9c3b6b8b6b294
git bisect start 'latest' 'oldest'
# bad: [45f8b50e2e33d2125a348134dd931ba01c70fe63] source-hash-0141153498bc34237d5b7dd72226ac2a03bbd11d
git bisect bad 45f8b50e2e33d2125a348134dd931ba01c70fe63
# bad: [d7078f40ea1c0e9f2ff1f6c29a19f6385130386d] source-hash-3034b144d0062e9c4394b901aded43fec117ed11
git bisect bad d7078f40ea1c0e9f2ff1f6c29a19f6385130386d
# good: [ae174a5dad6af4c0ac15756d8f2c986505499fb6] source-hash-bda58c33afe9a9f6ca4f8b27bff44ba2c22da395
git bisect good ae174a5dad6af4c0ac15756d8f2c986505499fb6
# good: [73abeda4de0b0294879d80693e4170e5b337b623] source-hash-4356aef48a8fcbd9dd019c0ca2d6a189d7332d0c
git bisect good 73abeda4de0b0294879d80693e4170e5b337b623
# good: [40c17b23437cae8f5e8b1ca9cb4ddecb8af59c00] source-hash-eeeefd6fd87b3cff18ba9078869bdfcd0e351d6f
git bisect good 40c17b23437cae8f5e8b1ca9cb4ddecb8af59c00
# skip: [2b40eb6e6119706141aeaf4554b905df2d591f24] source-hash-03725013b64e74473e1a9e925b24927e7e61d412
git bisect skip 2b40eb6e6119706141aeaf4554b905df2d591f24
# skip: [9fa58ed1cac23b404ad4fa8e8d381b0119c92a37] source-hash-6069b5162281ccc88eb242991a115197d0893fb4
git bisect skip 9fa58ed1cac23b404ad4fa8e8d381b0119c92a37
# good: [3b851f7e61c98722f0134f010db08e50e06f08f7] source-hash-ed5065d8b080bfaf51ea1232cebf3ff72af1e640
git bisect good 3b851f7e61c98722f0134f010db08e50e06f08f7
# good: [d05749940806480564c57eaa2603a51d601886b2] source-hash-78a61583c266a1fd222cd78c912e35e93f7010d3
git bisect good d05749940806480564c57eaa2603a51d601886b2
# first bad commit: [d7078f40ea1c0e9f2ff1f6c29a19f6385130386d] source-hash-3034b144d0062e9c4394b901aded43fec117ed11
Comment 1 Joel Madero 2014-05-15 19:02:53 UTC
Created attachment 99121 [details]
Image Showing Perfect Borders (View only, print still small gap)
Comment 2 Jorendc 2014-05-16 16:21:48 UTC
Repro, tested using Version: 4.3.0.0.alpha1+
Build ID: cc4a3f1a88afff114311bddf462ca4bc00a485c7
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-05-12_09:05:53

Kind regards,
Joren
Comment 3 Björn Michaelsen 2014-10-11 13:13:01 UTC
This looks like it is a sideeffect by Koheis commits on drawinglayer/source/processor2d/vclpixelprocessor2d.cxx for fdo#73487.
Comment 4 Björn Michaelsen 2014-10-16 14:59:18 UTC
(This is an automated message.)

It seems that the commit that caused this regression was identified. (Or at least a commit is suspected as the offending one.)

Thus setting keyword "bisected".
Comment 5 Matthew Francis 2015-01-16 12:02:13 UTC
Although it's only the end of a long series of border related commits, the one mentioned in comment 3, which is the below commit, is most directly responsible for the lumpy border corners in Writer.

commit 15974abe63f0d4fc88099634d5cd2ddb9760ec23
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Mon Jan 20 18:37:08 2014 -0500

    fdo#73487: Center thick border lines around cell grid.
    
    This reduces the amount of gap at line joins. Plus it generally looks better
    this way.
    
    Change-Id: Ifd21cd0bc1f61f8a875b1bad9cfb33564c18b9ae
Comment 6 Matthew Francis 2015-01-16 12:10:51 UTC
Bug 81643 seems to be essentially the same issue, and there are already commits referencing it - probably best to keep them together even though ordinarily the later bug would be closed in favour of the earlier bug.

Relevant discussion moved over there.

*** This bug has been marked as a duplicate of bug 81643 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:03:17 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]