Bug Hunting Session
Bug 78761 - SLIDESHOW: Slideshow is slow. Also with glitches
Summary: SLIDESHOW: Slideshow is slow. Also with glitches
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-15 22:30 UTC by Yan Pas
Modified: 2015-03-07 13:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2014-05-15 22:30:30 UTC
Problem description: While slides are changing I see 2 problems:
1) White stripes blinks for a moment sometimes somewhere at the top
2)Slide are changing by laces. I think they need vertical synchronization or something like this. Slide divides in about ten stripes and the first stripe runs ahead of the second, the second is ahead of third and so on.
Animation called shift to left, but it reproduced with a lot of animations

Steps to reproduce:
1. Open presentation
2. Add some animation
3. Start slideshow

Reproduced on nvidia machine with proprietary drivers and netbook

              
Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 Joel Madero 2014-05-16 01:04:17 UTC
Does this happen for every presentation? Is this new to 4.2.4.2 or was it an issue prior to this release?
Comment 2 Yan Pas 2014-05-16 06:26:04 UTC
(In reply to comment #1)
> Does this happen for every presentation? Is this new to 4.2.4.2 or was it an
> issue prior to this release?

This issue is since i was using libreoffice, from 4.1, but I'm sure it was in ealier versions. White stripes are buzzing only with 3d transition "Rosetta", maybe some other 3d effects. And interlacing effect (vsync problem) happens with every horizontal transition
Comment 3 Joel Madero 2014-05-16 15:19:45 UTC
updating version to at least 4.1 release (our versions are oldest version, not latest version) that you see the issue

I do not see this problem at all
Comment 4 Yan Pas 2014-05-16 23:43:10 UTC
I have checked LO on Windows (3.6 and 4.2) - everything is OK. Something with graphical acceleration on ubuntu. The bug is not so annoying if slide fits my screen
Comment 5 tommy27 2014-05-17 11:52:26 UTC
@Yan 
give a look at Bug 78703 test case and tell me if you think these are related issues.
Comment 6 Yan Pas 2014-05-19 08:50:43 UTC
@tommy27 No, this bug doesn't affect me, this effects work correctly. Ive captred video on my iPad that show the problem. I give you dropbox link to video, effect begins from 2nd second 
https://www.dropbox.com/s/8s6bditvulfsa14/2014-05-19%2012.40.55.mov
Comment 7 tommy27 2014-05-19 13:17:26 UTC
thanks 4 video. let's see if other Linux users experience anything similar.
Comment 8 Buovjaga 2014-11-01 15:51:48 UTC
(In reply to Yan Pashkovsky from comment #6)
> @tommy27 No, this bug doesn't affect me, this effects work correctly. Ive
> captred video on my iPad that show the problem. I give you dropbox link to
> video, effect begins from 2nd second 
> https://www.dropbox.com/s/8s6bditvulfsa14/2014-05-19%2012.40.55.mov

Link is broken.

I tested on a laptop with Manjaro and ATI Radeon and I see what you mean by Wipe left or right having a jagged edge when it slides. Wipe up or down don't have this problem. I'm not sure, if this is LO's fault - it might be just a limitation of the X window system. This is why I won't switch this to NEW. We need some expert's opinion.

Would be interesting to see, how a Wayland-using compositor behaves in this case.

Version: 4.3.2.2.0+
Build ID: 4.3.2.2 Arch Linux build-1
Comment 9 Yan Pas 2014-11-01 16:04:31 UTC
LO 4.4 uses OpenGL transitions, maybe that would fix the problem. https://wiki.documentfoundation.org/ReleaseNotes/4.4
Comment 10 tommy27 2015-03-07 10:27:54 UTC
@Yan
LibO 4.4.1.2 is out.
please give it a try and tell us if the issue has been fixed.
Comment 11 Yan Pas 2015-03-07 13:25:49 UTC
Yes, no everything work good and smoothly. May be closed
Comment 12 Buovjaga 2015-03-07 13:40:46 UTC
Thanks for testing. I'll mark as WFM.