Bug 78703 - SLIDESHOW: fading slide transitions start with a white 'flash'
Summary: SLIDESHOW: fading slide transitions start with a white 'flash'
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2014-05-14 18:59 UTC by Rene Sedmik
Modified: 2021-10-17 14:29 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
minimal test case (11.08 KB, application/vnd.oasis.opendocument.presentation)
2014-05-17 10:18 UTC, Rene Sedmik
Details
screencast demonstrating the issue (857.21 KB, video/webm)
2015-09-06 16:43 UTC, Jeff Fortin Tam
Details
some transitions impacted by the color's bug (1.03 MB, video/x-msvideo)
2015-11-25 07:55 UTC, roumanet
Details
square while transitions (flashing) (14.35 KB, application/vnd.oasis.opendocument.presentation)
2015-12-04 17:31 UTC, roumanet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Sedmik 2014-05-14 18:59:37 UTC
Problem description: 

The slide transitions `Fade smoothly' and `Fade through black' produce a white flash (like one frame of a video, sometimes the white screen is interrupted with black bars) before starting. The following slide is normal.

Steps to reproduce:
1. Choose a background color of the previous slide (the one from which the effect starts from) which is different from white (otherwise the effect is barely visible but still there).
2. Set slide transition to either `Fade smoothly' or `Fade through black'. Already the preview shows the white flash but it gets really obvious on the presentation
3. Look at the transition in the slide show and `flash' your audience

Current behavior:
Slide transitions involving a fade start with a white flash or burst before operating normally.

Expected behavior:
The first frame of the transition should equal the starting slide without any glitches.
              
Remark:
I have Fedora 20, on kernel 3.14.3, x64 on an Asus UX51V with NVidia+Intel card (The intel card is active with nouveau as driver, glx active). Java, opengl, flash, etc. work usually correct without errors.
The flash effect looks like if a non initialized page is simply displayed before the first rendered frame.

Remark II:
I never used these transitions before, so I cannot tell when this glitch appeared first.
Operating System: Fedora
Version: 4.2.4.2 release
Comment 1 tommy27 2014-05-17 04:52:17 UTC
please upload a simple test case with those slide transitions where you see that glitch.
Comment 2 Rene Sedmik 2014-05-17 10:18:54 UTC
Created attachment 99209 [details]
minimal test case

This is a minimal test case file.
Slide transition 'fade smoothly' from a slide with black background to one without (white).
Comment 3 Rene Sedmik 2014-05-17 10:21:19 UTC
I tested the same on an Ubuntu 13.10 system, with Libreofficce 4.0, also with Nvidia card but with proprietary drivers. There the glitch did not appear.
Could it be be that this is not a problem of LibreOffice but of glx?
Comment 4 tommy27 2014-05-17 11:38:17 UTC
no problem with test case under Win7x64 using LibO 4.2.4.2.
Comment 5 Rene Sedmik 2014-05-17 11:58:33 UTC
Thanks for the test.
Any suggestions how to track down the source of the error I see? It would be interesting if someone else could test this under Fedora Linux.
Comment 6 Joel Madero 2014-05-20 04:04:05 UTC
Requesting advice - but I believe this is NOTOURBUG. I'll let a developer who knows a lot more than I do set the status though :)
Comment 7 ablumer 2014-08-27 18:22:13 UTC
I am experiencing the same behavior. I've had to turn off the transitions to avoid the white flash.

A bit of history that might be helpful. I'm using Linux Mint 17 now. I was running Linux Mint 16 previously and did not see this problem in LibreOffice (not exactly sure of the version). I installed OpenOffice at the same time, and OpenOffice did show the white flash. I upgraded to Linux Mint 17 this summer and LibreOffice started the flashes. I have received a new laptop since then, put Linux Mint 17 on it, and it also flashes. This is with LibreOffice 4.2.4.2, Build ID: 420m0(Build:2)

My current hardware is a Dell Latitude E5440. The OpenGL is provided by Mesa 10.1.3 with the Vendor shown as "Intel Open Source Technology Center".

lspci shows: VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Comment 8 Joel Madero 2014-08-27 18:25:16 UTC
If this is a regression a bibisect would be nice:


https://wiki.documentfoundation.org/QA/HowToBibisect
Comment 9 ablumer 2014-08-27 19:37:02 UTC
Further information: I ran 'apitrace trace /usr/bin/loffice' and showed a couple slides that flash during transition. It produced a ~/soffice.bin.trace (rather than loffice.bin.trace ? ). I then ran 'glretrace -s /tmp/frame ~/soffice.bin.trace' which produced little PNG thumbnails of all the frames as it's fading in the slide.

The third frame in the sequence is all white. The two before it look all black. The one after it is a dark rendition of the slide.
Comment 10 ablumer 2014-08-27 20:29:56 UTC
I know next to nothing about GL, but I ran the same test above using qapitrace, a graphical front-end to GL API tracing. qapitrace shows each of the API calls in sequence, and in frame number 2 (which is the third frame), it is showing the frame turning white after this API call:

glDrawArrays(GL_TRIANGLES, 0, 6)


It's probably also important to note that because of different screen and slide aspect ratios, the display puts vertical black bars on either side of the slide to fill the screen, and the white screen has those black bars on either side. So it looks as though something really did intend to show an all-white slide.

Here is a list of some of the API calls before that glDrawArrays() (from 'apitrace dump'):

348 glPushMatrix()
349 glDisable(cap = GL_DEPTH_TEST)
350 glBindTexture(target = GL_TEXTURE_2D, texture = 1)
351 glPushMatrix()
352 glScaled(x = 0.8989751098096632, y = 1, z = 1)
353 glEnableClientState(array = GL_VERTEX_ARRAY)
354 glEnableClientState(array = GL_NORMAL_ARRAY)
355 glEnableClientState(array = GL_TEXTURE_COORD_ARRAY)
356 glTexCoordPointer(size = 2, type = GL_DOUBLE, stride = 0, pointer = blob(96))
357 glNormalPointer(type = GL_DOUBLE, stride = 0, pointer = blob(144))
358 glVertexPointer(size = 3, type = GL_DOUBLE, stride = 0, pointer = blob(144))
359 glDrawArrays(mode = GL_TRIANGLES, first = 0, count = 6)

I'll keep the trace around. Its over 2MiB so I'm not sure if it can be uploaded.
Comment 11 Kevin 2014-10-02 05:09:42 UTC
LibreOffice 4.2.6.3
Ubuntu 14.04.1 AMD64 (brand-new install)
Dell Latitude E5400
Intel Mobile 4 Series Integrated Graphics

I am also experiencing the same issue with a white flash on slide transitions when using Fade smoothly.  File format is .ODP.  System is a fresh install on clean drive, fully up-to-date, and no additional drivers to install.

Just figured I'd add my experience as well since I'm not the only Latitude E5400 series laptop having this issue.
Comment 12 tommy27 2014-10-02 05:13:47 UTC
set status to NEW because of independent confirmation in previous comment.
has anybody of the reproducing users already tried LO 4.3.2.2? is issue still there?
Comment 13 Kevin 2014-10-02 05:22:46 UTC
I have not tried LO 4.3.2.2 yet and I am on a time crunch to get this present done tonight...yay.  However, I will give it a try (after my presentation tomorrow) on the same file to see if I still have the issue on the newer version and report back.  For now I am just going without the transitions.
Comment 14 ablumer 2014-11-05 18:07:43 UTC
I just installed 4.3.3.2 and the white flash just happened.

I have a theory about what is happening. Through the year and a half that I've had to do presentations regularly, I have usually seen this problem, but as I went from one version of LibreOffice to the next, its behavior changed slightly. E.g., for 4.3.2.2 and 4.3.3.2, the flash does not usually occur, but for earlier versions, it usually did occur.

Because of the nature of the variations, I think that the performance of my computer may be a factor. When I use a cpufreq applet to keep the processor running full speed, I do not believe I have seen the flash occur. So I suspect there is a race between drawing in a buffer and the graphics code displaying it. Perhaps the buffer is being displayed before it has been filled, and thus we see a flash.
Comment 15 pieter kristensen 2015-02-13 13:46:35 UTC
(In reply to ablumer from comment #14)
> I just installed 4.3.3.2 and the white flash just happened.
> 
> I have a theory about what is happening. Through the year and a half that
> I've had to do presentations regularly, I have usually seen this problem,
> but as I went from one version of LibreOffice to the next, its behavior
> changed slightly. E.g., for 4.3.2.2 and 4.3.3.2, the flash does not usually
> occur, but for earlier versions, it usually did occur.
> 
> Because of the nature of the variations, I think that the performance of my
> computer may be a factor. When I use a cpufreq applet to keep the processor
> running full speed, I do not believe I have seen the flash occur. So I
> suspect there is a race between drawing in a buffer and the graphics code
> displaying it. Perhaps the buffer is being displayed before it has been
> filled, and thus we see a flash.

On my laptop (Compa
Comment 16 pieter kristensen 2015-02-13 13:51:16 UTC
(In reply to pieter kristensen from comment #15)
> (In reply to ablumer from comment #14)
> > I just installed 4.3.3.2 and the white flash just happened.
> > 
> > I have a theory about what is happening. Through the year and a half that
> > I've had to do presentations regularly, I have usually seen this problem,
> > but as I went from one version of LibreOffice to the next, its behavior
> > changed slightly. E.g., for 4.3.2.2 and 4.3.3.2, the flash does not usually
> > occur, but for earlier versions, it usually did occur.
> > 
> > Because of the nature of the variations, I think that the performance of my
> > computer may be a factor. When I use a cpufreq applet to keep the processor
> > running full speed, I do not believe I have seen the flash occur. So I
> > suspect there is a race between drawing in a buffer and the graphics code
> > displaying it. Perhaps the buffer is being displayed before it has been
> > filled, and thus we see a flash.
> 
> On my laptop (Compaq 6720s - Intel GME965/GLE960 Integrated Graphics Controller, Kubuntu 14.04 32 bit, LO 4.4.0.3) - I have this white flash effect too. The flash is very short but rather intens.
Comment 17 pieter kristensen 2015-02-13 16:10:26 UTC
> On my laptop (Compaq 6720s - Intel GME965/GLE960 Integrated Graphics Controller, Kubuntu 14.04 32 bit, LO 4.4.0.3) - I have this white flash effect too. The flash is very short but rather intens.

Sorry, this went wrong. This is the more elegant way to say something here.
Comment 18 ablumer 2015-02-19 16:53:37 UTC
Just an update. I am now using 4.4.0.3. The flash still occurs. I have also seen it occur when cpufreq is set to maximum CPU frequency, but it does seem to happen less often. So I am still suspecting a race of some kind.
Comment 19 pieter kristensen 2015-06-30 07:22:25 UTC
I am testing 5.0.0.2 Kubuntu 14.04 32 bit.

There has always been a white flash during 3d transitions on this computer. With 5.0.0.2 the flash perhaps got a little shorter.
But it clearly is still there.

The cpu is not a speed monster on this machine http://www.cpubenchmark.net/cpu_lookup.php?cpu=Intel+Celeron+M+530+%40+1.73GHz&id=705 (single core) it is possible that that has something to do with it.
Comment 20 Jeff Fortin Tam 2015-09-06 16:43:28 UTC
Created attachment 118470 [details]
screencast demonstrating the issue

FWIW, I'm also seeing this on Fedora 22 64-bit with open-source "radeonsi" drivers for the Radeon HD 7770, running GNOME Shell 3.16 on X11.

This is with LibreOffice 5.0.1.2 (official RPMs downloaded from the LibreOffice website)
Comment 21 roumanet 2015-11-25 07:55:20 UTC
Created attachment 120780 [details]
some transitions impacted by the color's bug

I've tested some of transitions and record a little movie (see attachement)

I'm running on Win10 family 64bits, with Intel+Radeon videocard (HP4740s notebook)
I've tested with 5.0.(1 to 3) and with Libreoffice 5.1.0 alpha release (november, 24th)
Version: 5.1.0.0.alpha1 (x64)
Build ID: 0b48731919433e46e4fda7e5a5ca27c08c28b981
Locale : fr-FR (fr_FR)

As you'll see, forms and texts colors changes while transition occurs and get back at the end of effect.
Not all transitions are impacted but the most important one (Fade smoothly) cause problem (especially when showing educational curses to my students or when trying to record animation for education purpose)

Graphic card detail : AMD Radeon HD 7650M
Comment 22 roumanet 2015-12-02 12:56:27 UTC
Seems to be solved in 5.2 alpha1 release of LibreOffice.
Version: 5.2.0.0.alpha0+
Build ID: 1ed6d1423c7cffa5403dad69a9946ec790a374f2
Threads 2; Ver: Windows 6.19; Render: GL; 

TinderBox: Win-x86@42, Branch:master, Time: 2015-11-29_01:57:00
Locale: fr-FR (fr_FR)
Comment 23 tommy27 2015-12-02 15:48:09 UTC
nice to hear that.
set status to RESOLVED WORKSFORME

other users are encouraged to retest.
if the fix is verified we could do a reverse bibisect in order to obtain a 4.1.x backport
Comment 24 roumanet 2015-12-04 17:10:03 UTC
Sorry, bad bug number (I'm following two bugs :( )
It still a small flash from transition to final slide... so it's not solved !

(I've to search for the second bug with colors in transitions that are inverted)
However, there is a causal effet : if colors are inverted, at the end of the transition, it could show a white flash.
For now, it still a flash but not white : I would say, like a snapshot with a different scale or few pixels offset.
Comment 25 roumanet 2015-12-04 17:31:48 UTC
Created attachment 121024 [details]
square while transitions (flashing)

I've made some new tests : in fact, the transition occurs and at the end, the previous slide appears one frame !
on the attached slides, each square is removed on each slide, but while transition, near the last time of it, the previous slide (say 'A') with square present where it was removed on new slide (say 'B').

The strange thing, is I can't record it (with NCH Debut software), like this flash occurs between two synchronisation screen
Comment 26 Joel Madero 2015-12-04 18:57:33 UTC
Wrong status.
Comment 27 roumanet 2015-12-05 09:12:01 UTC
As my english wasn't very clear (sorry!) here is a better explanation :

[SlideA] -- SlideA mixed with SlideB -- [SlideB] [SlideA a very short time] [SlideB]
Comment 28 Buovjaga 2015-12-06 13:17:03 UTC
(In reply to roumanet from comment #27)
> As my english wasn't very clear (sorry!) here is a better explanation :
> 
> [SlideA] -- SlideA mixed with SlideB -- [SlideB] [SlideA a very short time]
> [SlideB]

No problem here.

Ubuntu 15.10 64-bit 
Version: 5.0.3.2
Build ID: 1:5.0.3~rc2-0ubuntu1
Locale: en-US (en_US.UTF-8)
Comment 29 Robinson Tryon (qubit) 2015-12-10 10:15:27 UTC Comment hidden (obsolete)
Comment 30 Jean-Baptiste Faure 2016-01-25 20:28:02 UTC
Not reproducible for me with the minimal test case with LO 5.0.5.0.0+ under Ubuntu 15.10 x86-64.
That said the status unconfirmed is wrong because this bug has been confirmed (see history). Set back to NEW.

Best regards. JBF
Comment 31 pieter kristensen 2016-02-04 10:58:27 UTC
On this Windows machine, (32 bit W10) the problem has become less. The flash is not white any more but at the end of the transition there is a distorsion. All 3d transitions do this.
Comment 32 Xisco Faulí 2016-09-19 15:29:38 UTC Comment hidden (obsolete)
Comment 33 jebsolutions 2016-10-21 20:34:26 UTC
Same symptoms in 5.3.0 alpha 1.  On windows 10 64bit and Lubuntu 16.04 64 bit.

The very last step of the fade-in for a split second shows what's underneath.  Seems like a weird Z-layering/transparency issue.

E.g. transitioning from Slide A to Slide B with fade smoothly looks like:
A + B @ 0% transparency
A + B @ 10% transparency
A + B @ 20% transparency
A + B @ 30% transparency
A + B @ 40% transparency
A + B @ 50% transparency
A + B @ 60% transparency
A + B @ 70% transparency
A + B @ 80% transparency
A + B @ 90% transparency
A + B @ 0% transparency  <-- zero percent transparency ??
B @ 100% transparency 

For a split second B disappears so you get a "Flash" of the previous slide  below it.  

I think these bugs slide/animation transition problems are all the same:

slide flash
https://bugs.documentfoundation.org/show_bug.cgi?id=73273

slide transition
https://bugs.documentfoundation.org/show_bug.cgi?id=95479

Animation problem:
https://bugs.documentfoundation.org/show_bug.cgi?id=47341

There are many other duplicates of this bug.  I really hope this can get some attention.
Comment 34 QA Administrators 2017-10-23 13:59:25 UTC Comment hidden (obsolete)
Comment 35 Timur 2021-04-16 13:14:22 UTC
This is older bug, not obvious. Please retest. Please see bug 91456.
Comment 36 QA Administrators 2021-10-14 03:47:41 UTC Comment hidden (obsolete)
Comment 37 Rene Sedmik 2021-10-14 09:43:28 UTC
In response to Comment #36.

In LibreOffice 7.062 the minimal test case works without problems.
The problem seems to be solved

Thanks!
Comment 38 Telesto 2021-10-17 08:50:27 UTC
I still see a flash(on Windows)
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 93115d2c54d645bcf2f80fde325e3ede39dee4d5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 39 Buovjaga 2021-10-17 09:16:06 UTC
Seems we had earlier Windows confirmations, but OS was not changed to All.
Comment 40 Rafael Lima 2021-10-17 14:29:01 UTC
It is working on my machine using LO 7.3 alpha (build from Oct 14) and the kf5 backend. I used the "minimal test case" and it worked as expected, without the initial flash.

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: c998691e22ceda15c89d55cf7005201f0392dadb
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-10-14_11:54:20
Calc: threaded

Maybe a Windows-only issue?