Bug 95479 - Flicker in slide animation fade in
Summary: Flicker in slide animation fade in
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
Reported: 2015-10-31 17:52 UTC by 4bf5c083
Modified: 2023-01-30 05:47 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:

OpenGL details (37.10 KB, text/plain)
2015-10-31 17:52 UTC, 4bf5c083
Example file (62.90 KB, application/vnd.oasis.opendocument.presentation)
2016-12-29 19:28 UTC, Telesto

Note You need to log in before you can comment on or make changes to this bug.
Description 4bf5c083 2015-10-31 17:52:30 UTC
Created attachment 120146 [details]
OpenGL details

Just recently upgraded to from and presentations that I created in which had Fade-in slide animations are plagued with a slide flicker. The flicker is a split second flash of the previous slide at the end of the transition.  This makes it completely unusable.

I thought it might be an issue with incompatibility between the older version fade-in and the newer one, so I removed the fade-in slide transition from the original and re-created the transition with the new version Fade Smoothly. The new version has the same problem. I have tested many of the transitions and the flicker appears using Fine Dissolve, Fade Through Black, Fade Smoothly, Rochade, Turn around, Turn down – there maybe others that I have not tested but these are for sure.

I'm on an iMac running Yosemite:

Hardware Overview:

  Model Name:	iMac
  Model Identifier:	iMac12,2
  Processor Name:	Intel Core i5
  Processor Speed:	2.7 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	6 MB
  Memory:	12 GB
  Boot ROM Version:	IM121.0047.B21
  SMC Version (system):	1.72f2
Comment 1 Alex Thurgood 2015-11-02 09:43:51 UTC
Please provide a test Impress document so that we can attempt to confirm.
Comment 2 Pierre C 2016-03-10 12:14:44 UTC
I can confirm this bug.

All my slides are unusable, because I just use fading between slides

All is fine with LO 4.7.2. All is wrong in all versions Of LO 5.0 and 5.1

Working with Windows 10 x64
Comment 3 Xisco Faulí 2016-10-10 11:24:45 UTC Comment hidden (obsolete)
Comment 4 jebsolutions 2016-10-21 19:48:56 UTC
This bug is still present in 5.3.0 alpha 1.

Windows 10 64bit and Lubuntu 16.0.4 64bit.

Say we are transitioning from slide A to slide B using Fade transition with through-black option not checked.

It's like this happens: 
Slide A 
Slide A with Slide B at 90% transparency
Slide A with Slide B at 80% transparency
Slide A with Slide B at 70% transparency
Slide A with Slide B at 60% transparency
Slide A with Slide B at 50% transparency
Slide A with Slide B at 40% transparency
Slide A with Slide B at 30% transparency
Slide A with Slide B at 20% transparency
Slide A with Slide B at 10% transparency
Slide A with Slide B at 0% transparency
Slide A with Slide B at 100% transparency <<< ???
Slide B

For a split second you see the previous slide at the end of the transition.  It is repeatable, but not always observable.  I will notice it about 70% of the time or more.

It really looks horrible. :(
Comment 5 Alex Thurgood 2016-11-25 11:23:58 UTC
@PierreC, @jebsolutions :

we need a test file in order to be able to triage this bug correctly through the system. Since you both mention that you are experiencing the same problem as the initial reporter, could one of you please provide a test Impress document in which the problem is visible ? Otherwise, this report will be closed as RESOLVED INSUFFICIENTDATA.
Comment 6 Telesto 2016-12-29 19:28:26 UTC
Created attachment 130018 [details]
Example file

I can repro it with the example file and OPENGL enabled
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: nl-NL (nl_NL); Calc: CL
Comment 7 Aron Budea 2017-03-31 12:33:10 UTC
Possibly the same as bug 99685?
Comment 8 jebsolutions 2017-06-07 07:29:04 UTC
I think all these flickering/transition bugs go back to the OpenGL enhancements a few versions back.  I think the code changes broke compatibility with various OpenGL drivers and this is the result.  

My laptop has an intel i7-2620m cpu.  By default I'm using the integrated Intel graphics in the CPU.  This exhibits all the flickering/transition symptoms.

However...my laptop also has a discrete graphics card.  If I switch my laptop to use the NVIDIDA NVS 4200M video card LibreOffice works good.  

This explains why some people have the problem, and others don't.

Any easy way to test this is to use VirtualBox and install the VirtualBox guest additions.  

Just fyi...everything worked fine in older versions of OpenOffice and LibreOffice so this is a regression bug.  

Suggest testing on older Intel, Amd, Nvidia, and virtualbox.  Would be nice if we could have a non-broken version.  I'm still stuck on using old old versions to work around this bug.  :(
Comment 9 Pierre C 2017-06-08 18:55:29 UTC
I've made some test with my notebook
Widows 10 LO (both x64)
On my notebook, there are two graphic cards : NVIDIA GE FORCE 710M and Intel HD graphics 4000. (latest drivers)
I can choose witch graphic card run with a program.
Both of theses cards can't run OpenGL

If I use the Intel card, the flickering problem is present

If I use the NVidia graphic card, the flickering problem is away.

It doesn't matter if Hardware acceleration is enabled or not.

But Hardware if acceleration is disabled I've no anti-aliasing problem, and some other animation problems are gone away.
Comment 10 Kev 2019-02-28 07:19:32 UTC
Seeing this on the following system:

Linux Mint 19
Kernel Linux 4.15.0-45-generic x86_64
MATE 1.20.1
Intel® Core™ i5-4210U CPU @ 1.70GHz × 4 
Intel HD 4400 Graphics

This flicker happens consistently (although more with the flicker in the middle of the fade, rather than right before the end) on both of the following LibreOffice Impress versions:

Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

I've also tried the screen tearing advice here: https://forums.linuxmint.com/viewtopic.php?f=208&t=224942#p1197049  But that didn't make any difference in this case.

FWIW, this problem is also in the latest version of Apache OpenOffice Impress.

Could anyone point me to an archive of an older Impress version that didn't have this trouble?  Unfortunately my laptop only has the one video card, so I have no way of switching to nVidia or any other non-Intel graphics chipset.
Comment 11 Kev 2019-02-28 07:38:06 UTC
Found it at https://downloadarchive.documentfoundation.org/libreoffice/old/ and tried it out.

Result: I couldn't actually try it out.  Launching Impress results in the splash screen coming up for such a brief amount of time that I couldn't even capture it with Peek: https://unix.stackexchange.com/questions/503500/running-an-old-version-of-libreoffice

Since I would like to use this for a production-quality video, I guess I'm out of options until this is fixed...aside from switching to Google Slideshow, which does fade transitions without trouble on the same system.  :/

Isn't there some flag I can use somewhere to revert to the old behaviour?
Comment 12 Lars Jødal 2020-10-08 14:58:15 UTC
I experience the same flickering. Strangely, however, that is something I have only seen after switching the 7.0.x versions, and only on my stationary computer, not my laptop (both running upgraded versions of Win10).

User profile reset has not changed anything, and OpenGL on/off does not change it.

For what it's worth, here is version information:

Version: (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: da-DK (da_DK); UI: en-GB
Calc: threaded
Comment 13 Rafael Lima 2020-11-06 17:44:14 UTC
Unfortunately I have been experiencing this problem since at least one year now.

It seems to be a Gnome/Gtk related thing. When I use Ubuntu or PopOS (both Gnome) the flickering problem always happens.

However, if I use Kubuntu on the exactly same machine the problem disappears.

I've tested it in Ubuntu/Kubuntu 19.10, 20.04 and 20.10. On Kubuntu it works and on Ubuntu the problem is there.
Comment 14 dldld 2022-08-07 11:23:49 UTC
This bug might be fixed by https://bugs.documentfoundation.org/show_bug.cgi?id=91456
Comment 15 Lars Jødal 2022-08-29 18:59:22 UTC
Well, I am unable to reproduce the bug now, but I have not yet upgraded to 7.4.0, still running this version:

Version: (x64) / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: da-DK (da_DK); UI: da-DK
Calc: CL

Anyway, if the bug is gone for other people, too, then it is not very important whether it was by the fix mentioned or something else!

Can anybody reproduce the bug with a recent (7.3.5 or 7.4.0) version?
Comment 16 Lars Jødal 2023-01-30 05:47:28 UTC
I cannot confirm the bug any longer with LO

Version: (x64) / LibreOffice Community
Build ID: 85569322deea74ec9134968a29af2df5663baa21
CPU threads: 8; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: da-DK (da_DK); UI: da-DK
Calc: CL