Bug 99685 - Slides are flashing buffer of prior slide at the end of "Fade" transition, or end of "Fine Dissolve" transition
Summary: Slides are flashing buffer of prior slide at the end of "Fade" transition, or...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected) rc
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: bibisected, regression
: 113556 115210 116443 133739 (view as bug list)
Depends on:
Blocks: Slide-Transitions
  Show dependency treegraph
Reported: 2016-05-04 22:04 UTC by roumanet
Modified: 2022-06-29 03:38 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:
Regression By:

Presentation used for this bug (747.04 KB, application/vnd.oasis.opendocument.presentation)
2016-05-04 22:04 UTC, roumanet
MainPC configuration hardware/software (2.05 KB, text/plain)
2016-05-07 17:35 UTC, roumanet
test document using Focus template -- showing the "flash" of prior buffer at end of transition (20.79 KB, application/vnd.oasis.opendocument.presentation)
2016-12-04 15:09 UTC, V Stuart Foote

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2016-05-04 22:04:48 UTC
Created attachment 124847 [details]
Presentation used for this bug

I'm using the following presentation.
I've set the fading transition (in french : fondu) on all slides

I'm using a laptop computer HP4740s (with Intel+Radeon graphic system) under Windows 10.

When I launch my presentation, each slide has a remanent previous slide flashing : it's very curious and I can't snapshot it with internal software (like NCH Debut)... but I've used my phone with slowmotion function and I've got it !

Video is 7 seconds (20 Mo) but it happens at 6 seconds. Hope to give enough proof to help you, guys.
The link for the video is : http://david.roumanet.free.fr/BTS_2015/20160504_234409.mp4

PS : this bug is probably linked with other bug but I'm not sure (5.2 has corrected a lot of problem with transitions and colors fading that went wrong while fading but flashing still there and Linux users seems to be not impacted, so I suspect some graphical properties of Windows. My PC isn't modified, you can use it reference to see the graphic card).
I use dual screen (with many screen or videoprojector) and I've the same problem.
Comment 1 roumanet 2016-05-04 22:05:34 UTC
PC characteristics (Piriform Speccy)

Monitor 1
	Name	Generic PnP Monitor on Intel HD Graphics
	Current Resolution	1600x900 pixels
	Work Resolution	1474x900 pixels
	State	Enabled
	Multiple displays	Extended, Primary, Enabled
	Monitor Width	1600
	Monitor Height	900
	Monitor BPP	32 bits per pixel
	Monitor Frequency	60 Hz
	Device	\\.\DISPLAY1\Monitor0
Monitor 2
	Name	DELL E1910 on Intel HD Graphics
	Current Resolution	1440x900 pixels
	Work Resolution	1440x900 pixels
	State	Enabled, Output devices support
	Multiple displays	Extended, Secondary, Enabled
	Monitor Width	1440
	Monitor Height	900
	Monitor BPP	32 bits per pixel
	Monitor Frequency	60 Hz
	Device	\\.\DISPLAY2\Monitor0
Intel HD Graphics
	Manufacturer	Intel
	Model	HD Graphics
	Device ID	8086-0156
	Revision	A
	Subvendor	HP (103C)
	Current Performance Level	Level 0
	Driver version
		Count of performance levels : 1
			Level 1 - "Perf Level 0"
ATI AMD Radeon HD 7650M
	Manufacturer	ATI
	Model	AMD Radeon HD 7650M
	Device ID	1002-6841
	Subvendor	HP (103C)
	Current Performance Level	Level 0
	GPU Clock	0,0 MHz
	Driver version	15.201.1301.0
		Count of performance levels : 1
			Level 1 - "Perf Level 0"
Comment 2 roumanet 2016-05-04 22:07:35 UTC
Even without dual screen it flash between slides.
Comment 3 Buovjaga 2016-05-06 14:18:08 UTC
What is this setting in your LibO: Tools - Options - LibreOffice - View - Use OpenGL for all rendering?

Change back to UNCONFIRMED after you have provided the information.
Comment 4 roumanet 2016-05-07 09:38:14 UTC
My LO is in french but it should be :
[X] Use hardware acceleration
[X] Use smoothing
[X] Use OpenGL for all rendering (after restart)
   [ ] Force OpenGL even if in blacklist (after restart)

I've tried with all these options uncheck (close and restart LO 5.2 alpha1) and problem (flash) still occurs.
A strange thing happens during transition : the flash bug is visible on the 2 screen when in dual screen mode (one for videoprojector or LCD screen, second for the LO control screen too, with chronometer, next slide, etc.)
Comment 5 roumanet 2016-05-07 16:09:36 UTC
By the way, tested with Version:
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
Threads CPU : 2; Version de l'OS :Windows 6.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR)

and same problem.
Comment 6 V Stuart Foote 2016-05-07 16:48:53 UTC
You HP laptop has two graphics chips, the AMD chip and driver is not black listed but the driver for the Intel GPU is too old.

With three levels of support OpenGL, GPU accelerated, or just CPU driven graphics you get notably different rendering quality/speed of the UI.

Can you update the Intel GPU driver and see if you actually have OpenGL enabled?

Otherwise, does your laptop (and MS Windows) allow you force all graphics onto the AMD GPU? Or to force a specific program (soffice.exe) onto the discreet GPU? And if so do you get OpenGL and does the visual flash go away?
Comment 7 roumanet 2016-05-07 17:34:36 UTC
I've tried to update them : Intel said that it couldn't update because HP has used modified driver (but finaly, Intel have updated them :
AMD autodetect process said me I've the latest version.
Like you suggest my laptop's hardware is probably the cause of my problem, I've tried to use the same presentation with LO5.2alpha on my main PC.
** The problem still occurs **
The PC configuration is very different : Win7 family premium 64 bits with only one Graphics driver (Radeon HD5570)

So, I think the problem is a part of LibreOffice on Windows and I would still helping you.
Comment 8 roumanet 2016-05-07 17:35:45 UTC
Created attachment 124898 [details]
MainPC configuration hardware/software
Comment 9 V Stuart Foote 2016-05-07 19:38:39 UTC
(In reply to roumanet from comment #8)
> Created attachment 124898 [details]
> MainPC configuration hardware/software

The OpenGL "black list" is done by driver release by chip manufacturer, current code as listed here:


With that driver, your main PC will not run OpenGL unless it is set to forced use.

The Intel driver may or may not function for you now--check with the realtech-VR OpenGL Viewer utility found here: http://www.realtech-vr.com/glview/download.php

Please run that an report back OpenGL support for both the AMD and the Intel GPUs
Comment 10 roumanet 2016-05-07 21:56:37 UTC
Thanks, I understand better :)
My laptop is compatible up to OpenGL 4.0 (no superior)
Extensions du noyau OpenGL
v3.0 (100 % - 23/23)
v3.1 (100 % - 8/8)
v3.2 (100 % - 10/10)
v3.3 (100 % - 10/10)
v4.0 (100 % - 14/14)
v4.1 (0 % - 0/7)
v4.2 (0 % - 0/13)
v4.3 (0 % - 0/23)
v4.4 (0 % - 0/10)
v4.5 (0 % - 0/11)

On the main PC, result is slighty different, up to 4.2 (all tests passed on renderer tests) :
v3.0 (100 % - 23/23)
v3.1 (100 % - 8/8)
v3.2 (100 % - 10/10)
v3.3 (100 % - 10/10)
v4.0 (100 % - 14/14)
v4.1 (0 % - 7/7)
v4.2 (0 % - 13/13)
v4.3 (0 % - 2/23)
v4.4 (0 % - 0/10)
v4.5 (0 % - 0/11)

I can't force OpenGL (no option or dialogbox).
However, why the transition is 90% ok on each host but the previous slide is showed for 5-6 images (attached video is 119fps). Could you explain me what is doing the driver with diplaying this previous slide (look at slow speed : it a kind of transition fading but inverted) ? thanks
Comment 11 roumanet 2016-05-07 22:18:04 UTC
Sorry !!!
MainPC driver update was bad the first time. now, result is slighty different, up to 4.4 (all tests passed on renderer tests) :
v3.0 (100 % - 23/23)
v3.1 (100 % - 8/8)
v3.2 (100 % - 10/10)
v3.3 (100 % - 10/10)
v4.0 (100 % - 14/14)
v4.1 (100 % - 7/7)
v4.2 (100 % - 13/13)
v4.3 (100 % - 23/23)
v4.4 (100 % - 10/10)
v4.5 (90 % - 10/11)
ARB 2015 (0 % - 0/11)

Tested with LO (LO5.2 has hang with XXX violation) : old version with false colors while transition... and flashing images (with previous slide).
See Bug 91456 https://bugs.documentfoundation.org/show_bug.cgi?id=91456
Comment 12 dldl 2016-12-04 07:45:05 UTC
I have this problem on nearly every PC i have used in the last year, where Impress is installed. The graphic cards are from different manufatures (nVidia, Intel, AMD) and Impress was run on different operating systems (Windows 7 and Windows 10 and Ubuntu 16.04, Mint 17). On some configurations the problem is more visible (flashing slower) than on others. On the most configurations it was a complete new installation off the operating system and LibreOffice.
On some configurations Impress is not usable for presentation because the flicker is extremly annoying and other problems exists, like the presentation and the control window is shown on the same monitor. 
I acually use Impress only for presentations which doesn't use any animations, because they do not work correctly in many cases. Deactivating the presenter console, doesn't help. On some configurations the presentation and the animation are displayed on different monitors. For me, the presenting with LibreOffice works only with presentation which I have build around all these problems.
Comment 13 Buovjaga 2016-12-04 09:36:29 UTC
NEW per comment 12.
Comment 14 V Stuart Foote 2016-12-04 14:23:46 UTC
So, taking another look at this on Windows 10 Pro 64-bit with nVidia GPU with current master.

Build ID: 150afc29c951d5fc9c40ff8a72f5178c32383f8c
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-03_01:01:24
Locale: en-US (en_US); Calc: CL

It looks to be a transition issue with a buffer at beginning or end not being cleared.  Not resolved with OpengGL rendering, default GPU or CPU only rendering.

Here are repeatable STR

1. new Impress presentation, use the "Focus" template
2. use the first "your logo here" slide and delete the other 3.
3. replace text wtih "Slide 1111"
4. duplicate slide and change text to "Slide 2222"
5. duplicate slide and change text to "Slide 3333"
6. save without transition
7. play slide show -- no observable "flash"
8. apply a transition to each slide -- "Fade" or "Fine Dissolve" will show
9. play slide show -- the fade or dissolve advances smoothly, but at last frame a momentary show of the prior slide is shown -- in this case change limited to the 1111 -- 2222 -- 3333 text so identifiable.
Comment 15 V Stuart Foote 2016-12-04 15:09:39 UTC
Created attachment 129302 [details]
test document using Focus template -- showing the "flash" of prior buffer at end of transition

sample document for the STR of comment 14

Display the presentation (single monitor or split) and notice the flash of text from buffer of the prior slide.
Comment 16 V Stuart Foote 2016-12-04 16:40:26 UTC
The visible flash of the prior slide buffer was not present in the 5.0.x builds through Version: (x64)
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: en-US (en_US)

But is present in the 5.1.x builds, but I did not check betas or master for 5.1.0. 
Present in Version:
Build ID: ecd3574d51754b043f865cf5bafee286d24db7cc
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US)

For sure on Windows, can't tell with Linux as my VM (Centos 7.2 on Windows VMWare Workstation Host) will not run the Fine Dissolve--but the Fade transition does not flash the buffer.  And unable to check split presentation.
Comment 17 Aron Budea 2017-04-16 16:32:59 UTC
I can reproduce this in Linux (not in Windows), and bibisecting with lo-linux-dbgutil-daily-till51 pointed me to the following range:

This is the same as Xisco's result for bug 106898, a slightly different issue with a flash during slideshows that I reported:
(strangely, I get a different bibisect result for that one)
Comment 18 V Stuart Foote 2017-09-13 18:14:56 UTC
Sample presentation comment 15 still exhibits cache flash at the end of transition.

On Windows 10 Ent 64-bit en-US with nVidia GPU and
Version: (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
Locale: en-US (en_US); Calc: group

the dirty buffer flash occurs with OpenGL, with HA, with with CPU only rendering.
Comment 19 V Stuart Foote 2017-11-01 04:03:36 UTC
*** Bug 113556 has been marked as a duplicate of this bug. ***
Comment 20 Kevin Suo 2017-12-21 04:03:51 UTC
Removing keyword bibisectRequest as it's already bibisected.
Comment 21 Buovjaga 2018-02-13 09:35:13 UTC
*** Bug 115210 has been marked as a duplicate of this bug. ***
Comment 22 roumanet 2018-02-13 11:06:49 UTC
Bug still there LO :
Tested with files attached to the begining.
Comment 23 Buovjaga 2018-03-17 16:37:26 UTC
*** Bug 116443 has been marked as a duplicate of this bug. ***
Comment 24 roumanet 2018-11-21 22:14:51 UTC
By curiosity, I've tested OpenOffice 4.1.6 (new release from this month, 2018-11). It's uncredible but it has no bug on transition like fade to black, light fading, etc.
By the way, it's funny to see the LibreOffice GUI from 2-3 years ago (as OpenOffice doesn't evoluate too much... but maybe this is the way to avoid bugs)

I hope this information could help to bibisect more quickly (this bug is here from more than two years now...)

Comment 25 Buovjaga 2018-11-22 06:05:21 UTC
(In reply to roumanet from comment #24)
> I hope this information could help to bibisect more quickly (this bug is
> here from more than two years now...)

It was already bibisected in comment 17. It's just that the result is a range instead of a specific commit.

You are welcome to join the QA team and learn more about bibisecting: https://wiki.documentfoundation.org/QA/Bibisect

QA team does not avoid bugs - it confronts them fearlessly and knocks them over the head.
Comment 26 roumanet 2019-03-01 16:49:15 UTC
Hey! the bug seems fixed in LO6.2.0.3 (x64)
Could other people check on their presentations?

From my point of view, it's solved (no more blinking or flash at the end of transition).

Thanks to developpers who've worked on it!
Comment 27 roumanet 2019-03-01 16:55:24 UTC
As it's the same bug as Bug 116443, you can close this one (I put it as RESOLVED) but want to know what has been modified in code.
Comment 28 Buovjaga 2019-03-01 17:14:20 UTC
Seems ok with all VCL backends. Gen backend showed some different glitching randomly at times. KDE5 was otherwise hopeless, which is no surprise at this stage of development.

Arch Linux 64-bit
Build ID: d559c28e9e65f3be415ec2e36ee90aa147e65b84
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 March 2019
Comment 29 Mark 2019-03-11 21:46:47 UTC
Still not working for me, in fact the issue is worse it now flashes black lines across the screen for longer and hurts my eyes.
Comment 30 Buovjaga 2019-03-11 22:26:16 UTC
(In reply to Mark from comment #29)
> Still not working for me, in fact the issue is worse it now flashes black
> lines across the screen for longer and hurts my eyes.

Please copy and paste here the contents of your Help - About.
Comment 31 Aron Budea 2019-05-27 02:28:43 UTC
Note that a similar issue is now in 6.3 in Windows with OpenGL enabled (bug 122737).
Comment 32 Buovjaga 2020-06-15 09:50:26 UTC
*** Bug 133739 has been marked as a duplicate of this bug. ***
Comment 33 Telesto 2020-06-28 08:59:11 UTC
Awfully opportunistic here. As this a long standing issue unrelated to Skia, but would nice if this would get resolved for the Skia implementation 
It was broken only in GDI and in a later stadium for OpenGL (bug 122737).
Comment 34 QA Administrators 2022-06-29 03:38:46 UTC
Dear roumanet,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team