Bug 78806 - UI: make filter window expandable
Summary: UI: make filter window expandable
Status: RESOLVED DUPLICATE of bug 49813
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2014-05-17 03:56 UTC by bugquestcontri
Modified: 2015-12-18 10:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of currently too narrow filter window (14.99 KB, image/png)
2014-05-17 03:56 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2014-05-17 03:56:05 UTC
Created attachment 99189 [details]
screenshot of currently too narrow filter window

Problem description: 
When there are entries in Calc cells with more than 20 characters the window is too narrow too see all characters of an entry. Thus, the entries cannot be differentiated 

Example is attached.

Solution and enhancement request:
Make the filter window expandable when needed. 

Ideally with the two lower corner as points to pull horizontally and vertically to allow a very quick optimization of the window size. 

Vertical expansion possibility goes beyond the problem description but a vertical adjustment allows the eye to quickly read up and down.

Current size could be kept as default size; looks good to me.


Operating System: All
Version: 4.2.4.2 release
Comment 1 tommy27 2014-05-17 04:47:02 UTC
seems a valuable enhancement request.
could you please upload a test spreadsheet where I can reproduce that issue in the screenshot? which are the exact menu steps you do to show that window?
Comment 2 Joel Madero 2014-05-21 15:39:34 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform: Ubuntu Linux 14.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Low - not going to be saving a ton of time but still valid request. might be easy to implement (requesting developer evaluation)

Whiteboard Status - NeedDevEval

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Joel Madero 2014-05-21 15:40:35 UTC
To Reproduce: 

1. Open spreadsheet

2. Writer some header in A1 ("test")

3. Write numbers down column A (20 down or so)

4. Select column A

5. Data -> Filter - AutoFilter
Comment 4 bugquestcontri 2014-06-20 14:00:14 UTC
@tommy27 - Reading the comments of Joel Madero I feel there is no need to provide an test file. Beside this my version is only 4.2.4.2.
Comment 5 Adolfo Jayme 2014-10-25 20:08:58 UTC

*** This bug has been marked as a duplicate of bug 49813 ***
Comment 6 Robinson Tryon (qubit) 2015-12-18 10:51:06 UTC
Migrating Whiteboard tags to Keywords: (NeedDevEval -> NeedsDevEval)
[NinjaEdit]