Download it now!
Bug 78815 - Toolbar Formatting - Font Name - no drop-down selection
Summary: Toolbar Formatting - Font Name - no drop-down selection
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium minor
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.3.0 target:4.2.5
Keywords:
: 73188 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-17 09:01 UTC by Dominik
Modified: 2014-05-25 09:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
FontName no selector (195.61 KB, image/png)
2014-05-17 09:01 UTC, Dominik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik 2014-05-17 09:01:29 UTC
Created attachment 99206 [details]
FontName no selector

The selector is drawn as a button, with no visible response when clicking instead of a drop-down selection field as for the font-size.
Comment 1 Jorendc 2014-05-17 09:43:56 UTC
I can confirm this behavior, tested using Windows 8.1 with LibreOffice 4.2.4.2

Steps to reproduce:
* Create a new database (just click through the startup configuration)
* Click on 'Reports' at the left 'sidebar'
* Create report in design view (or something like that)
* Draw a textbox (using on of the icons at the toolbar)
* Select textbox

Easy workaround is to use the right sidebar in tab 'General'. In this setting list, you can change the font type too.

Kind regards,
Joren
Comment 2 Dominik 2014-05-17 10:19:12 UTC
Sure, but this way you need at least twice as much clicks and (at least on low-end HW) it takes 2-3 seconds to open the Character Settings.
Comment 3 Julien Nabet 2014-05-18 19:44:18 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.

I noticed this console logs several times:
warn:legacy.osl:14377:1:svx/source/unodraw/unoprov.cxx:870: [CL] unknown SdrObject identifier
Comment 4 Commit Notification 2014-05-19 06:08:48 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=214de0e5124b44df0f37fdf89271a527667590dc

fdo#78815 Fix report builder toolbox controller



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-05-21 12:57:28 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c16a3cea9845c37b5cc73da44e8a55d6ad30eea&h=libreoffice-4-2

fdo#78815 Fix report builder toolbox controller


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Maxim Monastirsky 2014-05-25 09:15:23 UTC
*** Bug 73188 has been marked as a duplicate of this bug. ***