Download it now!
Bug 78846 - wrong AutoCorrect entries in English default replacement lists
Summary: wrong AutoCorrect entries in English default replacement lists
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.3.0 target:4.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-18 03:54 UTC by Tom Meinen
Modified: 2014-05-18 18:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Meinen 2014-05-18 03:54:27 UTC
Problem description: 

Steps to reproduce:
1. .... Tools ==> AutoCorrect Options
2. .... scroll down to the listings (explained below)

Current behavior: There are two incorrect entries.  1. docuement corrects to documents  2. faetures corrects to feature.  

Expected behavior: Both those autocorrections are wrong.  They should be as follows: 1. docuement corrects to document (not plural)  2. faetures corrects to features. (it is plural)  

Other way to reproduce problem: In a document, simply type "docuement" and "faetures."  You will see that they autocorrect to the wrong thing.  

              
Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 tommy27 2014-05-18 07:32:43 UTC
I confirm those 2 wrong entries in many English subgroups (UK, USA, Australia, SouthAfrica) in Win7x64 as well.

not a new issue since those errors have been shipped in the default english replacement lists from OOo era and affect any subsequent LibO and AOO release.

so version is "inherited from OOo"

those files are under: 
\Bin\LibreOffice 4\share\autocorr

and are:
acor_en-AU.dat (australian english)
acor_en-GB.dat (british english)
acor_en-US.dat (american english)
acor_en-ZA.dat (south african english)

I also see an acor_en-ES.dat which I don't know wich variant refers to.

issue persists in Version: 4.3.0.0.alpha1+
Build ID: a1dd961c3093f5f7624e4d1f2240e9120fd13f23
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-06_11:47:48


@Tom
would you please check if there are other wrong entries so that we fix'em all at once?
Comment 2 tommy27 2014-05-18 07:42:41 UTC
@Joel Madero
I think this bug represent a MAB (most annoying bug) for english users since we ship an autocorrect feature that automatically corrects 2 common typing mistakes in an incorrect way.
Comment 3 Julien Nabet 2014-05-18 16:40:24 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.
Comment 4 Commit Notification 2014-05-18 16:42:07 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9868373a6f6db525e963ec79301ecbd74fbfdeba

Resolves: fdo#78846 wrong AutoCorrect entries



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2014-05-18 16:44:19 UTC
gerrit review for 4.2: https://gerrit.libreoffice.org/#/c/9397/
Comment 6 Commit Notification 2014-05-18 18:44:41 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cacde838a6369cfe9231f0808b76ecedfb87e312&h=libreoffice-4-2

Resolves: fdo#78846 wrong AutoCorrect entries


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.