Download it now!
Bug 78857 - ERROR: Source for bsh.jar not found! when building --with-java=no
Summary: ERROR: Source for bsh.jar not found! when building --with-java=no
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-18 11:45 UTC by Simon Wilper
Modified: 2014-05-20 08:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Wilper 2014-05-18 11:45:42 UTC
In module instsetoo_native the make_installer.pl script throws the errors that the files bsh.jar, js.jar and hsqldb.jar could not be found although I am building --with-java=no.

I checked the file workdir/InstallScriptTarget/setup_osl.ins and found the entries

1590a1591,1604
> File auto_extensions_bsh_jar_bsh
> 	Dir = gid_Dir_Classes;
> 	Name = bsh.jar;
> 	Styles = (PACKED);
> 	UnixRights = 644;
> End
> 
> File auto_extensions_rhino_jar_js
> 	Dir = gid_Dir_Classes;
> 	Name = js.jar;
> 	Styles = (PACKED);
> 	UnixRights = 644;
> End
> 
1679a1694,1700
> End
> 
> File auto_ooo_jar_hsqldb
> 	Dir = gid_Dir_Classes;
> 	Name = hsqldb.jar;
> 	Styles = (PACKED);
> 	UnixRights = 644;

After removing those the build completes just fine, I get an install package that I can unpack and the office runs fine.

So my question is: Did I miss an autoconf option so that the entries don't get in the setup_osl.ins in the first place? How is this file generated an when (in the buildprocess)?
Comment 1 Stephan Bergmann 2014-05-19 08:15:35 UTC
likely caused by the move to scp2/AutoInstall.mk
Comment 2 Commit Notification 2014-05-19 08:30:23 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2dec067928da439dad282de6e084c1ed983836a5

fdo#78857 jars aren't built without java



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Simon Wilper 2014-05-20 08:31:02 UTC
Excellent! That was fast!  Working fine now.