Bug Hunting Session
Bug 78912 - Text autocorrect function does not correct according to the selected language
Summary: Text autocorrect function does not correct according to the selected language
Status: RESOLVED DUPLICATE of bug 76964
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 81398 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-19 14:01 UTC by Eduardo Soares
Modified: 2015-07-31 22:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Exemple of wrong portuguese auto-correction in a spanish document. (14.41 KB, application/vnd.oasis.opendocument.text)
2014-05-20 00:52 UTC, Eduardo Soares
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Soares 2014-05-19 14:01:24 UTC
Problem description: Text auto-correct function does not correct according to the selected language. I'm using the PT-BR version of LibreOffice and I selected the Spanish language for this document. But LO still auto-correcting my text using the Portuguese dictionary.

Steps to reproduce:
1. Use the PT-BR LO
2. Change the language of the document to Spanish
3. After tipping "en" (in Spanish) the LO auto-correct to "em" (portuguese)

Current behavior: Auto-correct "en" to "em"

Expected behavior: Ignore the word "en" (because it's Spanish).
Comment 1 tommy27 2014-05-19 18:24:57 UTC
please upload a test document where you reproduce the bug
Comment 2 Eduardo Soares 2014-05-20 00:52:03 UTC
Created attachment 99365 [details]
Exemple of wrong portuguese auto-correction in a spanish document.
Comment 3 tommy27 2014-05-20 04:23:56 UTC
mhhh... not reproducible under Win7x64 using LibO 4.2.4.2 if I digit "en" and "con" in your test document inside the "spanish" paragraph I see no autocorrection to "em" and "com"

did you check if those "en -> em" and "con -> com" autocorrect entries have been erroneously been entered in the spanish replacement list or in the [All] replacement list?

click "Tools/AutoCorrect options/Replace" then select "Spanish (spain)" and dig trough the autocorrect lists. If there's nothing there, do the same in the "[All]" list which is at the very top of the dropdown menu.

other thing you can do is to reset the user profile (backup first).
instructions here: https://wiki.documentfoundation.org/UserProfile

please also give exact informations about your Linux distro
Comment 4 resetlanguagebutton 2014-05-25 21:59:22 UTC
This language bug exist since I can think in (OpenOffice and) LibreOffice. The problem is that once a text is set to a specific language, you cannot reset it.

You can (re)set it but only if you explicitly mark that text and change the language.

Changing the default language does not RESET (not set) element-specific language settings.

I am facing the same (stupid) behavior right now. I have to set text element by text element slide by slide manually. This annoys me!

My proposal to eliminate this bug:

Invent a button that RESETS/ELIMINATES (not sets) all language specific settings of any document element!

There exists already such a button (File -> Properties... -> General -> Reset), but the reset does not affect the language.
Comment 5 sophie 2014-06-04 14:47:02 UTC
Hi, I could not reproduce, but there is something unclear for me: you're speaking about LO using Portuguese dictionary and you also speak about AutoCorrect options. This is two different features. So as Tommy said, check the right setting of the language in the replacement table. But also check that you have the Spanish dictionary activated under Format > Character > their should be a blue check in front of Spanish in the language list. Thanks. Set as Needinfo as both of us are not able to reproduce. Using version 4.2.4.2 under Ubuntu 14.04.
Comment 6 smeyer 2014-10-01 13:21:00 UTC
I have the same error here
Comment 7 smeyer 2014-10-01 13:25:09 UTC
I have Libreoffice version 
I have version: 4.2.6.3 on Linux. I use English UK as the User Interface Language. I have Danish as the default for documents. I have marked all text and chosen Danish as the language. When I look at the properties of the text, it is marked as being danish in the language field.

When I type a small i it will be autocorrected to capital I. It uses the english autocorrect list even though document language settings are danish by all means. If I delete that entry in the english autocorrect list it will not do it anymore, but I also write english documents...

I don't know if it is related, but in Tools - Langauge, danish is marked for 'selection' but not for 'paragraph' or 'All text' no matter how many times I mark it.

This have existed for a long time - across many versions, but not allways.
It seems to me that Bug 81398 is about the exact same thing.
Comment 8 tommy27 2014-10-01 14:34:33 UTC
(In reply to comment #6)
> I have the same error here

set status to NEW because of independent confirmation.
Comment 9 tommy27 2014-10-01 14:36:22 UTC
*** Bug 81398 has been marked as a duplicate of this bug. ***
Comment 10 kreska07 2014-10-09 13:20:08 UTC
Hello,

I have the same problem.
Comment 11 sophie 2014-10-09 14:56:38 UTC
Hi, so to make sure, there is two different things:
- if you want to have the Danish Autocorrection replacement table working, you have to set Danish under Tools > Options > Language Settings > Language > Locale Settings.
- if you want to use the Danish spellchecker, you set it as a character setting in the Character or Paragraph dialogs.
Setting the language at the character level will not change the Replacement table in the Autocorrection options. Could you check that your locale settings in the linguistic options is on Danish? thanks - Sophie
Comment 12 Björn Michaelsen 2014-11-28 09:42:21 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 13 Urmas 2014-11-28 12:25:31 UTC
Apparently you are trying to type in Spanish with Portuguese keyboard.
Comment 14 Eduardo Soares 2014-11-28 13:02:15 UTC
Yes, I'm trying to type in Spanish with Portuguese keyboard. But I do the same thing with Microsoft Office without any problems. The problem is only with LibreOffice.
Comment 15 Valerio 2014-12-20 23:56:48 UTC
Hi gents and ladies,
I would like to add my observation to this bug that afflict me as well.

LO version: 3.4.5 installed through Libreoffice website packages.

My keyboard layout: Italian (IT)
My LO user interface: English (USA)
My LO locate settings: Italian (it)
My LO default languages for documents: Italian
My actual document language: Italian

In the autocorrect option window I see:
"Replacements and exceptions for languages: Italian"
If I check the words in the "Replace" tab, they are all italian, in the "word Completion" tab, they are all italian... so everything looks good.

In fact, in the list of the autocorrections word, there is not i -> I, however, if I write "i" in my document and then push the spacebar, that "i" became "I", I need to push Ctrl+Z to reverse the modification, every time. That correction has no sense in the italian language, it is clearly part of the english autocorrection rules.

I tried to download and install the italian language pack, but nothing change.
I tried also to switch the UI in italian, but still the "i" is autocorrect in "I".
I tried to enable the option "Ignore system input language", but nothing change.

Regards,
Valerio
Comment 16 josiasmat 2015-01-29 11:59:08 UTC
In can confirm this bug. Running LibreOffice 4.0.0.3 on Windows 8.1 x64.
Because I write in both Portuguese and Spanish frequently, I know it's VERY annoying. I think this is a CRITICAL bug.
Comment 17 tommy27 2015-06-18 22:26:56 UTC
please give update of the bug current status using latest LibO 4.4.3.2 release
Comment 18 tommy27 2015-07-31 22:36:18 UTC
the root of the bug is that 2 different languages are used as "Locale" and "Default Document Language" and the Locale autocorrections are applied to documents using the Default Document Language

*** This bug has been marked as a duplicate of bug 76964 ***