Bug 78982 - EDITING: Copying formulas upward by dragging deletes content.
Summary: EDITING: Copying formulas upward by dragging deletes content.
Status: RESOLVED DUPLICATE of bug 81803
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-05-20 19:54 UTC by Jim Avera
Modified: 2014-07-31 18:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Demo spreadsheet (24.31 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2014-05-20 19:54 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2014-05-20 19:54:22 UTC
Created attachment 99441 [details]
Demo spreadsheet

Problem description: If a formula cell is selected and the border dragged up or down over multiple columns, and the covered cells are empty, then the formula is not pasted into the cells.  However if the border is dragged only over a single adjacent cell (in the previous or following row), then it works.

This is a regression from 4.2.5.0.0

Steps to reproduce:
1. Open the attached "FormaulaCopyProblem.ods" file
2. Select E7 and drag the box up to cover E1 through E6

Current behavior: Nothing happens

Expected behavior: The formula in E7 should be copied into E1:E6 with appropriate relative-address adjustments.


              
Operating System: Ubuntu
Version: 4.2.4.2 release
Comment 1 Jim Avera 2014-05-20 19:58:24 UTC
Version: 4.3.0.0.alpha1+
Build ID: fc974a4028fcc14304be85f36f5b15524beff5e4
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-05-18_04:57:34
Comment 2 Jim Avera 2014-05-20 20:03:53 UTC
What's the deal with the "Version" field?

Bugzilla says that "Version" is supposed to be the earliest version known to contain the bug.  However bug-assistant at https://www.libreoffice.org/get-help/bug/ seems to use a different convention: It sets Version in the bug to the "Latest Known Working Version" (as input to the assistant), and apparently ignores the "Version the Bug Appeared".
Comment 3 m.a.riosv 2014-05-20 20:38:30 UTC
Hi Jim, thanks for reporting.

Reproducible only dragging to top.
Win7x64Ultimate
Version: 4.3.0.0.alpha1+ Build ID: 48eccfb812284f43ba24c3be3903537ce954944d
   TinderBox: Win-x86@39, Branch:master, Time: 2014-05-16_00:35:19

Works for me with:
Version: 4.2.5.0.0+ Build ID: d758875cd0ea87f8c7bbe1bbb78e49d06254cbee
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-05-17_04:23:54
Comment 4 Kohei Yoshida 2014-05-22 15:19:39 UTC
It actually deletes contents in the destination range.
Comment 5 Eike Rathke 2014-05-27 18:15:45 UTC
Deleting content when drag-selecting upwards has been a long standing feature and comes in handy when having dragged down some cells too far. The help tip even says so. 4.2.x and apparently 4.1.x have some funny magic if and how cells were select before drag-selecting upwards, and then it either copies or deletes cells, I'm not sure users will understand that anyway..
Comment 6 Dominik 2014-06-11 20:31:09 UTC
i've discovered this today and would say its a regression. as it doesn't implement a new function but changes how a existing works, i'd say: undo this.

if you dragged too far, just mark the range and delete the content, no need to change something that works.
Comment 7 Markus Mohrhard 2014-07-31 18:46:36 UTC

*** This bug has been marked as a duplicate of bug 81803 ***