Bug Hunting Session
Bug 79007 - FILEOPEN PPTX Shapes with washout mode are not displayed
Summary: FILEOPEN PPTX Shapes with washout mode are not displayed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1 all versions
Hardware: Other All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2014-05-21 09:14 UTC by Vipin
Modified: 2019-10-15 12:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
AS requested attached a sample (73.85 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-05-28 05:27 UTC, Vipin
Details
pptx with Graph (42.37 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-06-11 11:00 UTC, Vipin
Details
LO 4.2.4.2 (13.51 KB, image/png)
2014-06-11 14:18 UTC, ign_christian
Details
Expected result from PowerPoint (30.08 KB, image/jpeg)
2019-09-27 17:50 UTC, Buovjaga
Details
Color modes not supported for pptx export (58.63 KB, application/vnd.oasis.opendocument.presentation)
2019-09-30 16:43 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vipin 2014-05-21 09:14:13 UTC
A microsoft powerpoint presentation with pictures does not appear correctly in the LibreOffice viewer, here's a screenshot
1. As it appears in Powerpoint - http://goo.gl/aZp2CY
2. As it appears in LibreOffice - http://goo.gl/7r0yfE (notice the images are lost)

Please suggest.
Operating System: All
Version: 4.2.4.2 release
Comment 1 Firas Hanife 2014-05-27 19:30:51 UTC
Hi Vipin,
Thanks for the report

If you can attach a document to test with, it would help a lot in finding and resolving the issue.
Comment 2 Vipin 2014-05-28 05:27:36 UTC
Created attachment 99998 [details]
AS requested attached a sample
Comment 3 Julien Nabet 2014-05-30 21:41:32 UTC
On pc Debian x86-64 with LO Debian package 4.2.4, I can reproduce this but with 4.2 sources updated 2 days ago, I don't reproduce this.

For the test, could you give a try to 4.2.5.RC1  (see http://www.libreoffice.org/download/libreoffice-fresh/?version=4.2.5)?
Comment 4 Vipin 2014-06-11 11:00:26 UTC Comment hidden (off-topic)
Comment 5 ign_christian 2014-06-11 14:18:14 UTC
Created attachment 100880 [details]
LO 4.2.4.2

I can reproduce with slightly different result (please see attachment). Tested with Ubuntu 12.04 x86 - LO 4.2.4.2.

@Vipin, please inform your OS & what kind of image that not appear (png, gif, svg, etc) ?
Comment 6 ign_christian 2014-06-11 14:26:34 UTC Comment hidden (off-topic)
Comment 7 Joel Madero 2014-06-15 17:59:01 UTC Comment hidden (obsolete)
Comment 8 Vipin 2014-06-16 04:44:08 UTC Comment hidden (off-topic)
Comment 9 Joel Madero 2014-06-16 05:11:35 UTC Comment hidden (obsolete)
Comment 10 sophie 2014-06-18 12:31:25 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2018-04-10 18:56:25 UTC
This issue is still reproducible in master.
Putting back to NEW as it's a dupe of an INVALID issue...

Version: 6.1.0.0.alpha0+
Build ID: 0a4c1fb68c3619e61099a7c548f550b0d3fd7a53
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 12 QA Administrators 2019-04-11 02:57:46 UTC Comment hidden (obsolete)
Comment 13 Buovjaga 2019-09-27 17:50:59 UTC
Created attachment 154604 [details]
Expected result from PowerPoint
Comment 14 Buovjaga 2019-09-27 17:56:21 UTC
Still confirmed and already in 3.3.0. The problem is the shapes have no colour and thus cannot be seen. You can quickly make the outlines visible by selecting them and giving them a fill colour.

The off-topic chart issue is no longer a problem, I marked related stuff as off-topic/obsolete here.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: e1b51d4588b4b39592bb94dd5bb90de5e04d061e
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-23_09:16:11
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 15 Buovjaga 2019-09-27 18:19:50 UTC
(In reply to Julien Nabet from comment #3)
> On pc Debian x86-64 with LO Debian package 4.2.4, I can reproduce this but
> with 4.2 sources updated 2 days ago, I don't reproduce this.

I was intrigued by this, so I tested with Win 4.3 bibisect repo: indeed, the oldest shows the problem, but the latest does not! This is the commit that made it work OK:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/893fe88469dec5b727d96f8ea1b4edb9e88288a7%5E!/
handle brightness+contrast from msoffice (bnc#875713)

Maybe it got reverted afterwards (could not find evidence quickly).
Comment 16 Xisco Faulí 2019-09-30 14:59:32 UTC
(In reply to Buovjaga from comment #15)
> (In reply to Julien Nabet from comment #3)
> > On pc Debian x86-64 with LO Debian package 4.2.4, I can reproduce this but
> > with 4.2 sources updated 2 days ago, I don't reproduce this.
> 
> I was intrigued by this, so I tested with Win 4.3 bibisect repo: indeed, the
> oldest shows the problem, but the latest does not! This is the commit that
> made it work OK:
> 
> https://gerrit.libreoffice.org/plugins/gitiles/core/+/
> 893fe88469dec5b727d96f8ea1b4edb9e88288a7%5E!/
> handle brightness+contrast from msoffice (bnc#875713)
> 
> Maybe it got reverted afterwards (could not find evidence quickly).

Let's make it a regression then...
It's fine in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8

and bad in


Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

thus, it needs to be bisected with 5.1 repo
Comment 17 Xisco Faulí 2019-09-30 15:23:46 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d151ed35ad4c4e7aa9fbb807930fcf91dea2eba7

author	Joren De Cuyper <jorendc@libreoffice.org>	2015-06-02 22:26:29 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2015-07-15 23:44:01 +0000
commit	d151ed35ad4c4e7aa9fbb807930fcf91dea2eba7 (patch)
tree	cc1c0e8d966608ee2b0581d8d2854f88fa54995d
parent	e51fa143587d018b75db08e60cf27ff932b1cf8d (diff)
tdf#87539 map MSO washout filter to LO's watermark colormode

Adding Cc: to Joren De Cuyper
Comment 18 Xisco Faulí 2019-09-30 15:46:40 UTC
The problem is that d151ed35ad4c4e7aa9fbb807930fcf91dea2eba7 maps nBrightness == 70 && nContrast == -70 to watermark, so if we are so unlike to have an image with those properties, it's a watermark for LibreOffice
Comment 19 Xisco Faulí 2019-09-30 16:43:15 UTC
Actually it might not be a regression, but a lucking feature. Bug 87539 added support for exporting images modes ( watermark, black/white, grayscale )...
LibreOffice doesn't support it for pptx export
Comment 20 Xisco Faulí 2019-09-30 16:43:49 UTC
Created attachment 154658 [details]
Color modes not supported for pptx export
Comment 21 Xisco Faulí 2019-09-30 17:57:14 UTC
How to reproduce it from scratch:
1. Go to powerpoint
2. Insert an image
3. Menu - Color - Recolor - Washout
4. Saved as .pptx
5. Open it in LibreOffice
Comment 22 Xisco Faulí 2019-09-30 19:54:02 UTC
So I did a couple of tests to verify the feature is missing in impress.
1. a DOCX file with a washout image is correctly imported in Writer with watermark mode
2. Changing https://opengrok.libreoffice.org/xref/core/oox/source/drawingml/fillproperties.cxx?r=09cd0e36#762 to eColorMode = ColorMode_STANDARD; and https://opengrok.libreoffice.org/xref/core/writerfilter/source/dmapper/GraphicImport.cxx?r=7a1bf5c1#1324 to if( m_pImpl->eColorMode == drawing::ColorMode_STANDARD && opens the washout image as standard in Writer. nothing is displayed in Impress
Comment 23 Xisco Faulí 2019-09-30 21:09:08 UTC
I have a fix for this, working on a unittest.
I'll create a follow-up bug for the export part...
Comment 24 Commit Notification 2019-10-01 22:15:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/727ca36e83868acbe40aaa239cefc69659b9bc39

tdf#79007: PPTX: reset Contrast and Brightness when we map...

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Buovjaga 2019-10-02 11:13:00 UTC
Verified, fantastic to have this oldie fixed!

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: cb5eaa791739865d54b381c16c60224c432171dc
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 2 October 2019
Comment 26 Commit Notification 2019-10-15 12:33:33 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/4b8415616071ec74e21040369d5dd1a9496db71d

tdf#79007: PPTX: reset Contrast and Brightness when we map...

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2019-10-15 12:33:41 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9270f74466d0eb841babaa24997f608631c70341

tdf#79007: Do not overwrite if only one of nBrightness...

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.