Bug 79077 - No option to make File > Print > Options > "Use only paper size from printer preferences" stick
Summary: No option to make File > Print > Options > "Use only paper size from printer ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
: 89180 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-22 16:23 UTC by Charles
Modified: 2019-06-11 20:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2014-05-22 16:23:02 UTC
There is currently no way to make this preference (in Summary) 'stick', it must be manually selected each time you print.

The reason this is currently very important is because this is the only way to work around bug 65205 concerning LibreOffice's inability to print properly to 'Tabloid' size paper on Windows:

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=65205
Comment 1 Cor Nouws 2014-05-22 17:40:14 UTC
Hi Charles,

thanks for reporting. I agree this would be a useful possibility to have in Tools > Options > Writer > Printing.
The other options are already there.
Cheers,
Cor
Comment 2 tmacalp 2015-01-06 19:57:00 UTC
I too would love to have this setting saved.  But it needs to be improved in a number of ways :

1. Implement a way to set this as the default for LO in options, as comment 1 suggests.

2. At least remember this setting during a session.  Currently, as soon as you hit print, the setting is disabled again.

3. Save this print setting in the odt.  If this setting is required to make LO do something as fundamental as actually obey the print dialog's paper size/orientation, it should be remembered with the document's printer settings.

Also, "Use only paper size from printer preference" needs to be relocated to the Properties dialog, next to "Paper size" and "Orientation."  And those fields need to be greyed out unless the box is checked.  That would make it obvious that LO is completely ignoring the user's explicit settings in favor of the page format.
Comment 3 tmacalp 2015-09-18 16:02:15 UTC
*** Bug 89180 has been marked as a duplicate of this bug. ***
Comment 4 Cor Nouws 2015-09-18 17:33:05 UTC
There is a recent discussion on the UX-list
  http://listarchives.libreoffice.org/global/design/msg07254.html

The latter mails have some sort of summary. But reading this and 65205 again, not the final ;)

That discussion focuses more changing page orientation. But making the option clearer, is one of the ideas. The idea of this bug report, is an addition.
Comment 5 Justin L 2016-08-12 17:13:25 UTC
The "use only paper size from printer preferences was introduced:
author Caolán McNamara <caolanm@redhat.com> 2013-05-20 10:26:20 (GMT)
commit	f937ef20f57b306191f7583c2d47b5ad3f2a73ee
https://cgit.freedesktop.org/libreoffice/core/commit/?id=f937ef20f57b306191f7583c2d47b5ad3f2a73ee
Related: fdo#61186 add a toggle to override the paper format
Comment 6 Justin L 2016-08-16 11:40:25 UTC
Here are two different possible approaches to the same fix (simply keeping the papersize setting sticky). Both have the failing that cancelling the dialog doesn't discard the change (matching the behaviour of existing options).
https://gerrit.libreoffice.org/28163 
https://gerrit.libreoffice.org/28160 - old-style dialog code used
Comment 7 Commit Notification 2017-12-20 11:33:49 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=75fc4934c3aafcd83d9bbee63d8d24cbddae8ea0

tdf#79077: copy 'paper from printer setup' toggle

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-12-20 12:54:37 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=45429e4518fb265dc817d96f41ad4238a5d09c65

tdf#79077: Cleanup PapersizeFromSetup related code

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-12-20 12:54:45 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a07477790204c9392a31d5060ecb5478b7c001c6

tdf#79077: Load/save PapersizeFromSetup bit into ODF for sd

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-12-21 09:47:26 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=785a8564ebb501e2e623133e214467b947f7e671

tdf#79077: Load/save PapersizeFromSetup into ODF for sw and sc

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-12-22 08:24:52 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2113282cf957943d08999e7c7071a76734cf2c00

tdf#79077: Mildly improved user experience

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-01-10 17:07:08 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a50357ded3293bda08b9a68b53ee71164cd49a1

tdf#79077: Harmonize PapersizeFromSetup checkboxes in printer config

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2018-02-12 18:45:31 UTC
A polite ping to Katarina Behrens: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 14 Katarina Behrens (CIB) 2018-02-19 17:00:55 UTC
IDK if this bug is really fixed, I did some due diligence and it certainly is fixed for me, but that may not be the case for someone else

Since some time, I'm extremely reluctant to close bugs as fixed, since every time I do, someone pops up and complains about (sometimes more, sometimes less) tangential things that are not fixed. So I can as well spare me the effort
Comment 15 tmacalp 2018-02-19 20:23:00 UTC
Thanks for the commit, I really like it!  I think it's much more intuitive and will clear up a lot of confusion!

I tested it in the nightly from this morning:
Version: 6.1.0.0.alpha0+
Build ID: bd22f1be6739c9d90e129e5b094206157893c030
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: x11; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-02-19_10:44:44
Locale: en-US (en_US.UTF-8); Calc: group

It's EXTREMELY minor, but setting "Options->Use only paper size" modifies "General->Properties->Paper->Use only paper size", but the reverse isn't true.  So, if you go out of your way to try to break it, you can get into a state where the two checkboxes are out of sync.  Of course, this weirdness only persists as long as the print dialog is up.  Also, the preview window gives accurate feedback by showing the correct page size when the option is toggled.  The state is correctly retained through the session and is saved with the document.

Again, this makes me very happy.  :)
Comment 16 Adolfo Jayme 2018-03-15 09:37:13 UTC
VERIFIED per previous comment; additional quirks can always be filed as follow-up bugs.
Comment 17 Josh G 2018-08-07 02:20:19 UTC
I don't really see how this is fixed. I still have no way to make this setting stick that I can see. As per comment 1, the option for globally setting the paper tray from print settings is stored at Tools -> Options -> LibreOffice Writer -> Print and works exactly how I would expect a similar option to set the paper size to obey the same way.

My problem is this: I have a computer that regularly prints 4x6 cards from a bypass tray on a large printer. Without that setting checked, it refuses to obey a 4x6 paper size, despite it being the document page size *and* a paper size set in the printer properties itself that it should be using. It forces the page to 6x11. And the users are not easily trained to go check an option that should, by either page size auto-detection or the printer property defaults, already be using. It's counter-intuitive.

I am using the daily 6.1.1 Windows build to test, but I've looked at the 6.1.0 build as well and don't see it there, either.
Comment 18 Misha 2019-06-11 20:50:34 UTC
This is still not fixed, as there is no way to make this preference persistent for all printers and documents.
It definitely should be in global Print settings, not just in the print dialog.
Please, reopen this bug as not fixed.