Bug 79124 - Options dialog text shift down when "measurement unit" listbox clicked.
Summary: Options dialog text shift down when "measurement unit" listbox clicked.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: high minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0
Keywords: bibisected, regression
: 79394 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-23 14:11 UTC by Akira Matsumiya
Modified: 2015-12-17 08:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The Options Dialog after 20 clicks. (109.34 KB, image/png)
2014-05-23 14:11 UTC, Akira Matsumiya
Details
The Options Dialog after 20 clicks. (109.34 KB, image/png)
2014-05-23 14:13 UTC, Akira Matsumiya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Akira Matsumiya 2014-05-23 14:11:26 UTC
Created attachment 99639 [details]
The Options Dialog after 20 clicks.

How to reproduce

1. Create New Text Document
2. tools > options > LibreOfficeDev Writer > General 
3. Settings > Mesurement unit 
4. The dialog text shift down when "measurement unit" listbox clicked.

Attached image is the state of the dialog after 20 clicks.
Comment 1 Akira Matsumiya 2014-05-23 14:13:14 UTC
Created attachment 99640 [details]
The Options Dialog after 20 clicks.
Comment 2 Joel Madero 2014-05-24 21:16:47 UTC
Confirmed:

Ubuntu 14.04 x64
LibreOffice 4.3 beta1

Works fine in LibreOffice 4.2.4.2 release

NEW
Minor - not going to really affect ability to produce high quality work but looks pretty awkward with it shifting every click
High - regression + makes LibreOffice look less professional


regression
Comment 3 Joel Madero 2014-05-24 21:29:48 UTC
5ad42e6e2be772d6e3f5793758dda469d42ed63e is the first bad commit
commit 5ad42e6e2be772d6e3f5793758dda469d42ed63e
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed May 21 08:57:55 2014 +0000

    source-hash-1b8cfd5d1414da9127ff18e4701b40f5bceabb36
    
    commit 1b8cfd5d1414da9127ff18e4701b40f5bceabb36
    Author:     Markus Mohrhard <markus.mohrhard@collabora.co.uk>
    AuthorDate: Tue May 20 23:59:55 2014 +0200
    Commit:     Markus Mohrhard <markus.mohrhard@collabora.co.uk>
    CommitDate: Wed May 21 01:50:44 2014 +0200
    
        remove unnecessary whitespaces
    
        Change-Id: I4d93c0149aaf90e2477c1382aa51f8f08c967626

:100644 100644 501fbfa427b8a231fe035cd8c6c9861d0483e887 03ad3b133ed354d5ab45bdc712a5355013402c17 M	ccache.log
:100644 100644 94e1769dda5ee27e4952754e43c4d26fe19c2009 e900cb9aba87ebf78801bd60b03866aab0460fac M	commitmsg
:100644 100644 8c966b034e7c757c8922b3ba931bd93077f23e64 b8dc772fd79ceee78f8854fb2bdf577904e75049 M	make.log
:040000 040000 5f3414102b71bcb5a2c7f817d6502959169c4345 291f8ca8cacce30d162bc70628131b1a960519bb M	opt


# bad: [a92705c1fabafddd43d175a0714855cd22551232] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [6ab7f53af36f13bbefdd4e4fcbd3d1ea432a77d9] source-hash-22029c7e17b4cb48acb058d47ec9c3b6b8b6b294
git bisect start 'latest' 'oldest'
# good: [bebf9d31c8fe9de96798484288a0fffc4d54917d] source-hash-09e5de8278dd8f13adcf614db35c8a8a04ba8e47
git bisect good bebf9d31c8fe9de96798484288a0fffc4d54917d
# good: [fac643700ecfabc737836bbed068776f34037d53] source-hash-40a61d93ade494fa98c23a9fd8776c8dadf8f30f
git bisect good fac643700ecfabc737836bbed068776f34037d53
# good: [44e392733ca46fb0fde9664f8b33ff4da5295caa] source-hash-062e69f40b749aa8a6058c3e6ca328af86aeb45b
git bisect good 44e392733ca46fb0fde9664f8b33ff4da5295caa
# good: [f97af5a6db933cb14cc482cea5aea50200e5035b] source-hash-94e3f3e5015e53b5f3c8e5775b668e0bc12ab457
git bisect good f97af5a6db933cb14cc482cea5aea50200e5035b
# good: [186a367d51c464e467b46ef7612ff14940b9b084] source-hash-6f019bea96e93c127ccd695d381647b48d06d710
git bisect good 186a367d51c464e467b46ef7612ff14940b9b084
# good: [790bc86e8c522b4456d84f3eb54a89033e80513c] source-hash-3558f9c0592b443f20ca1f406198f89a5385767e
git bisect good 790bc86e8c522b4456d84f3eb54a89033e80513c
# bad: [5ad42e6e2be772d6e3f5793758dda469d42ed63e] source-hash-1b8cfd5d1414da9127ff18e4701b40f5bceabb36
git bisect bad 5ad42e6e2be772d6e3f5793758dda469d42ed63e
# good: [e4d005824609d6fe312fa4bee93ca5b683428a1d] source-hash-c9f3c508bb1a1d94fd6172b9cdac30278559f31c
git bisect good e4d005824609d6fe312fa4bee93ca5b683428a1d
# first bad commit: [5ad42e6e2be772d6e3f5793758dda469d42ed63e] source-hash-1b8cfd5d1414da9127ff18e4701b40f5bceabb36
Comment 4 Caolán McNamara 2014-05-26 15:50:11 UTC
strange scrolled window ended up in there
Comment 5 Commit Notification 2014-05-26 19:42:02 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=66925f65f83910ce97b4213f91d0d0e3aa2db43e

Resolves: fdo#79124 options cells shift down when unit clicked



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Yousuf Philips (jay) (retired) 2014-05-29 07:28:08 UTC
*** Bug 79394 has been marked as a duplicate of this bug. ***
Comment 7 Robinson Tryon (qubit) 2015-12-17 08:11:25 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]