Download it now!
Bug 79134 - Autorecovery screen shows '$(ARG1)'
Summary: Autorecovery screen shows '$(ARG1)'
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoSave-AutoRecovery-Backup
  Show dependency treegraph
 
Reported: 2014-05-23 15:44 UTC by Luuk
Modified: 2019-01-19 13:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of initial untitled ODT recovery (40.50 KB, image/png)
2014-05-24 21:38 UTC, reporter_of_bugs
Details
screeenshot of initial titled ODS with macro (42.78 KB, image/png)
2014-05-24 21:39 UTC, reporter_of_bugs
Details
Screenshot with described 'problem' (41.00 KB, image/png)
2014-05-25 11:16 UTC, Luuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luuk 2014-05-23 15:44:51 UTC
When LO crashed, the autorecovery screen gives a text with the following contents:
The file '$(ARG1)' is corrupt and therefore cannot be opened. LibreOfficeDev can try to repair the file.

The corruption could be the result of document manipulation or of structural document damage due to data transmission.

We recommend that you do not trust the content of the repaired document.
Execution of macros is disabled for this document.

Should LibreOfficeDev repair the file?


After wanting to repai the file (YES to above question):
The file '$(ARG1)' could not be repaired and therefore cannot be opened.



The term '$(ARG1)' is not very user-friendly.......
Comment 1 Luuk 2014-05-23 15:45:51 UTC
BTW, 
- it was an unsaved document that i was editing, when LO crashed.
- reason for crashing wil be posted in another bug, if i find the reason ;)
Comment 2 reporter_of_bugs 2014-05-24 21:38:48 UTC
Created attachment 99741 [details]
screenshot of initial untitled ODT recovery
Comment 3 reporter_of_bugs 2014-05-24 21:39:34 UTC
Created attachment 99742 [details]
screeenshot of initial titled ODS with macro
Comment 4 reporter_of_bugs 2014-05-24 21:46:35 UTC
I was unable to replicate this on

Ubuntu 14.04 64bit
Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

using the sidebar crash(https://bugs.freedesktop.org/show_bug.cgi?id=79161) 
with an untitled odt and a macro containing ods. The recovery screens generated after the crash are attached above.

If you find the specific steps necessary to repeat your crash, please add details.
Comment 5 pierre-yves samyn 2014-05-25 08:55:12 UTC
Hi

(In reply to comment #0)
> The term '$(ARG1)' is not very user-friendly

I confirm and agree: it would be better to display the temporary name of the unsaved document (Untitled 1, Untitled 2...)

It is not really a bug, so I set status to New - Enhancement

Regards
Pierre-Yves
Comment 6 Luuk 2014-05-25 11:16:49 UTC
Created attachment 99761 [details]
Screenshot with described 'problem'

The other two screenshots missed the last step.
probably i did not describe it clear enough ;-)
The problem is after pressing the 'Start recovery' button
Comment 7 Luuk 2019-01-19 13:30:33 UTC
not reproducable in 6.1.4.2 ==> closing