Bug 79145 - Copy chart from Calc to Writer formats data axis to number axis
Summary: Copy chart from Calc to Writer formats data axis to number axis
Status: RESOLVED DUPLICATE of bug 71767
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-05-23 17:42 UTC by Jorendc
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document; Copy chart in it to Writer (63.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-23 17:42 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2014-05-23 17:42:18 UTC
Created attachment 99667 [details]
Sample document; Copy chart in it to Writer

How to reproduce:
* Pull a chart out of some date formatted data (or just use my attached document)
* Select the chart
* Copy it
* Paste it in Writer

Behavior: date formatted axis converts to number formatting.

Workaround is to format the axis again in writer. Double click on it Format > Axis > X or Y axis > Numbers

Kind regards,
Joren
Comment 1 tommy27 2014-05-24 06:30:02 UTC
confirmed under Win7x64 with version between 4.0.4.2 and 4.2.4.2 
works fine with 3.6.7.2, hence a regression of the 4.0.x branch (I do not have early 4.0.x to test) which need bibisect.

issue persists with 4.3.0.0.alpha1+
Build ID: 19979ae27055cb910bfc368bfc2899d211f56be1
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-21_00:29:23
Comment 2 Jorendc 2014-05-25 13:10:24 UTC
git bisect start
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [793dbf6f80f497dfe587d560d6257f42a24273f6] source-hash-1581b1fc3ac82a7bd62df968226e98604a4ca52d
git bisect bad 793dbf6f80f497dfe587d560d6257f42a24273f6
# bad: [793dbf6f80f497dfe587d560d6257f42a24273f6] source-hash-1581b1fc3ac82a7bd62df968226e98604a4ca52d
git bisect bad 793dbf6f80f497dfe587d560d6257f42a24273f6
# bad: [8092559c5013969ebda017d79200463b9b975038] source-hash-fd84daf696a368c2c7561b5253b32a63ecdeca4a
git bisect bad 8092559c5013969ebda017d79200463b9b975038
# good: [2bdbcaf93e4616633a733de7eb88ba19571929ac] source-hash-cf04745f7a027594fd64a493c276a8280dbccfe1
git bisect good 2bdbcaf93e4616633a733de7eb88ba19571929ac
# good: [f823dd19086ed09fb8e2072050e963cf1bfcd5fe] source-hash-b679a2a02180c017bd8b596fb2e4f283bad93b75
git bisect good f823dd19086ed09fb8e2072050e963cf1bfcd5fe
# good: [8cf46b05e525ac3602433613f227f0dcacc44035] source-hash-1692cf6854ff7adbb2bd47f2f7ec2b3de51864f3
git bisect good 8cf46b05e525ac3602433613f227f0dcacc44035
# bad: [3cb56a12a43a7c2a43954dc7694a6f6bde544f98] source-hash-41c2b0375773b2d2945d75e255ea6bb6c7fd378d
git bisect bad 3cb56a12a43a7c2a43954dc7694a6f6bde544f98
# bad: [6178060e0e995b23fb5fe35c52b1fba67bd0760d] source-hash-44b96a2fce52b6e3e683dc917fab219cf75001db
git bisect bad 6178060e0e995b23fb5fe35c52b1fba67bd0760d
# good: [c01053e32bdb3d0b413b71ddde869618fa5d2624] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
git bisect good c01053e32bdb3d0b413b71ddde869618fa5d2624
# bad: [8125b06dfe80e260ff2108fab3c85eb03ec2608b] source-hash-683758efb22d08a4cf211a6d985148f513da2a90
git bisect bad 8125b06dfe80e260ff2108fab3c85eb03ec2608b
# bad: [3f239c0dbc91ea922758438ecbddf6dc7203c268] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
git bisect bad 3f239c0dbc91ea922758438ecbddf6dc7203c268
# first bad commit: [3f239c0dbc91ea922758438ecbddf6dc7203c268] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
Comment 3 Kohei Yoshida 2014-06-20 03:36:04 UTC

*** This bug has been marked as a duplicate of bug 71767 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 11:03:34 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]