Bug 79169 - FILEOPEN: Can't Load Chart with trend line equation. NVIDIA OpenGL Driver error.
Summary: FILEOPEN: Can't Load Chart with trend line equation. NVIDIA OpenGL Driver error.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-24 08:25 UTC by tommy27
Modified: 2014-06-05 04:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
NVIDIA OpenGL Driver error dialog (67.25 KB, image/jpeg)
2014-05-24 08:25 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2014-05-24 08:25:20 UTC
Created attachment 99693 [details]
NVIDIA OpenGL Driver error dialog

tested under Win7x64.
steps to reproduce:

1- download attachment 97474 [details] from Bug 77526 which is a chart with trend line equation 

2- load it in LibO 4.3 

3- file doesn't load and a NVIDIA error dialog shows up (see screenshot)

bug reproduced with following 4.3.x versions:

4.3.0.0.alpha1+
Build ID: 19979ae27055cb910bfc368bfc2899d211f56be1
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-21_00:29:23

4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

the same file loads with no issue in the same computer using LibO 4.2.4.2
hence regression
Comment 1 Laurent BP 2014-05-24 09:17:24 UTC
Hello,

I do NOT reproduce with Win7 (32bit) LibO Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
Comment 2 Jorendc 2014-05-24 09:27:41 UTC
@tommy: what are the specifications of your system (CPU, video card, memory,...)?

Kind regards,
Joren
Comment 3 tommy27 2014-05-24 09:35:42 UTC
Intel Core2 Duo CPU P8400 @ 2.26GHz
DDR2 4GB
OpenGL Version	3.3.0
NVIDIA Corporation Renderer GeForce 9300M GS/PCIe/SSE2
GLU Version 1.2.2.0 Microsoft Corporation
Comment 4 Jorendc 2014-05-24 12:15:11 UTC
Following the website referred on your popup ( http://nvidia.custhelp.com/app/answers/detail/a_id/3008) :

The most common cause for this issue is that the application was unable to continue due to hardware limitations. The workload the application sent to the Graphics Card could not be broken into small enough pieces to be processed.

How can this be fixed:
* Update your drivers (http://www.nvidia.com/Download/index.aspx?lang=en-us)

If updating your driver doesn't work: You can also try manipulating a smaller image as you may be running out of video memory with extremely large images.  If none of these work, you likely need a more powerful Graphics Card to handle this application.

@Markus: not sure we can detect this kind of errors and disable OpenGL by default?

Kind regards,
Joren
Comment 5 tommy27 2014-05-28 06:49:08 UTC
that's probably a NVIDIA issue since LibO 4.3beta1 can load that file with no errors in another Win7x64 PC with AMD Radeon HD 6450.

I'll try to upgrade drivers in the other PC and tell if it fix things.
in the meantime I set status to NEEDINFO
Comment 6 tommy27 2014-06-05 04:16:16 UTC
I did not update drivers since there were no newer stable releases for my PC (just betas available) anyway I can say it works again with 4.4.0.0.alpha0+
Build ID: dacab84536f61f79a5422e1d8d394019ec62f3ec
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-04_04:27:18

I've read that Markus is working on this openGL issue and I suppose he fixed that.
Comment 7 Markus Mohrhard 2014-06-05 04:34:16 UTC
(In reply to comment #6)
> I did not update drivers since there were no newer stable releases for my PC
> (just betas available) anyway I can say it works again with 4.4.0.0.alpha0+
> Build ID: dacab84536f61f79a5422e1d8d394019ec62f3ec
> TinderBox: Win-x86@39, Branch:master, Time: 2014-06-04_04:27:18
> 
> I've read that Markus is working on this openGL issue and I suppose he fixed
> that.

Interesting. I think I only fixed some memory leaks but nothing major in the code. I'll however check the commit log for the relevant file.