Bug 79179 - Formulas contained in Writer document are wrongly loaded (with blue background)
Summary: Formulas contained in Writer document are wrongly loaded (with blue background)
Status: RESOLVED DUPLICATE of bug 80468
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf
Keywords: dataLoss, regression
Depends on:
Blocks:
 
Reported: 2014-05-24 15:14 UTC by Firas Hanife
Modified: 2015-12-18 09:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testing file (28.96 KB, application/vnd.oasis.opendocument.text)
2014-05-24 15:14 UTC, Firas Hanife
Details
Screenshot (11.62 KB, image/png)
2014-05-24 15:14 UTC, Firas Hanife
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Firas Hanife 2014-05-24 15:14:36 UTC
Created attachment 99713 [details]
Testing file

I noticed this strange behavior loading a 4.1.6.2 document. The document contained many formulas, but only the two in the attached .odt present this issue.

- Steps to reproduce:

1) Open the attached document
The formulas background is shown as blue even if I didn't set it to blue

Double-clicking on the formula to enable editing mode shows that the background color is transparent.
Comment 1 Firas Hanife 2014-05-24 15:14:55 UTC
Created attachment 99714 [details]
Screenshot
Comment 2 Firas Hanife 2014-05-24 15:45:20 UTC
The Fill color in
4.1.6.2 is set to "No Fill" (Object > Background)
4.3.0.0.beta1 is set to "Tango: Sky Blue 1" (Object > Area)
Comment 3 V Stuart Foote 2014-05-24 16:10:12 UTC
Confirming, adjusting platform to all.

On Windows 7 sp1, 32-bit 
In Version: 4.1.6.2
Build ID: 40ff705089295be5be0aae9b15123f687c05b0a

The Formula object shows Background of "No Fill", with color selection of White

But on Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

The Formula object shows the "No Transparency" radio button selected, but an Area fill value of "Tango: Sky Blue 1"--with no apparent way to assign "No Fill" to the Area value.
Comment 4 tommy27 2014-07-27 20:52:44 UTC
confirming blue background under Win7x64 using Version: 4.4.0.0.alpha0+
Build ID: b9dca968c6fd0ab5ca140c65b0e54d153cd34986
TinderBox: Win-x86@42, Branch:master, Time: 2014-07-18_22:51:20

loads fine in 4.2.5.2 hence regression
Comment 5 ign_christian 2014-08-15 03:06:20 UTC
Set Platform All|All per comment 3

Add bibisectRequest per Bug 82632
Comment 6 Michael Stahl (allotropia) 2014-11-12 15:22:16 UTC
this was fixed in 4.3.0.4... so it's another duplicate of bug 80468

*** This bug has been marked as a duplicate of bug 80468 ***
Comment 7 V Stuart Foote 2014-11-22 19:54:01 UTC
Confirming as fixed with 4.4.0.0alpha1 release.

Incorrect through
Version: 4.4.0.0.alpha0+
Build ID: 93f9451340957dae29a6b3ccec127a99a03ffd31
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-27_06:02:32

but was corrected by
Version: 4.4.0.0.alpha0+
Build ID: fc24eadc6283cd03397b70fda309a578ce295f16
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-03_00:31:27

So, http://cgit.freedesktop.org/libreoffice/core/commit/?id=5aa360cae0383f270c12708e7e94179a7fde6711 for bug 80468 probably also corrected this issue.
Comment 8 Robinson Tryon (qubit) 2015-12-18 09:53:06 UTC
Migrating Whiteboard tags to Keywords: (dataloss)
[NinjaEdit]