Bug Hunting Session
Bug 79181 - LibreOffice logo not vertically aligned in about dialog
Summary: LibreOffice logo not vertically aligned in about dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium trivial
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0 target:4.2.5
Keywords: regression
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2014-05-24 16:00 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-09-30 19:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
how the LibO logo looks in the about dialog from 4.0 to 4.3 (39.22 KB, image/jpeg)
2014-05-24 16:00 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-24 16:00:31 UTC
Created attachment 99720 [details]
how the LibO logo looks in the about dialog from 4.0 to 4.3

In the Help > About dialog box, the LibO logo is not centered vertically in the green background. This was tested in linux and has been a regression since 4.2 as it is correctly centered in 4.0 and 4.1.
Comment 1 Jorendc 2014-05-24 16:04:25 UTC
Reproducible, tested using Windows 8.1 with LibreOffice 4.2.4.2.

Kind regards,
Joren
Comment 2 Caolán McNamara 2014-05-26 09:31:31 UTC
FWIW, it appears to be the "clipPath" entry in the icon-themes/galaxy/brand/flat_logo.svg that causes the problem
Comment 3 Commit Notification 2014-05-26 11:58:39 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5251d35043cab1117e12677f0c40f3e849f3e1c

Resolves: fdo#79181 drop hidden shape and drop negative clip rect



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-05-26 12:00:12 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e71fccd0729340c666e2b32dc09cdc9eff246568&h=libreoffice-4-3

Resolves: fdo#79181 drop hidden shape and drop negative clip rect


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2014-05-26 12:26:40 UTC
fixed for 4-3 and master for the "generic one", backport on gerrit for 4-2 and asking cloph to use a new replacement one for the "official" logos to fix those too.
Comment 6 Commit Notification 2014-05-27 07:38:10 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7bf812bc1e976c895dcd65b0c01d46bc39e348fc&h=libreoffice-4-2

Resolves: fdo#79181 drop hidden shape and drop negative clip rect


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Yousuf Philips (jay) (retired) 2014-05-30 05:38:33 UTC
Unfortunately the logo without 'The Document Foundation' in it is appearing now similar to how it looked back in 4.1.
Comment 8 Caolán McNamara 2014-05-30 13:07:57 UTC
The bug was "the logo is not vertically aligned in the about dialog" and it was "correctly centered in 4.0 and 4.1". Its now centered again, or at least it should be. So presumably the bug is fixed now. If there is an issue around the white border then that's a different issue. If it is that, then the extra white space around the image is the standard 6 pixel border we put around all of the dialog contents.
Comment 9 Yousuf Philips (jay) (retired) 2014-05-31 01:35:06 UTC
Yes the logo that is presently in there is center, but its the wrong logo. The logo there now is the logo found in version 4.1 shown in attachment 99720 [details].
Comment 10 Caolán McNamara 2014-06-04 14:58:06 UTC
The logo with "the document foundation" should only appear in the release builds because its reserved for the official document foundation builds, while the logo without "the document foundation" is the default everyone gets to use.

So the actual 4.2.5/4.3.0 betas and final release should have the "The Document Foundation" version of the logo which I also adjusted and uploaded for cloph and co. to use the next time.
Comment 11 Yousuf Philips (jay) (retired) 2014-06-05 05:35:12 UTC
Thanks for the reply. :)