Bug 79224 - FILEOPEN: DOC Wrong page layout when section start set to even or odd page
Summary: FILEOPEN: DOC Wrong page layout when section start set to even or odd page
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Page Writer-Styles-Page-Odd-Even
  Show dependency treegraph
 
Reported: 2014-05-25 19:39 UTC by ntrrgc
Modified: 2020-04-24 07:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document triggering the bug (86.72 KB, application/msword)
2014-05-25 19:39 UTC, ntrrgc
Details
word 2007 section start (21.49 KB, image/jpeg)
2014-05-25 22:42 UTC, Yousuf Philips (jay) (retired)
Details
libO 4.2 page layout (27.26 KB, image/jpeg)
2014-05-25 22:43 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ntrrgc 2014-05-25 19:39:15 UTC
Created attachment 99792 [details]
Document triggering the bug

Writer has an option (Format/Page/Page/Page layout) for pages to be always left or right and thus skipping even or odd page numbers.

For some reason the attached document is getting this option set to "Only right", thus causing strange behavior as pages are added. For example, with 5 pages Writer indicates the document has 9 pages: 1, 3, 5, 7 and 9.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-25 22:41:09 UTC
I can confirm that LibO isnt representing the information correctly, as word has section start set to 'odd page', which means that the start of a section should be an odd number page, while writer is translating this into 'only right' in page layout.

So adding 2 pages in word with 'odd page' will number the three pages as 1, 2, 3 and with 'even page' will number them 2, 3, 4, while writer with 'only right' has the statusbar as 'Page 1 / 5', 'Page 3 / 5', 'Page 5 / 5' and with 'only left' has the page numbers as 'Page 1  2 / 6', 'Page 3  4 / 6' and 'Page 5  6 / 6'.

I tested this in linux mint with the latest releases of 3.6 - 4.2 and 4.3 beta.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-25 22:42:26 UTC
Created attachment 99809 [details]
word 2007 section start
Comment 3 Yousuf Philips (jay) (retired) 2014-05-25 22:43:03 UTC
Created attachment 99810 [details]
libO 4.2 page layout
Comment 4 QA Administrators 2015-06-08 14:42:42 UTC Comment hidden (obsolete)
Comment 5 Yousuf Philips (jay) (retired) 2015-06-10 06:43:24 UTC
Still present. Document doesnt open in 3.3.0 as it claims it is corrupted.

Version: 5.1.0.0.alpha1+
Build ID: 782c116b5ac39aef27c3a00f7fc145c9f755e3a3
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-06-09_23:59:00
Comment 6 Robinson Tryon (qubit) 2015-12-09 18:43:16 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2018-10-05 02:52:43 UTC Comment hidden (obsolete, spam)
Comment 8 Justin L 2020-04-24 07:32:03 UTC
I cannot reproduce in 5.2 or 7.0+.

For starters, the example document is only one page long, so it is hard to see problems with page 3 and 5 on a one page document.

Also, this is not a DOC bug, but a DOCX file.

So I used Word 2003 to modify the page size, so that it took up three pages, and added page numbering to the header. I saved in both .doc and .docx format. LO opens them both up fine as pages 1, 2, 3 with bibisect-linux-64-5.3 oldest.

Because of all of this, plus no action for 5 years, I will close as works-for-me.