Download it now!
Bug 79227 - Truncated text "Table" and "Term" tools
Summary: Truncated text "Table" and "Term" tools
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: Other All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.4.0 target:4.3.2
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-25 20:10 UTC by Riccardo Vianello
Modified: 2014-08-20 14:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot with English (US) UI (128.89 KB, image/png)
2014-05-25 20:51 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Vianello 2014-05-25 20:10:39 UTC
Description: When i click on the "Tools" menu, the game shows a new drop-down menù where there are many entries. If i click on the "Bibliographic database" a new window is shown.
In this case the word "Table" and "Term" are hiding between his fields because these text is too long instead of the space. (Video 1)

Step by Step:
1)I wait which the my program is open
2)I click on the "Tools" menu and the game shows a new drop-down menu where there are many entries.
3)If i click on the "Bibliographic database", a new window is shown.
4)The "Table" and "Term" word are truncate text because these texts are too long instead of the space, and these words are hiding partially from their field (Video 1)

2.a)Truncate text: "Tabe"
Right text: "Tabella"

2.b)Truncate text: "Term"
Right text: "Termine ricercato"

OS:Windows 8 Pro
Size Monitor:1366x768
Monitor: AMD Radeon HD 7670
Language: Italian

Video:
Video 1 => https://www.youtube.com/watch?v=oBngiuRYtAY&feature=youtu.be

please fix these truncate texts.
Comment 1 Firas Hanife 2014-05-25 20:22:31 UTC
I can reproduce this issue on 4.1.6.2 with openSUSE 13.1.
Comment 2 Julien Nabet 2014-05-25 20:51:18 UTC
Created attachment 99797 [details]
screenshot with English (US) UI

On pc Debian x86-64 with master sources updated 2 days ago, I can reproduce this.
Comment 3 Julien Nabet 2014-05-25 20:54:10 UTC
Caolan: I thought you might be interested in this one for UI migration.
I attached a screenshot. "Table" and "Search" at top left are indeed truncated but some labels don't show completely (they're a little bit "cropped" at the top).
Comment 4 Caolán McNamara 2014-05-27 11:33:08 UTC
yeah, ui-conversion should fix this when we get to that big one
Comment 5 Jean-Baptiste Faure 2014-07-24 10:56:49 UTC
Word "bug" in the summary is useless.
Comment 6 Commit Notification 2014-08-20 13:57:38 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=71804294c79136ef43a8f91b5c961e266d32187a

Resolves: fdo#79227 labels are truncated



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-08-20 14:09:32 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3b6748a4002f4b61ae477da7a84b4a0feccdef12&h=libreoffice-4-3

Resolves: fdo#79227 labels are truncated


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.