Bug 79292 - FILESAVE: DOCX index table losses periods before page number when opened in MS Word 2013
Summary: FILESAVE: DOCX index table losses periods before page number when opened in M...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: DOCX-TableofContents mab4.3
  Show dependency treegraph
 
Reported: 2014-05-27 07:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-02 20:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibO 4.3 beta exported docx file opened in Word 2013 (179.09 KB, application/pdf)
2014-05-27 07:46 UTC, Yousuf Philips (jay) (retired)
Details
LibO 4.2.4 exported docx file opened in Word 2013 (178.54 KB, application/pdf)
2014-05-27 07:46 UTC, Yousuf Philips (jay) (retired)
Details
Index table shown from exports from Libo 4.2.4 and 4.3 beta in Word 2013 (90.20 KB, image/png)
2014-05-27 07:49 UTC, Yousuf Philips (jay) (retired)
Details
Missing index table from re-opened export in LibO 4.2.4 comparing to re-opened export in 4.3 beta (89.16 KB, image/png)
2014-05-27 07:51 UTC, Yousuf Philips (jay) (retired)
Details
incorrect figure number after re-opening the exported 4.2.4 file (90.70 KB, image/png)
2014-05-27 08:13 UTC, Yousuf Philips (jay) (retired)
Details
screenshot: the docx file open in OneDrive (80.16 KB, image/png)
2014-05-28 05:45 UTC, Kevin Suo
Details
Screenshot from OneDrive of the Original docx (52.03 KB, image/png)
2014-05-28 08:35 UTC, Yousuf Philips (jay) (retired)
Details
QQ user test in MSO 2013: The original file screenshot (17.32 KB, image/jpeg)
2014-05-28 08:43 UTC, Kevin Suo
Details
QQ user test in MSO 2013: The LO 4.3.0 Beta 1 saved file screenshot (25.51 KB, image/jpeg)
2014-05-28 08:45 UTC, Kevin Suo
Details
the docx exported out of libO 4.3b (21.75 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-28 08:55 UTC, Yousuf Philips (jay) (retired)
Details
the pdf export of opening the 4.3 beta exported docx in word 2013 (179.09 KB, application/pdf)
2014-05-28 08:56 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-27 07:46:06 UTC
Created attachment 99924 [details]
LibO 4.3 beta exported docx file opened in Word 2013

When testing attachment 86189 [details] from bug 69614, i noticed that when the LibO 4.3 beta exported docx file opens in Word 2013, it looses the periods before page numbers on page 3 compared to the LibO 4.2.4 exported docx file opened in Word 2013.

But there is also another weird behaviour with the index table, as when you reopened the exported LibO 4.3 beta in LibO 4.3 beta and compared it to the exported LibO 4.2.4 in LibO 4.2.4, the index table is missing in LibO 4.2.4, and the figure on page 2 is labelled as figure 1, when it should be labelled as figure 2.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-27 07:46:30 UTC
Created attachment 99925 [details]
LibO 4.2.4 exported docx file opened in Word 2013
Comment 2 Yousuf Philips (jay) (retired) 2014-05-27 07:49:00 UTC
Created attachment 99926 [details]
Index table shown from exports from Libo 4.2.4 and 4.3 beta in Word 2013
Comment 3 Yousuf Philips (jay) (retired) 2014-05-27 07:51:46 UTC
Created attachment 99927 [details]
Missing index table from re-opened export in LibO 4.2.4 comparing to re-opened export in 4.3 beta
Comment 4 Yousuf Philips (jay) (retired) 2014-05-27 08:13:27 UTC
Created attachment 99929 [details]
incorrect figure number after re-opening the exported 4.2.4 file
Comment 5 Joel Madero 2014-05-28 05:06:12 UTC
Can't reproduce with MSO 2010

Steps to Reproduce:

1. Download attachment 86189 [details]
2. Open with Microsoft Office - notice that periods exist on page 3 TOC
3. Open in LibreOffice 4.3 beta1
4. Save as new file with .docx extension
5. Open new file with Microsoft Office 2013

Can't confirm but above steps should be attempted with 2013. I created the file in Linux and then emailed it to myself and opened it with MSO 2010 in W7.
Comment 6 Yousuf Philips (jay) (retired) 2014-05-28 05:10:48 UTC
I do confirm office 2007 and 2010 show the TOC correctly. :)
Comment 7 Kevin Suo 2014-05-28 05:45:53 UTC
Created attachment 100000 [details]
screenshot: the docx file open in OneDrive

I can confirm the TOC "..." missing issue in OneDrive (was SkyDrive, OneDrive = MSO 2013)

See the attached screenshot.

Steps to reproduce:
1. Download attachment 86189 [details];
2. Upload the attachment to OneDrive (https://onedrive.live.com);
3. Open the file with OneDrive.

Current Behaviour:
"........" in the TOC are missing.

Expected:
There should be "........" in the TOC.
Comment 8 Yousuf Philips (jay) (retired) 2014-05-28 06:23:12 UTC
(In reply to comment #7)
> Steps to reproduce:
> 1. Download attachment 86189 [details];
> 2. Upload the attachment to OneDrive (https://onedrive.live.com);
> 3. Open the file with OneDrive.

No these instructions are incorrect. After downloading it, you need to open it up in LibO and then save as a .docx file and then upload that saved .docx file in OneDrive. But when i tried opening it in OneDrive, i see the dots.
Comment 9 Kevin Suo 2014-05-28 06:36:14 UTC
(In reply to comment #8)

> No these instructions are incorrect. After downloading it, you need to open
> it up in LibO and then save as a .docx file and then upload that saved .docx
> file in OneDrive. But when i tried opening it in OneDrive, i see the dots.

No, I confirm I did nothing before I upload it to OneDrive.
(So maybe attachment 86189 [details] is already buggy?)
Comment 10 Yousuf Philips (jay) (retired) 2014-05-28 08:07:48 UTC
(In reply to comment #9)
> (In reply to comment #8)
> 
> > No these instructions are incorrect. After downloading it, you need to open
> > it up in LibO and then save as a .docx file and then upload that saved .docx
> > file in OneDrive. But when i tried opening it in OneDrive, i see the dots.
> 
> No, I confirm I did nothing before I upload it to OneDrive.
> (So maybe attachment 86189 [details] is already buggy?)

Well it wasnt buggy for me when i opened it in OneDrive, which is weird.
Comment 11 Yousuf Philips (jay) (retired) 2014-05-28 08:34:39 UTC
Well suokunlong@gmail.com went into edit mode in onedrive which shows it like that, but in view mode it shows it with the dots. onedrive couldnt open the exported docx files from libO as it states that the document has objects it doesnt support, which is weird. I'm assuming its just MS stopping people from editing documents not created in MSO.
Comment 12 Yousuf Philips (jay) (retired) 2014-05-28 08:35:26 UTC
Created attachment 100014 [details]
Screenshot from OneDrive of the Original docx
Comment 13 Kevin Suo 2014-05-28 08:43:20 UTC
Created attachment 100016 [details]
QQ user test in MSO 2013: The original file screenshot

Someone (48701547<god_anubis@163.com>)in the official LibreOffice Chinese QQ Chatroom (QQ Qun) has tested in Office 2013, He can not reproduce.

Attached is the original file opened in MSO 2013. The TOC has dots as expected.
Comment 14 Kevin Suo 2014-05-28 08:45:48 UTC
Created attachment 100017 [details]
QQ user test in MSO 2013: The LO 4.3.0 Beta 1 saved file screenshot

This is the screenshot for the LibreOffice 4.3.0 beta1 saved file openned in MSO 2013.

As you can see, dots still exists at page 3 TOC.
Comment 15 Kevin Suo 2014-05-28 08:46:50 UTC
Set back to UNCONFIRMED.
Comment 16 Yousuf Philips (jay) (retired) 2014-05-28 08:55:13 UTC
Created attachment 100019 [details]
the docx exported out of libO 4.3b
Comment 17 Yousuf Philips (jay) (retired) 2014-05-28 08:56:18 UTC
Created attachment 100020 [details]
the pdf export of opening the 4.3 beta exported docx in word 2013
Comment 18 Yousuf Philips (jay) (retired) 2014-05-28 09:08:23 UTC
I tested it out again in word 2013 and the dots have appeared, so strange.