Bug 79313 - DOCX: Line breaks disappear in exported SDT block
Summary: DOCX: Line breaks disappear in exported SDT block
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2014-05-27 14:24 UTC by Jacobo Aragunde Pérez
Modified: 2018-12-12 14:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case (21.25 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-27 14:24 UTC, Jacobo Aragunde Pérez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2014-05-27 14:24:23 UTC
Created attachment 99947 [details]
Test case

The attached test case contains a SDT "comments" block with several lines. Just:

1. Open it
2. Save as .docx
3. Open the exported document with Word

In the exported document, the SDT block contains only the first line and the others have been moved outside.
Comment 1 Jorendc 2014-05-29 15:32:04 UTC
Repro, windows 8.1 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: a35d92197d850527bd294eb6197b5bf83109d5be
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-29_10:21:12

Kind regards,
Joren
Comment 2 QA Administrators 2015-07-18 17:43:35 UTC Comment hidden (obsolete)
Comment 3 Jacobo Aragunde Pérez 2015-08-12 08:59:40 UTC
The bug behavior has changed. Now the SDT block in the exported document contains all the text combined in one line, removing the line breaks.

Bug description changed:
DOCX: Some contents moved outside the SDT block -> DOCX: Line breaks disappear in exported SDT block

Tested with:

Version: 5.1.0.0.alpha1+
Build ID: 0f4b3cb7d3d68906de316a64dcec281da2a641bd

Version: 4.4.4.3
Build ID: 4.4.4.3-6.fc22
Comment 4 QA Administrators 2016-09-20 10:20:36 UTC Comment hidden (obsolete)
Comment 5 Jacobo Aragunde Pérez 2016-10-19 10:54:46 UTC
Still reproducible as described in comment 3.

Version: 5.1.6.1.0+
Build ID: 5.1.6.1-1.fc24
CPU Threads: 4; OS Version: Linux 4.7; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 6 QA Administrators 2017-12-11 08:55:10 UTC Comment hidden (obsolete)
Comment 7 Jacobo Aragunde Pérez 2017-12-11 12:11:30 UTC
Still reproducible as described in comment #3.

Version: 5.3.7.2.0+
Build ID: 5.3.7.2-4.fc26
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: es-ES (en_US.UTF-8); Calc: group
Comment 8 QA Administrators 2018-12-12 03:42:41 UTC Comment hidden (obsolete)
Comment 9 Jacobo Aragunde Pérez 2018-12-12 14:33:45 UTC
Still reproducible as described in comment #3.

Version: 6.0.6.2
Build ID: 6.0.6.2-3.fc28
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: es-ES (en_US.UTF-8); Calc: group
Comment 10 Jacobo Aragunde Pérez 2018-12-12 14:39:12 UTC
More information:

* Opening the exported document with Word 2010 on Windows reproduces the bug.
* Opening the exported document with Word Online with a free OneDrive account shows the document correctly (!)