Bug 79357 - Trend line can't be added by the Insert menu
Summary: Trend line can't be added by the Insert menu
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL: https://poetryurdu.net/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-28 07:43 UTC by Boaz Dodin
Modified: 2021-08-01 08:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple chart for example (20.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-28 07:43 UTC, Boaz Dodin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boaz Dodin 2014-05-28 07:43:40 UTC
Created attachment 100012 [details]
Simple chart for example

According to this official page:
https://help.libreoffice.org/Chart/Trend_Lines
"Trend lines can be added to all 2D chart types except for Pie and Stock charts."

It looks like I can't add trend lines at all - after double-click on the chart and entering the edit mode, Insert - Trend Lines option is disabled (grey and can't be choosed).

Attached a simple chart for example.
Comment 1 Tomaz Vajngerl 2014-05-28 08:26:37 UTC
You have to select a data series (either on the chart or in the combo box) to add a trend line. This is a must when you have more data series in one chart but unfortunately inconvenient when you just have one.
Comment 2 Boaz Dodin 2014-05-28 09:21:55 UTC
(In reply to comment #1)
> You have to select a data series (either on the chart or in the combo box)
> to add a trend line. This is a must when you have more data series in one
> chart but unfortunately inconvenient when you just have one.

Selecting data series do allow to add a trend line, but there is a bug regarding adding trend line by the Insert menu.
Moreover, it's a regression somewhere between LO 4.1.x to 4.2.x!

I just tested the originally attached file on LO 4.1.6.2, WinXP SP3 - a trend line can be added by the Insert menu following the steps in bug description.
Comment 3 Tomaz Vajngerl 2014-05-28 10:44:45 UTC
As I already said - you have to select the data series to enable "Insert->Trend Lines..". The abilities of trend lines changed in 4.2 and so did the behavior - this is why this is not a bug but was changed intentionally.

It is unfortunate that you now have to select the data series even when tere is only one, but you also have to select the image (even when there is only one) for which you want to perform "Format->Flip->Flip Vertically".
Comment 4 Boaz Dodin 2014-05-28 11:01:15 UTC
If it's "by design", it's a very problematic change. Especially for the users moved from old version to the 4.2.

For me, double-clicking on the chart is exactly as telling to LO where the trend line should be added. In fact, 4.1 works this way, as expected.

So, the example of image flipping is not relevant, as the bug is not about enabling insert of trend line all the time (without double-click on the chart).

Moreover, till today I was not aware of the option to select data series and adding trend line from right click menu (although working with trend lines for about 2 years).
How the user can guess why the trend line can't be added?..
Comment 5 Tomaz Vajngerl 2014-05-28 12:17:08 UTC
When you double-click on the chart it is still not clear to which data series you want to add a trend line. You can have more data series in one chart (and this is what I have been talking about the whole time) - so the example clearly applies - one in scope of Calc, the other in scope of Chart.
Comment 6 Boaz Dodin 2014-05-28 12:26:34 UTC
All that I say, is because this behavior is new to 4.2, moreover it's about something stopped working, it can't be just disabled.

How about a short hint or a pop-up explaining why trend line can't be added from the Insert menu and what should be done to add it?

P.S. If the chart is only about 1 data series, what is the rational to still disable the menu option?
Comment 7 Markus Mohrhard 2014-06-22 21:29:07 UTC
Tomaz already mentioned that it is not a bug. It is part of the improved support for trendlines.
Comment 8 Jean Gislason 2020-02-29 08:11:10 UTC Comment hidden (spam)
Comment 9 meave 2020-06-03 13:22:41 UTC Comment hidden (spam)
Comment 10 Karyn Chase 2021-01-14 07:18:31 UTC Comment hidden (spam)
Comment 12 anand 2021-01-22 08:22:05 UTC Comment hidden (spam)
Comment 13 karthika 2021-04-12 20:50:58 UTC Comment hidden (spam)
Comment 14 saif 2021-06-21 08:59:05 UTC Comment hidden (spam)
Comment 15 Saim ali 2021-08-01 08:43:14 UTC Comment hidden (spam)