Download it now!
Bug 79365 - UI: sidebar dropdown cropped on high resolution screen with OS scaling factor 2
Summary: UI: sidebar dropdown cropped on high resolution screen with OS scaling factor 2
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2014-05-28 13:06 UTC by freddi34
Modified: 2016-12-26 17:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the LibreOffice formula editor UI with sidebar and cropped dropdown (20.00 KB, image/png)
2014-05-28 13:06 UTC, freddi34
Details

Note You need to log in before you can comment on or make changes to this bug.
Description freddi34 2014-05-28 13:06:53 UTC
Created attachment 100032 [details]
Screenshot of the LibreOffice formula editor UI with sidebar and cropped dropdown

Problem description: 
The dropdown field for selecting a category of formula elements is slightly cropped and covered by the white area below it.

It could be relevant that Ubuntu is set to use UI scale 2.0 and LibreOffice is at its default 100% (Settings → View). Changing LibreOffice scale other than default makes it rather worse.

Steps to reproduce:
1. Open LibreOffice
2. Insert → Object → Formula
Operating System: Ubuntu
Version: 4.2.3.3 release
Comment 1 tommy27 2014-07-13 22:59:22 UTC
not reproducible with 4.2.5.2 under Win7x64
does issue persists on your Linux machine using latest LibO version?
Comment 2 tommy27 2014-08-28 15:32:17 UTC
set status to NEEDINFO still waiting for user feedback.
current availble releases are 4.2.6 and 4.3.1
Comment 3 QA Administrators 2015-04-01 14:47:26 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2015-05-06 14:21:48 UTC Comment hidden (obsolete)
Comment 5 freddi34 2015-05-24 10:03:55 UTC
This is still the case in LibreOffice Math 4.4.2.2 40m0(Build:2) on Ubuntu 15.04 on a 3200×1800px screen.

The operating system wide UI scale is set to System Settings → Displays → UI scale = 2.0 (corresponds to dconf org.gnome.desktop.interface.scaling-factor=2).

LibreOffice → View → User interface → scale is kept at default 100% because it wouldn't respect the OS setting but add on top of it (resulting in mixed inconsistent 4× scale).

As it seems LibreOffice takes its UI scale cue from somewhere else because changing the operating system setting to 1.0 will still result in a scaled LibreOffice UI with the above bug. Reducing the screen resolution to 1600×900px with UI scale = 1 gives the correct result with the dropdown completely visible.
Comment 6 Jean-Baptiste Faure 2015-08-01 22:19:02 UTC
Made summary more complete (I hope).
Not such screen at home -> can't test.

Best regards. JBF
Comment 7 Buovjaga 2016-05-02 14:54:43 UTC
From the Displays UI I can set the scaling to max. 1,75.
Dconf sez: error: unknown command org.gnome.desktop.interface.scaling-factor=2

No problem with 1,75 scaling in Formula element selection.

Ubuntu 16.04
Version: 5.1.2.2
Build ID: 1:5.1.2-0ubuntu1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8)
Comment 8 tommy27 2016-12-21 21:04:31 UTC
@freddi34
is bug still present in LibO 5.2.3.3?
Comment 9 freddi34 2016-12-26 16:59:50 UTC
The issue has disappeared (LibreOffice Math 5.2.2.2, Build-ID: 1:5.2.2-0ubuntu2, Ubuntu 16.10)
Comment 10 Jean-Baptiste Faure 2016-12-26 17:41:14 UTC
(In reply to freddi34 from comment #9)
> The issue has disappeared (LibreOffice Math 5.2.2.2, Build-ID:
> 1:5.2.2-0ubuntu2, Ubuntu 16.10)

Thank you for your tests. So closing as WorksForMe.

Best regards. JBF