Bug 79453 - Toolbar gradient does not stretch across entire row (Windows)
Summary: Toolbar gradient does not stretch across entire row (Windows)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2014-05-30 11:26 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-07 11:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How the toolbar looks in Windows 7 (18.31 KB, image/png)
2014-05-30 11:26 UTC, Yousuf Philips (jay) (retired)
Details
gradient incomplete LO4.3b1, osx 10.9.3 (66.39 KB, image/png)
2014-05-30 14:01 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-05-30 11:26:28 UTC
Created attachment 100160 [details]
How the toolbar looks in Windows 7

In Windows, the right side of the toolbar after the width of the toolbar in that row ends is shown without a gradient on it. Tested with Windows 7 on 4.1.6, 4.2.4, and 4.3 beta.
Comment 1 retired 2014-05-30 14:01:12 UTC
Confirmed:OSX:4.3b1
OS -> all

attachingscreenshot since the error is similar but different. OSX 10.9.3.

Thanks for filing this Jay!
Comment 2 retired 2014-05-30 14:01:40 UTC
Created attachment 100164 [details]
gradient incomplete LO4.3b1, osx 10.9.3
Comment 3 Adolfo Jayme Barrientos 2014-05-31 02:07:14 UTC
The Windows look, while a bit ugly, is not a bug. It has been like that since ages. Compare it with Office 2003.

On the other hand, the Mac look *is* obviously a bug.
Comment 4 Yousuf Philips (jay) (retired) 2014-05-31 14:50:36 UTC
you are right Adolfo that it does look like office 2003, but that doesnt mean that we cant do anything about making it look good. :)
Comment 5 Jorendc 2014-06-20 20:51:12 UTC
Hi Kendy,

Question related to this bug: is there any 'refresh' option we can call here? I do see this behavior sometimes when switching focus (to other windows and back). So this looks like a refresh update to me. Only the toolbars are refreshed, not the background (area where the Personas are too).

Kind regards,
Joren
Comment 6 Yousuf Philips (jay) (retired) 2014-06-24 16:13:47 UTC
joren suggested i try personas themes and they appear in top toolbars, but not bottom ones.
Comment 7 Adolfo Jayme Barrientos 2014-06-24 22:35:47 UTC
*** Bug 80474 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2015-07-18 17:42:51 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-10-16 19:55:31 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 10 Adolfo Jayme Barrientos 2015-11-08 21:36:11 UTC
(In reply to Beluga from comment #9)
> Confirmed.
> 
> Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+

Hm, no. See comment 3. Its looks is intended, and you won’t see it anyway because the Classic UI cannot be set anymore under modern Windows versions (i.e., anything above Windows 7).

The OS X bug (unrelated, of course, it was bug 80474) has been resolved in the meantime.