Download it now!
Bug 79631 - issue with encoding when exporting various non latin text from Base to Calc
Summary: issue with encoding when exporting various non latin text from Base to Calc
Status: RESOLVED DUPLICATE of bug 37859
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-04 09:55 UTC by Dimitris Xenakis
Modified: 2014-10-10 16:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a Base file containing a single table exhibiting the issue (3.99 KB, application/zip)
2014-06-04 09:55 UTC, Dimitris Xenakis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitris Xenakis 2014-06-04 09:55:34 UTC
Created attachment 100392 [details]
a Base file containing a single table exhibiting the issue

Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
-- Need to transfer data from a Base table to a spreadsheet (Calc)
-- The data contain non Latin characters (in my case Greek)
-- If I follow the instructions in https://help.libreoffice.org/Common/Importing_and_Exporting_Data_in_Base
-- The greek characters are not tranferred properly

The attachment is a Base file with a single table exhibiting the issue

Below is a pasted text from the Calc file after attempting the export. (by the way, the copied table cannot be pasted as text, only as RTF and HTML)

ID	comment	textinnonlatin
0	Russian	Съешь же ещё этих мягких французских булок да выпей чаю.
1	Greek (monotonic)	îåóêåðÜæù ôçí øõ÷ïöèüñá âäåëõãìßá
2	german	Falsches Üben von Xylophonmusik quält jeden größeren Zwerg.
3	Suomi / Finnish	Törkylempijävongahdus 
4	Hebrew	זה כיף סתם לשמוע איך תנצח קרפד עץ טוב בגן.
5	Spanish	 El pingüino Wenceslao hizo kilómetros bajo exhaustiva lluvia y frío, añoraba a su querido cachorro.
9	texts (pangrams) taken from http://www.columbia.edu/~fdc/utf8/
Comment 1 Dominik 2014-06-04 11:14:58 UTC
On Version: 4.4.0.0.alpha0+
Build ID: df48d00ffb4fb1bf206ea41ba704373fcc35c749 the exported greek looks like:
ξεσκεπάζω την ψυχοφθόρα βδελυγμία

is this ok?
Comment 2 Dimitris Xenakis 2014-06-04 12:52:07 UTC
This is indeed OK!



(In reply to comment #1)
> On Version: 4.4.0.0.alpha0+
> Build ID: df48d00ffb4fb1bf206ea41ba704373fcc35c749 the exported greek looks
> like:
> ξεσκεπάζω την ψυχοφθόρα βδελυγμία
> 
> is this ok?
Comment 3 Julien Nabet 2014-10-09 21:27:09 UTC
On pc Debian x86-64 with 4.3.2 Debian package, I don't reproduce the problem.

Let's put this one to WFM.
Comment 4 Dimitris Xenakis 2014-10-10 07:37:23 UTC
I confirm that is works for Linux (Ubuntu 12.04, LibreOffice Version: 4.3.2.2
Build ID: 430m0(Build:2)), but I also confirm that it does *not* work for Windows as I mention in bug #37859.
Comment 5 Urmas 2014-10-10 16:27:19 UTC
This is actually the 37859.

*** This bug has been marked as a duplicate of bug 37859 ***