Bug 79636 - EDITING: writer hangs on character insert in multicolumn section
Summary: EDITING: writer hangs on character insert in multicolumn section
Status: RESOLVED DUPLICATE of bug 73805
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-06-04 13:48 UTC by globefish
Modified: 2014-06-05 11:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt console (11.17 KB, text/plain)
2014-06-04 20:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description globefish 2014-06-04 13:48:37 UTC
Problem description:
Trying to insert a character in a multicolumn section hangs libreoffice writer. One CPU is at 100%, libreoffice writer does not react on any key strokes or mouse clicks. You need to kill libreoffice writer and recover the file.

Steps to reproduce:
1. open the attached document Festschrift.odt and move the cursor to the page 10 (effective page 14) just behind the text "im Lauf der Zeit den Nam".
2. Now type the letter "e" to complete the partial word "Nam" to "Name"
3. libreoffice writer hangs

Current behavior:
libreoffice writer hangs instead of appending the letter "e". It does not react to any key strokes or mouse clicks, nor does it repaint the screen on exposure events.

Expected behavior:
libreoffice writer should append the letter "e" rebalancing the text evenly distributing contents to all 3 columns.

I generated a core file of the looping writer process. As this file is large (240 MB) I don't append it to this bug report. Instead I provide the core dump (as well as the test file) for download at http://libreoffice.huber-und-boehm.dyndns.org/

              
Operating System: openSUSE
Version: 4.2.4.2 release
Last worked in: 4.2.3.3 release
Comment 1 globefish 2014-06-04 15:19:36 UTC
To be more precise: "Last worked in 4.2.3.3 release" means I did not see this behaviour before. But this might be due to the fact that I did not use 3-column layouts before - I used 2-column layouts before.
The problem with this test file can be reproduced by several versions including 4.1.5.3 (OpenSuse), 4.1.6.2, 4.2.3.3, 4.2.5.1 and 4.3.0.0 beta.
Comment 2 globefish 2014-06-04 16:21:46 UTC
Uploading of the test file failed due to its size, and I did not succeed in getting it smaller. So please grab the test file "Festschrift.odt" from ...

http://libreoffice.huber-und-boehm.dyndns.org/Festschrift.odt
Comment 3 Julien Nabet 2014-06-04 20:08:46 UTC
Created attachment 100420 [details]
bt console

On pc Debian x86-64 with master sources updated today, I could reproduce this.

During my tests, I noticed this log repeated:
warn:legacy.osl:28533:1:sw/source/core/layout/flowfrm.cxx:2377: <SwFlowFrm::MoveBwd(..)> - layout loop control for layout action <Move Backward> applied!
Comment 4 globefish 2014-06-04 23:45:03 UTC
The problem is reproducable on a windows machine (4.2.4.2 release) as well.
Comment 5 Julien Nabet 2014-06-05 11:25:25 UTC
Thank you globefish for this test, so I put ALL platforms and increase importance.

Michael: one for you?
Comment 6 Michael Stahl (CIB) 2014-06-05 11:34:08 UTC

*** This bug has been marked as a duplicate of bug 73805 ***