Bug Hunting Session
Bug 79786 - CRASH - In a form, try to insert when a record is selected in "Datasource as Table" view causes LO to abort
Summary: CRASH - In a form, try to insert when a record is selected in "Datasource as ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: high critical
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.3.0.1 target:4.4.0 target:4.2.6
Keywords: haveBacktrace
: 80740 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-08 05:01 UTC by pierre-yves samyn
Modified: 2015-02-26 16:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
firebirdtest.odb (262.54 KB, application/vnd.oasis.opendocument.database)
2014-06-08 05:01 UTC, pierre-yves samyn
Details
bt (6.85 KB, text/plain)
2014-06-08 09:28 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2014-06-08 05:01:40 UTC
Created attachment 100631 [details]
firebirdtest.odb

Hi

In a form, try to insert when a record is selected in "Datasource as Table" view causes LO to abort

Steps to reproduce:

1. File> Open the attached firebirdtest.odb
2. Open the form "people2"
3. Click in the navigation toolbar of the form on "Datasource as table" (last right). The view opens up screen
4. In this view click the header line of a record to select (e.g. #2)

Expected & actual result: record #2 displayed in the form

5. Click in the navigation toolbar of *the form* on "New record" 

Crash

Platform: windows 7/64 & Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2014-06-08 05:08:23 UTC
Hi again

Crash also occurs with the HSQLDB embedded database format.
I removed Firebird from the Summary

Pierre-Yves
Comment 2 ribotb 2014-06-08 07:52:29 UTC
Hi,

I confirm the crash with : 
- HSQLDB embedded,
- Firebird embedded,
- ODBC connexion to a MariaDB server.

Bernard
Comment 3 pierre-yves samyn 2014-06-08 08:22:35 UTC
(In reply to comment #2)
 
> I confirm the crash with : 
> - HSQLDB embedded,
> - Firebird embedded,
> - ODBC connexion to a MariaDB server.

Ok, thank you
I set status to New

Regards
Pierre-Yves
Comment 4 Julien Nabet 2014-06-08 09:28:09 UTC
Created attachment 100645 [details]
bt

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 5 Julien Nabet 2014-06-08 10:01:29 UTC
It was working on 4.2.4 => regression
Comment 6 Julien Nabet 2014-06-08 10:05:38 UTC
Hmm, I had forgotten to select header of the row on my test with 4.2.4. After another test, it failed too so I remove "regression".
Comment 7 Julien Nabet 2014-06-08 10:23:20 UTC
gerrit review for master sources: https://gerrit.libreoffice.org/#/c/9679/1

It doesn't crash with this patch but, as usual, perhaps I'm just hiding the bug.
Comment 8 Julien Nabet 2014-06-08 10:38:43 UTC
May someone attach a quick example with hsqldb?
Comment 9 Lionel Elie Mamane 2014-06-09 05:11:05 UTC
Cannot reproduce with master sources as of 1 June.
Comment 10 Lionel Elie Mamane 2014-06-09 05:17:36 UTC
(In reply to comment #9)
> Cannot reproduce with master sources as of 1 June.

Sorry, forgot to click on "new record". Reproduced.
Comment 11 Lionel Elie Mamane 2014-06-09 06:33:03 UTC
setting version to 4.2.4.2 as per comment 6
Comment 12 Commit Notification 2014-06-09 06:42:44 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a730fe78a8d8aa1edf81ccb16622f6d10ebd20e6&h=libreoffice-4-3

fdo#79786 implement getFormOperations for data grid (table view)


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-06-09 06:42:59 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ade17fc916caf7c7bace630eaf83ae16215a2cc2

fdo#79786 implement getFormOperations for data grid (table view)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Julien Nabet 2014-06-09 07:36:36 UTC
Thank you Lionel for your review and for the real fix! :)
Comment 15 Commit Notification 2014-06-09 08:06:21 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dce8d79861408f51d392a9ed0b5ac21d420622ca&h=libreoffice-4-2

fdo#79786 implement getFormOperations for data grid (table view)


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 pierre-yves samyn 2014-06-20 08:33:49 UTC
Hi

Verified Ok on windows 7/64 Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

Thank you
Regards
Pierre-Yves
Comment 17 Julien Nabet 2014-07-04 11:11:32 UTC
*** Bug 80740 has been marked as a duplicate of this bug. ***