Bug Hunting Session
Bug 79812 - When enable "Freeze Window", sheet do not scroll when selecting cell range crossing the freeze border
Summary: When enable "Freeze Window", sheet do not scroll when selecting cell range cr...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Formula Cell-Freeze
  Show dependency treegraph
 
Reported: 2014-06-09 03:29 UTC by Kevin Suo
Modified: 2018-09-30 01:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test ODS file (12.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-09 03:29 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-06-09 03:29:41 UTC
Created attachment 100696 [details]
test ODS file

Steps to reproduce:
1. Open the attached test file. (Please note that Window Freeze is enabled in sheet1)
2. In any empty cell, type "=", then try to select range "A1:Z1".

Current Behaviour:
Window do not scroll to the right at step 2.

Expected Behaviour:
Window should scroll to the right at step 2.

More info:
When you try to select range "B1:Z1" in step 2, then window is scrolling to the right as expected.

Version:
Reproduce in 4.2.5.1 and 4.3.0 beta 2.

OS: Windows XP SP3.
Comment 1 Kevin Suo 2014-06-09 03:49:47 UTC
(In reply to comment #0)

> 2. In any empty cell, type "=", then try to select range "A1:Z1".

Sorry, to reproduce, you have to input in cells after column B. When input in cells of column A it works as expected.
Comment 2 Kevin Suo 2014-06-09 03:51:56 UTC
This is a possible regression against 4.2.4.2. Set whiteboard "PossibleRegression".
Comment 3 Kevin Suo 2014-06-09 03:54:17 UTC
(In reply to comment #2)
> This is a possible regression against 4.2.4.2. Set whiteboard
> "PossibleRegression".

Sorry, just ignore this word. This bug behaviour also reproduciable in 4.2.4.2. Revised version accordingly.
Comment 4 ign_christian 2014-06-10 04:02:58 UTC
Confirm with 4.0.6.2 - Win7 x86. Looks like an enhancement request
Comment 5 Kevin Suo 2015-06-23 09:46:00 UTC
Bug still exists with:

Version: 5.0.0.1
Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale: zh-CN (zh_CN)
Comment 6 Tim Richardson 2015-07-02 04:34:59 UTC
I confirm this in v5.0 RC2
Comment 7 Kevin Suo 2018-09-30 01:52:41 UTC
Still reproducible

Version: 6.0.6.2
Build ID:0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU 线程:4; 操作系统:Linux 4.15; UI 渲染:默认; VCL: gtk2; 
区域语言:zh-CN (zh_CN.UTF-8); Calc: group