Bug 79818 - DOCX DATALOSS: Line breaks lost after edit-and-save
Summary: DOCX DATALOSS: Line breaks lost after edit-and-save
Status: RESOLVED DUPLICATE of bug 78887
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta2
Hardware: x86 (IA32) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-06-09 07:56 UTC by Kevin Suo
Modified: 2014-06-14 13:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test docx file (3.91 KB, application/vnd.openxmlformats-officedocument.wordprocessingml)
2014-06-09 07:56 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-06-09 07:56:45 UTC
Created attachment 100703 [details]
test docx file

Problem Description:
The attached DOCX file has 5 line breaks (Shift+Enter). After edit-and-save with libreoffice 4.3.0 beta2, 4 line breaks are lost, only 1 is remaining.

Steps to reproduce:
1. Open the attached test file;
2. Do some editing (for example, insert some blank paragraghs below);
3. Save the file and reopen.

Current behaviour:
The 4 line breaks below the first line is lost.

Expected:
Line breaks should remain the same as it was.

Version: 4.3.0 beta 2. (Works OK in 4.2.5.1)
OS: Windows XP SP3.
Comment 1 Jacques Guilleron 2014-06-09 12:25:28 UTC
Hi suokunlong,

I reproduce using LO 4.3.0.0.beta2+
Build ID: 4b5975b1f777c85259bc38afbfae8e1160fbebbe
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-06-08_21:29:21
& Windows 7 Home Premium.

I set Status to NEW.

Regards,

Jacques
Comment 2 Kevin Suo 2014-06-09 13:50:31 UTC
Added to MAB4.3 list.
Comment 3 Michael Stahl (CIB) 2014-06-10 16:22:30 UTC
it works on master but is broken on libreoffice-4-3 branch

... was fixed by:

commit 8555c24e069dc00071eaad23c711f1d1375e5afc
Author:     Ravindra Vidhate <ravindra.vidhate@synerzip.com>
AuthorDate: Wed May 21 14:54:35 2014 +0530

    fdo#78887 <w:br> tag is not being preserved after export.

*** This bug has been marked as a duplicate of bug 78887 ***