Bug Hunting Session
Bug 79835 - LibreOffice should display a message when Base is not installed
Summary: LibreOffice should display a message when Base is not installed
Status: RESOLVED DUPLICATE of bug 75369
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-09 11:49 UTC by Axel Howind
Modified: 2014-06-09 14:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Howind 2014-06-09 11:49:58 UTC
Trying to create a database on a fresh install of Ubuntu failed with no explanation at all. I checked LibreOffice settings, and there's even a settings page for Base.

Google pointed me to this question on askubuntu: http://askubuntu.com/questions/453728/libreoffice-base-not-opening-in-14-04

So, even LibreOffice Base isn't installed in the default installation, at least a message box should open and present a text along the lines of "LibreOffice Base isn't currently installed on this system. Please install LibreOffice Base to proceed."

The current silent failure just leaves the user frustrated.
Comment 1 Maxim Monastirsky 2014-06-09 11:55:07 UTC

*** This bug has been marked as a duplicate of bug 75369 ***
Comment 2 Alex Thurgood 2014-06-09 13:59:41 UTC
You could just pour scorn on the package maintainers at Ubuntu, but I doubt that would get you very far.

TDF doesn't control what the distros do with the code when the distros repackage it. If you want unadulterated packages, get the official ones from the TDF download page, and purge yourself of the Ubuntu supplied ones.

Alternatively, just add the libreoffice base support via apt-get install.
Comment 3 Axel Howind 2014-06-09 14:29:26 UTC
@Alex: Why bother the pacakage maintainers of Ubuntu with this? It's rather clear there is an issue in LibreOffice: LibreOffice "knows" something is wrong with the installation (button flashes red for a part of a second) but then gives no clue whatsoever on how to fix it.

Finding out the cause for this problem doesn't get any better when the Options page *does* show Base settings despite it not being installed. If nothing else, when opening the settings for a non-installed or non-functional package, there should at least be a warning message ("package is missing or not working").

I, as a single user can get this to work (and have already done so). But for LibreOffice to be able to gain a larger market share, things like these have to be ironed out.

There might even be another issue with the Ubuntu packaging as you said, and I could ask them to include Base by default. But do you have any solid numbers about your user base out there? I am sure quite a large portion of those (at least on linux) get LibreOffice simply because it's packaged in the base distribution. If they all have to uninstall and install manually from your packages (unless they find out what is broken in the packaged version), I am sure many will be disappointed and just switch to using an alternative.

Please don't take me wrong, I *want* LibreOffice to succeed. (I still have to use "redmond" at work...)