Download it now!
Bug 80039 - FILEOPEN: Cell background color not imported
Summary: FILEOPEN: Cell background color not imported
Status: RESOLVED DUPLICATE of bug 49177
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:xlsx
Depends on:
Blocks: OOXML-Object-Fill XLSX
  Show dependency treegraph
 
Reported: 2014-06-14 23:24 UTC by Fabian Alexander Wilms
Modified: 2020-07-21 08:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (10.01 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-06-14 23:24 UTC, Fabian Alexander Wilms
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Alexander Wilms 2014-06-14 23:24:45 UTC
Created attachment 101068 [details]
Sample file

Problem description: 
A cell's bg color is not preserved

Steps to reproduce:
1. Open attached file in LibreOffice and MS Office online

Current behavior:
A1 should have a red bg in LibreOffice, too

Expected behavior:
It doesnt
              
Operating System: Windows 7
Version: 4.3.0.0.beta2
Comment 1 Fabian Alexander Wilms 2014-06-14 23:28:41 UTC
It seems like this is related to whether there's a filter applied to the cell or not. If there's a filter, the color is not preserved.
Comment 2 Jacques Guilleron 2014-06-15 11:28:10 UTC
Hello Fabian Alexander,

I reproduce with LO 4.3.0.0.beta2+
Build ID: 4b5975b1f777c85259bc38afbfae8e1160fbebbe
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-06-08_21:29:21,
LO 4.2.4.2 Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
and LO 3.6.6.2
Windows 7 Home Premium

Jacques
Comment 3 Fabian Alexander Wilms 2014-07-30 11:02:20 UTC
Reproducable with Version: 4.3.0.4
Build-ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
Comment 4 Xisco Faulí 2015-08-20 09:39:57 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 5 Robinson Tryon (qubit) 2015-12-09 16:47:39 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2017-03-15 10:25:02 UTC
Still reproducible in

Version: 5.4.0.0.alpha0+
Build ID: d3b5bd4a07a619db6bee1c39c32280ac3c620532
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 7 QA Administrators 2018-07-03 02:38:37 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2020-07-03 03:40:31 UTC Comment hidden (obsolete)
Comment 9 Fabian Alexander Wilms 2020-07-03 03:59:15 UTC
Still reproducible in

Version: 7.0.0.0.alpha1+ (x64)
Build ID: 21875558f6c478f07d68ff39e025d7ffd451674f
CPU-Threads: 8; BS: Windows 10.0 Build 18362; UI-Render: Skia/Vulkan; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
Comment 10 NISZ LibreOffice Team 2020-07-21 08:48:06 UTC
This file has a gradient type cell background.

*** This bug has been marked as a duplicate of bug 49177 ***