Download it now!
Bug 80045 - VIEWING: Draw OLE object showing SVG picture: Parts of Drawing not shown
Summary: VIEWING: Draw OLE object showing SVG picture: Parts of Drawing not shown
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2014-06-15 06:45 UTC by Bugcruncher
Modified: 2018-06-20 16:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Documents (310.75 KB, application/x-7z-compressed)
2014-06-15 06:45 UTC, Bugcruncher
Details
opening svg file VS inserting svg (LibO 4.2.4) (177.01 KB, image/png)
2014-06-15 22:49 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2014-06-15 06:45:29 UTC
Created attachment 101081 [details]
Test Documents

This one is a follow up to [Bug 80014] VIEWING: Horizontal line artifacts in Draw OLE object

Problem description: 
Parts of the Drawing will not be shown in Writer as OLE object. Missing parts of drawing appear if you do y double click
Steps to reproduce:

Already done for test set 
1. Download <http://www.clker.com/cliparts/W/F/u/u/s/H/gps-navigation.svg>
2. Create a Drawing document "gps-navigation_opened.odg"
   by opening "gps-navigation.svg" from LibreOffice File menu
   and saving it 
   (and close document)
3. Create a Drawing document "gps-navigation_imported.odg"
   by inserting "gps-navigation.svg" from "Insert" menu
   and saving it after having adopted page size to drawing
   size
4. Insert both Draw documents as OLE objects into sample.odt
   Compare results

Current behavior:
The dark grey housing of the navigation device is not shown in OLE object viewing in Writer document, but will appear after double click on OLE object.

Not intended to be reported here: Object from "gps-navigation_imported.odg" shows the artifacts problem already reported in [Bug 80014] VIEWING: Horizontal line artifacts in Draw OLE objects. and additionally you see 2 hotizontal lines, thickness as the dashed lines, but not dashed,
what should not be shown (and what disaapear after double click on object)
            
Some explication:
The SVG looks perfect in Writer, but I often create Drawing documents based on such .svg from WWW with own supplements. For this use the bug is irksome.
Operating System: Windows 7
Version: 4.2.4.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-15 22:49:02 UTC
Confirmed in Linux Mint in 3.3.0, 4.2.4 and 4.3 beta.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-15 22:49:55 UTC
Created attachment 101126 [details]
opening svg file VS inserting svg (LibO 4.2.4)
Comment 3 Xisco Faulí 2015-11-20 10:14:30 UTC
This issue is still present in 

Version: 5.1.0.0.alpha1+
Build ID: e6fade1ce133039d28369751b77ac8faff6e40cb
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-16_00:12:42
Locale: es-ES (es_ES)

on Window 7
Comment 4 Xisco Faulí 2015-11-20 10:20:49 UTC
attached file contains a clipPath element that can't be handled by Libreoffice at opening time. Link it to bug 90168
Comment 5 Robinson Tryon (qubit) 2015-12-10 04:35:46 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-01-03 19:42:46 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2018-06-20 16:43:38 UTC
No longer reproducible in

Version: 6.2.0.0.alpha0+
Build ID: 370a30b6acc5b99b6046440f6b5f4f3f5f9f4b1a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Closing as RESOLVED WORKSFORME