Download it now!
Bug 90168 - FILEOPEN: SVG doesn't import clipPath element
Summary: FILEOPEN: SVG doesn't import clipPath element
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 75314 91722 (view as bug list)
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2015-03-23 08:28 UTC by Matthew Francis
Modified: 2018-06-20 17:03 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
SVG file which should be clipped (4.27 KB, image/svg+xml)
2015-03-23 08:32 UTC, Matthew Francis
Details
Screenshot of inserted svg in Draw (Version: 4.5.0.0.alpha0+) (3.34 KB, image/png)
2015-04-04 20:45 UTC, Christina Rossmanith
Details
circles (402 bytes, image/svg+xml)
2015-10-27 16:54 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2015-03-23 08:28:32 UTC
Split from bug 42692

Opening the attached SVG in Draw fails to apply a clipping path. It should show the intersection of a circle and a rectangle, but instead shows the full circle.

Before the below commit, the clipping path is shown separately as a filled black rectangle, but this too was incorrect (i.e. the below changed the behaviour but didn't fix the issue with this file)

    commit 5e27d23d7e665cc0aeac8fc9ea2236bf8bc088ff
    Author:     Chr. Rossmanith <ChrRossmanith@gmx.de>
    AuthorDate: Fri Oct 3 13:51:00 2014 +0200
    Commit:     Thorsten Behrens <thb@documentfoundation.org>
    CommitDate: Fri Oct 10 21:58:26 2014 +0000
    
        fdo#65864: dont't traverse defs-nodes when in shape writing mode
Comment 1 Matthew Francis 2015-03-23 08:32:18 UTC
Created attachment 114263 [details]
SVG file which should be clipped
Comment 2 Buovjaga 2015-03-23 11:50:20 UTC
Confirmed.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 3 Christina Rossmanith 2015-04-04 20:45:52 UTC
Created attachment 114625 [details]
Screenshot of inserted svg in Draw (Version: 4.5.0.0.alpha0+)

SVG is inserted into Draw fine for me. Opening shows the full circle. Version: 4.5.0.0.alpha0+
Comment 4 A (Andy) 2015-04-05 13:48:43 UTC
Reproducible with LO 4.4.1.2, Win 8.1: it shows a full circle instead of a clipped circle
Comment 5 Christina Rossmanith 2015-04-12 18:22:25 UTC
Comment 3 is wrong. Correct comment is: Circle is clipped as documented in the screenshot in the corresponding attachment.
Comment 6 Buovjaga 2015-04-12 18:49:06 UTC
(In reply to Christina Rossmanith from comment #5)
> Comment 3 is wrong. Correct comment is: Circle is clipped as documented in
> the screenshot in the corresponding attachment.

It's not clipped in 4.5 for me.

Version: 4.5.0.0.alpha0+ (x64)
Build ID: 53d7c88da82f6d16c0c9a45a86a3f9d505764605
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-10_02:14:19
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.5.0.0.alpha0+
Build ID: 02bea75dd6bc91759e987fafb5dccec6ce92b0c2
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-03-28_00:19:15
Locale: en_US
Comment 7 Yousuf Philips (jay) (retired) 2015-04-13 07:43:16 UTC
Full circle seen in 3.3 (go-oo filter), 3.6 (oracle filter) and master (apache filter).

Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-31_08:18:46
Comment 8 Regina Henschel 2015-05-12 23:00:14 UTC
Insert > Image is OK. File > Open is wrong. I have used Version: 5.0.0.0.alpha1+
Build ID: e9fbe1f7cd28de2a9da8089d89e903406165eb56 TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-04-25_00:22:55 Locale: de_DE

It is not "Inherit From OOo". Neither OpenOffice 3.4.1 nor any of the Apache OpenOffice versions show this wrong behavior in File > Open. It is a LibreOffice own bug. Apache OpenOffice uses a different implementation for File > Open than LibreOffice. It is not a "Apache filter".

The summary should be changed from "Importing" to "File Open".
Comment 9 Yousuf Philips (jay) (retired) 2015-05-15 22:46:52 UTC
Confirmed behaviour isnt in AOO 4.1.1.
Comment 10 Xisco Faulí 2015-10-27 16:38:15 UTC
*** Bug 91722 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2015-10-27 16:45:44 UTC
*** Bug 75314 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2015-10-27 16:54:39 UTC
Created attachment 120008 [details]
circles
Comment 13 Robinson Tryon (qubit) 2015-12-09 18:52:34 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2017-05-22 13:38:30 UTC Comment hidden (obsolete)
Comment 15 ZioTibia81 2017-05-23 12:39:07 UTC
Still in:

Versione: 5.3.3.2
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
Thread CPU: 2; Versione SO: Windows 5.1; Resa interfaccia: predefinito; Motore layout: nuovo; 
Versione locale: it-IT (it_IT); Calc: group
Comment 16 Roman Kuznetsov 2018-06-18 20:40:20 UTC
opens fine in Draw with File->Open for LO 6.1 beta 2 both SVG from attach

status -> WFM