Download it now!
Bug 80067 - Chart axis in file created with Excel displays incorrect dates
Summary: Chart axis in file created with Excel displays incorrect dates
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-06-15 21:37 UTC by bvieri
Modified: 2015-04-22 14:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
original file (13.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-06-15 21:37 UTC, bvieri
Details
screenshot of file rendered by Calc (209.78 KB, image/jpeg)
2014-06-15 21:47 UTC, bvieri
Details
Screenshot of file rendered by Excel (185.49 KB, image/jpeg)
2014-06-15 21:49 UTC, bvieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bvieri 2014-06-15 21:37:51 UTC
Created attachment 101121 [details]
original file

System:  Libreoffice 4.2.3.3 and Ubuntu 14.04 LTS

The xlsx file created with Excel 2010 contains a scatter chart with a y-axis marked with m:ss time values which Calc shows incorrectly.  

Attached is the original file.  The y axis marks should read from 2:00 to 3:40 at 0:10 intervals.  Calc shows them from 00:00 to 50:00 then 00:00 again to 40:00 at 10:00 intervals. 

Note that Excel handles time values clumsily.  Charts require range and intervals selections as fractions of 24 hours.  see:  
  http://rnm1978.wordpress.com/2011/09/08/labelling-time-axes-in-excel/

Thank you.
Bruno
Comment 1 bvieri 2014-06-15 21:47:19 UTC
Created attachment 101122 [details]
screenshot of file rendered by Calc
Comment 2 bvieri 2014-06-15 21:49:26 UTC
Created attachment 101123 [details]
Screenshot of file rendered by Excel
Comment 3 Jorendc 2014-06-16 13:39:02 UTC
Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

Kind regards,
Joren
Comment 4 GerardF 2014-06-16 17:48:57 UTC
What is the number format of Y-axis in Excel? (I don't have Excel for checking).

When opening the file with LO, Y-axys show data formated MM:SS while the data in the sheet are HH:MM
If I check the "use format source" box, the display is correct (and same as Excel).
Comment 5 bvieri 2014-06-16 19:39:19 UTC
The number format of the y-axis data in the Excel .xlsx file is Custom/h:mm


 

(I don't think it's relevant to the bug but the m:s/500m  label reflects the
actual meaning of the data.  The history is that the data were obtained and
logged in .csv by an Android cellphone running the BoatCoach app using the
format General, e.g. as 2:30/500m meaning a speed equivalent to 500 meters
in 2m 30s   The .csv file was opened in Excel, the /500 "tails" were deleted
manually and the cells reformatted as hh:mm because if mm:ss was selected
(or any other format tried) Excel changed the data.  I think it's because
Excel recognizes only date and clock time and not elapsed time, which is the
case here.  The file was saved as .xlsx)

 

Best regards,

Bruno

 

https://play.google.com/store/apps/details?id=com.eiref.boatcoach

 

 

 

From: bugzilla-daemon@freedesktop.org
[mailto:bugzilla-daemon@freedesktop.org] 
Sent: Monday, June 16, 2014 10:49 AM
To: bvieri@ieee.org
Subject: [Bug 80067] Chart axis in file created with Excel displays
incorrect dates

 

 <mailto:gerard.fargeot@orange.fr> GerardF changed bug 80067
<https://bugs.freedesktop.org/show_bug.cgi?id=80067>  


What

Removed

Added


CC

  

gerard.fargeot@orange.fr 

Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=80067#c4>  on bug
80067 <https://bugs.freedesktop.org/show_bug.cgi?id=80067>  from
<mailto:gerard.fargeot@orange.fr> GerardF 

What is the number format of Y-axis in Excel? (I don't have Excel for
checking).
 
When opening the file with LO, Y-axys show data formated MM:SS while the
data
in the sheet are HH:MM
If I check the "use format source" box, the display is correct (and same as
Excel).
  _____  


You are receiving this mail because: 

*	You reported the bug.
Comment 6 Markus Mohrhard 2015-04-22 14:33:48 UTC
Seems to work correctly in master. MIght have been fixed by one of the many ooxml chart commits recently.