Bug 80077 - "File - Send - Create Master Document / Create HTML Document" always show "Can not create document" in Non-English UI
Summary: "File - Send - Create Master Document / Create HTML Document" always show "Ca...
Status: RESOLVED DUPLICATE of bug 113876
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Writer-Master-Doc File-Send
  Show dependency treegraph
 
Reported: 2014-06-16 05:54 UTC by Kevin Suo
Modified: 2017-12-08 22:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-06-16 05:54:43 UTC
Description:
"File - Send - Create Master Document" and "File - Send - Create HTML Document" do not work. I tested in the following languages: Chinese Simplified, Chinese Tranditional, Japanese, French. When I choose these two menu items, Writer always show the error "Can not create document" (translated).

Steps to reproduce:
1. Switch to a non-English UI;
2. New Writer docoument, type some text (i.e., "test html");
3. Go to menu "File - Send - Create Master Document" or "File - Send - Create HTML Document".

Current Behaviour:
Writer shows error message that the document can not be created.
When is in English UI, no error message is shown, and the master document or HTML document can be created with no problem.

Expected:
Master document and HTML document can be created in non-English UI, no error message is shown.

OS: Windows XP SP3
Version:
4.2.5.1, Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de
4.3.0.0.beta2, Build ID: a06aa316117a6ff0f05c697c82831c227812d810
Comment 1 Kevin Suo 2014-06-16 05:58:06 UTC
(In reply to comment #0)

> 3. Go to menu "File - Send - Create Master Document" or "File - Send -
> Create HTML Document".

You have to type the filename in the file-save dialog, and click "Save".
Comment 2 Kevin Suo 2014-06-16 14:32:02 UTC
I talked with sophi in #libreoffice-qa IRC channel, and she thinks this one is not a bug, because to generate Master document and HTML document, one has to apply (title) styles. And if no styles were applied, those two menus should be grayed-out (which is another bug).

But I do not agree with sophi, because in English UI, I can generate Master Document / HTML Document even I do not apply styles (using the "Default Style"). But in non-English UI, I can not do so.

So I put NeedDevEval in whiteboard.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-16 15:40:24 UTC
Confirmed on Windows 7 with 4.1.6 and 4.2.4 in Arabic and English UI. Testing in Linux Mint on 4.2.4, in English UI the file gets created, but in Arabic UI it fails.
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:21:04 UTC Comment hidden (obsolete)
Comment 5 Kruno 2016-10-16 19:54:48 UTC
(In reply to Kevin Suo from comment #2)
> I talked with sophi in #libreoffice-qa IRC channel, and she thinks this one
> is not a bug, because to generate Master document and HTML document, one has
> to apply (title) styles. And if no styles were applied, those two menus
> should be grayed-out (which is another bug).
> 
> But I do not agree with sophi, because in English UI, I can generate Master
> Document / HTML Document even I do not apply styles (using the "Default
> Style"). But in non-English UI, I can not do so.
> 
> So I put NeedDevEval in whiteboard.

I do not agree as well. And I think this is bug report is duplicate of bug 67260 that I've reported back in 2013.

If it's available in English, it better be in any other language also ;)
Comment 6 Mark Hung 2016-11-22 14:46:49 UTC
Hi, 

I've set both UI and locale to en-US, but it also
failed to create HTML document or master document.
But if I set first paragraph to heading1 with ctrl+1,
I can send to both as HTML and master document both
in English or Chinese(zh_TW) UI.

Can you confirm again that this is (still) an issue?


Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (zh_TW); Calc: single
Comment 7 Kruno 2016-11-22 17:19:55 UTC
I'm using LibreOffice 5.1.6 and can't test on newer version but you're right: I can send to master document in hr locale if there is at least one Heading 1 in a document.

But I can also send to master document completely blank document when using en_US locale.

Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: hr-HR (hr_HR.UTF-8); Calc: group
Comment 8 raal 2017-08-18 17:20:29 UTC
*** Bug 111898 has been marked as a duplicate of this bug. ***
Comment 9 Regina Henschel 2017-08-18 17:34:01 UTC
The feature "Send" generates a master document and several sub-documents from an already existing document. The division depends on the outline level of the headings.
It should not work, if you try it from a document, which has no outline. And for me it does not work in Version: 6.0.0.0.alpha0+
Build ID: f1a896c71c495bdef5861eb664581507b6b9b5bb
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-13_07:38:19
Locale: en-US (de_DE); Calc: group
Comment 10 Yousuf Philips (jay) (retired) 2017-08-21 10:56:19 UTC
(In reply to Mark Hung from comment #6)
> Can you confirm again that this is (still) an issue?

Master document and html both get created with a blank document.

Version: 6.0.0.0.alpha0+
Build ID: a19dc104ec008f0bb44676d63d4764c6d7442a0d
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 11 Gabor Kelemen 2017-08-29 19:31:14 UTC
This function happens here: 
https://opengrok.libreoffice.org/xref/core/sw/source/uibase/app/docsh2.cxx#857

where it implements FN_NEW_GLOBAL_DOC

Especially this part:
 
if ( sPrefix == "Style" )
...
else if ( sPrefix == "Outline" )

stinks as something that *might* break in a different language.
Comment 12 Gabor Kelemen 2017-12-08 22:05:25 UTC
Marking this as duplicate, as bug#113876 already has a patch committed.

*** This bug has been marked as a duplicate of bug 113876 ***