Download it now!
Bug 80087 - FILESAVE: DOCX: File Corruption: Roundtrip file gets corrupted (Invalid Hyperlink)
Summary: FILESAVE: DOCX: File Corruption: Roundtrip file gets corrupted (Invalid Hyper...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA interoperability
Keywords: filter:docx
Depends on:
Blocks: DOCX-Corrupted
  Show dependency treegraph
 
Reported: 2014-06-16 09:08 UTC by Umesh Kadam
Modified: 2017-12-07 16:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
File has a link to local file (14.13 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-06-16 09:08 UTC, Umesh Kadam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Umesh Kadam 2014-06-16 09:08:15 UTC
Created attachment 101153 [details]
File has a link to local file

Problem description: 

Steps to reproduce:
1. Open the file in LO
2. Save as docx
3. Open the file in MSO

Current behavior:
RT file appears to be corrupt. MSO reports file corruption while opening the file.

Expected behavior:
One should be able to open RT without any error messages.

              
Operating System: All
Version: 4.4.0.0.alpha0+ Master
Comment 1 tommy27 2014-10-17 05:28:44 UTC
retested with 4.4.0.0.alpha0+ under Win7x64
Build ID: 2d6dacc1c93bfd4a9086f8fde6b0edbfdeb573c9
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-13_23:44:09

roundtrip file can be opened by Docx readed with no corruption alert.

please retest with recent master and MS Word and give update of the bug status which I temporarily set to NEEDINFO
Comment 2 QA Administrators 2015-05-06 14:15:19 UTC Comment hidden (obsolete)
Comment 3 Alexandr 2015-05-17 07:51:31 UTC
Hello.
I reproduce the bug with LibreOffice 4.3.3 and 5.0.0.0.alpha1+
Build ID: bcbf45d9f94d177c6841ccede3ff0ba69c4f22b1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-04_03:51:16

When I open the saved file in MS Word Viewer or MS Word 2010 I get a message that the file is corrupted.

After saving in LibreOffice 3.5.4 MS Word Viewer still shows error message, but MS Word 2010 opens the file. So, I set regression keyword.

Tommy, what program did you use to check the file after roundtrip?

Umesh Kadam, do you still want to have the bug assigned to you?
Comment 4 tommy27 2015-05-17 08:16:37 UTC
(In reply to Alexandr from comment #3)
> ...
> 
> Tommy, what program did you use to check the file after roundtrip?

I used a freeware tool called Docx reader.



however a more accurate test has to be done with MS Word which I don't have
Comment 5 Xisco Faulí 2015-08-20 12:59:36 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit) with Office 2010
Comment 6 Robinson Tryon (qubit) 2015-12-14 05:35:36 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-09-14 22:55:28 UTC
Hi Umesh,
I'm setting this ticket back to NEW as it has been inactive for more than 3
months.
Feel free to assign it back to you if you're still working on this.
Regards
Comment 8 Xisco Faulí 2016-10-02 22:40:52 UTC
This doesn't seem to be a regression. I've just tested it in

Version: 4.4.0.0.alpha0+
Build ID: eadc132d5fa339b6fe5b2f8bb482ed30dbd2314

which is the build from  2014-10-13 as in comment 1 and the file is corrupted when it's opened in office 2010.

Removing keywords bibisectRequest and regression
Comment 9 Xisco Faulí 2016-12-21 15:38:15 UTC
Open XML SDK 2.5 fails to open it saying: Cannot open the file: Invalid Hyperlink: Malformed URI is embedded as a hyperlink in the document
Comment 10 Bartosz 2017-05-19 11:50:18 UTC
Have you tried to change security level?
https://www.stellarinfo.com/support/kb/index.php/article/resolve-word-error-file-is-corrupted-and-cannot-be-open

Does it helps?


Application for fixing word documents
https://www.stellarinfo.com/repair-word-file.php
Comment 11 Xisco Faulí 2017-05-20 10:14:02 UTC
(In reply to Bartosz from comment #10)
> Have you tried to change security level?
> https://www.stellarinfo.com/support/kb/index.php/article/resolve-word-error-
> file-is-corrupted-and-cannot-be-open
> 
> Does it helps?
> 
> 
> Application for fixing word documents
> https://www.stellarinfo.com/repair-word-file.php

Anyway, LibreOffice is doing something wrong at export time. The original file can be opened by MSO without problem, the roundtripped file not.

Reproduced in

Version: 5.5.0.0.alpha0+
Build ID: fa89a464ca9c76332f533da0ab641da5acd00b52
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-05-19_01:24:56
Locale: es-ES (es_ES); Calc: group

@Bartosz, Are you planning to work on this?
Comment 12 Bartosz 2017-09-12 21:26:37 UTC
Reproduced with LO 5.4.3
It seems that issue is caused by wrong relationship entry in file: word/rels/document.xml.rels

The entry which is causing issue is:
    <Relationship Id="rId2" Type="http://schemas.openxmlformats.org/officeDocument/2006/relationships/hyperlink" Target="file:///G:%3FChromium.Htm" TargetMode="External"/>
Comment 13 Xisco Faulí 2017-12-07 16:34:30 UTC
Issue no longer reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 495ac1bc97f3deea8e13cb1a2b9f59d087873c3f
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: group threaded

closing as RESOLVED WORKSFORME

[Improvement found by office-interoperability-tools]