Bug Hunting Session
Bug 80094 - FILEOPEN DOC Some table edges slip into hiding
Summary: FILEOPEN DOC Some table edges slip into hiding
Status: RESOLVED DUPLICATE of bug 60378
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2014-06-16 13:17 UTC by johannsb-lista
Modified: 2017-10-03 15:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file created in MS Word 2000 (35.50 KB, application/msword)
2014-06-16 13:17 UTC, johannsb-lista
Details
Screen of file RE.doc opened in MS Word 2000 (81.66 KB, image/png)
2014-06-16 13:18 UTC, johannsb-lista
Details
Screen of file RE.doc opened in LibreOffice 4.2.2.1 (85.28 KB, image/png)
2014-06-16 13:19 UTC, johannsb-lista
Details
Screenshot of hidden borders (68.72 KB, image/png)
2017-09-03 13:19 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description johannsb-lista 2014-06-16 13:17:11 UTC
Created attachment 101169 [details]
Original file created in MS Word 2000

Compare the file "RE.DOC" opened with MS Word 2000 and with LibreOffice 4.2.2.1 (see attachments). Our organization have many documents created with MS Word 2000 and we need open them correctly in LibreOffice.

We used LibreOffice Versão: 4.2.2.1
ID de compilação: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

Attachments:

1. "RE.doc" - File created in MS Word 2000
2. "RE-DOC.doc-Microsoft_Word_2000.png" - Screen of file "RE.doc" in MS Word 2000
3. "RE-DOC-4.2.2.1.png" - Screen of file "RE.doc" in LibreOffice 4.2.2.1
Comment 1 johannsb-lista 2014-06-16 13:18:11 UTC
Created attachment 101170 [details]
Screen of file RE.doc opened in MS Word 2000
Comment 2 johannsb-lista 2014-06-16 13:19:16 UTC
Created attachment 101171 [details]
Screen of file RE.doc opened in LibreOffice 4.2.2.1
Comment 3 Jorendc 2014-06-16 13:31:28 UTC
Repro, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810
Comment 4 QA Administrators 2015-07-18 17:43:27 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-10-17 13:56:20 UTC
Now it is even more messed up. The cell contents are in the wrong cells.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 6 QA Administrators 2016-11-08 11:35:46 UTC Comment hidden (obsolete)
Comment 7 Justin L 2017-09-03 00:32:35 UTC
It looks to me like this was fixed in 5.0 for bug 90504 by
commit b7fff04ad728369a09a5e1a5cfbe494cf388317b
Author:     Caolán McNamara 
CommitDate: Tue Apr 7 21:09:05 2015 +0100
  Resolves: tdf#90504 0x7 chars in .doc are not always cell/row ends
  fdo65094-2.doc shows that a 0x7 isn't always a row/cell end
  only a 0x7 that is right at the end of the paragraph range is
  a real row/cell end

I don't know what Buovjaga saw in comment 5...
Comment 8 Buovjaga 2017-09-03 13:19:19 UTC
Created attachment 135985 [details]
Screenshot of hidden borders

It's almost perfect, but some cell edges still go into hiding as illustrated in by the screenshot.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 4082b5874adddedf8332fe977b6bb47b6949b302
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 31st 2017
Comment 9 Xisco Faulí 2017-10-03 15:02:24 UTC

*** This bug has been marked as a duplicate of bug 60378 ***