Bug 80134 - START CENTER: 'Base Database' is not being translated to Arabic
Summary: START CENTER: 'Base Database' is not being translated to Arabic
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks: RTL-Arabic
  Show dependency treegraph
 
Reported: 2014-06-17 13:21 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 01:05 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
4.2 - start center in arabic (263.99 KB, image/png)
2014-06-17 13:21 UTC, Yousuf Philips (jay) (retired)
Details
4.1 - start center in arabic (46.93 KB, image/png)
2014-06-17 13:31 UTC, Yousuf Philips (jay) (retired)
Details
Start Center on windows 7 (44.83 KB, image/png)
2014-06-17 14:26 UTC, Ibrahim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-17 13:21:22 UTC
Created attachment 101232 [details]
4.2 - start center in arabic

On Linux and Windows, when the UI is in arabic in 4.2.4 and 4.3, key string 3FFPp for 'Base Database' is not being shown in arabic on the start center. Before the start center appeared, it was fine in 4.1.6.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-17 13:31:54 UTC
Created attachment 101233 [details]
4.1 - start center in arabic
Comment 2 Ibrahim 2014-06-17 14:24:58 UTC
Confirmed on Windows 7 in 4.2.4
Comment 3 Ibrahim 2014-06-17 14:26:53 UTC
Created attachment 101234 [details]
Start Center on windows 7
Comment 4 Julien Nabet 2014-06-17 19:20:16 UTC
just for information, https://wiki.documentfoundation.org/Language_Teams give people who deal with the different localizations.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-17 19:52:22 UTC
just for further information, the entry is already translated, and has been from atleast 4.2.0, but is just not displaying.
Comment 6 Julien Nabet 2014-06-17 19:54:00 UTC
Andras: I thought you might be interested in this tracker. Pootle problem here?
Comment 7 Andras Timar 2014-06-17 21:15:59 UTC
It's marked as fuzzy now. 
sfx2/uiconfig/ui.po-#: startcenter.ui
sfx2/uiconfig/ui.po-#, fuzzy
sfx2/uiconfig/ui.po-msgctxt ""
sfx2/uiconfig/ui.po-"startcenter.ui\n"
sfx2/uiconfig/ui.po-"database_all\n"
sfx2/uiconfig/ui.po-"label\n"
sfx2/uiconfig/ui.po-"string.text"
sfx2/uiconfig/ui.po:msgid "Base D_atabase"
sfx2/uiconfig/ui.po-msgstr "_قاعدة بيانات بيز"

By the way, Arabic translation is far from complete (88%).
Comment 8 Yousuf Philips (jay) (retired) 2014-06-27 00:51:17 UTC
Excuse my ignorance but what does 'marked as fuzzy' mean. I am currently working on completing the arabic UI translation with a friend and hope to have it done by 4.3 release next month.
Comment 9 David Tardon 2014-06-29 04:11:24 UTC
(In reply to comment #8)
> Excuse my ignorance but what does 'marked as fuzzy' mean. I am currently
> working on completing the arabic UI translation with a friend and hope to
> have it done by 4.3 release next month.

It is gettext terminology. It means that the original string has changed since the translation, so the translated string needs to be reviewed and possibly changed too.
Comment 10 Yousuf Philips (jay) (retired) 2014-06-29 05:15:13 UTC
I can see that the string is at < https://translations.documentfoundation.org/ar/libo_ui/translate/sfx2/uiconfig/ui.po#unit=48728472 > and that it has 'Needs Work' enabled on it and also noticed that Needs Work has a query of 'filter=fuzzy' on it. Is there any means to know what the old string looked like before the translation was turned fuzzy, in order to compare?

As a side note, who do i speak to about entries in the UI that dont have string reference numbers, as i found a number of them in the Tools > Options > Load/Save > General > 'Always save as' drop down menu.
Comment 11 David Tardon 2014-06-30 06:28:23 UTC
(In reply to comment #10)
> As a side note, who do i speak to about entries in the UI that dont have
> string reference numbers, as i found a number of them in the Tools > Options
> > Load/Save > General > 'Always save as' drop down menu.

You should report a bug.
Comment 12 Alex Thurgood 2015-01-03 17:40:36 UTC
Adding self to CC if not already on
Comment 13 Robinson Tryon (qubit) 2015-03-05 18:18:36 UTC
(In reply to Jay Philips from comment #8)
> ..I am currently
> working on completing the arabic UI translation with a friend and hope to
> have it done by 4.3 release next month.

Sounds like bibisect is irrelevant.
Whiteboard -> bibisectNotNeeded
Comment 14 Yousuf Philips (jay) (retired) 2015-03-06 09:45:15 UTC
This has been fixed.
Comment 15 Robinson Tryon (qubit) 2015-12-17 08:23:44 UTC
Migrating Whiteboard tags to Keywords: (bibisectNotNeeded)
[NinjaEdit]