Download it now!
Bug 80301 - FILEOPEN: Libreoffice crashes when opens spreadsheet
Summary: FILEOPEN: Libreoffice crashes when opens spreadsheet
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA target:4.5.0 target:4.4.0.0.beta2
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-06-20 18:37 UTC by Yan Pas
Modified: 2014-11-25 08:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
That file, which hangs LO (31.91 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-06-20 18:37 UTC, Yan Pas
Details
bt console from master sources (25.91 KB, text/plain)
2014-06-20 21:14 UTC, Julien Nabet
Details
proposed patch (1.10 KB, patch)
2014-06-20 22:47 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2014-06-20 18:37:28 UTC
Created attachment 101449 [details]
That file, which hangs LO

Problem description: 
I've finded site with MS Office templates. I choosed one of them, opened it in Excel Web app, and than downloaded it from Skydrive to my Linux PC. Then I opened it with libreoffice. LO immediatly hanged and suddenly windows has become grey. That was reproduced may times. Even after reboot.

Running from terminal doesn't log any errors
Operating System: Ubuntu
Version: 4.2.5.2 rc
Comment 1 afonit 2014-06-20 20:00:12 UTC
I downloaded the file and opened it with LO 4.2.5.2, the file opened without issue.
I am unable to reproduce the hang the bug reporter has noted.

  (Fedora 20)
Comment 2 Julien Nabet 2014-06-20 21:14:03 UTC
Created attachment 101460 [details]
bt console from master sources

On pc Debian x86-64 with master sources updated today (with enable-debug), I could reproduce the crash.
(with 4.2 sources updated 2 weeks ago (with enable-debug) I had a crash too)

However with LO Debian package 4.2.4, I can open the file without problem.
Comment 3 Yan Pas 2014-06-20 21:34:27 UTC
(In reply to comment #2)
> Created attachment 101460 [details]
> bt console from master sources
> 
> On pc Debian x86-64 with master sources updated today (with enable-debug), I
> could reproduce the crash.
> (with 4.2 sources updated 2 weeks ago (with enable-debug) I had a crash too)
> 
> However with LO Debian package 4.2.4, I can open the file without problem.

I've checked situation in Windows - everything is fine. But in Ubuntu 14.04 x64 (on both machines: notebook and desktop) with added official LO repository  I see crash. Maybe LO needs some elements to open this spreadsheet?

PS I've met another such a file. Not sure that it was xlsx, but surely some of Microsoft docs - and situation was pretty the same. I didn't repoted that, coz I was newbie :( Well If I'll find another similar file I will attach it here and make another report.
Comment 4 Julien Nabet 2014-06-20 21:37:30 UTC
Yan: which LO version are you using on Windows?

The problem seems to be "НеобходимоЗачетныхЕдиниц" is parsed as a double whereas it's a defined name (see bt)

I put in See Also fdo#75372 which seem to have the same problem.

Kohei/Markus/Eike: one for you?
Comment 5 Yan Pas 2014-06-20 21:44:36 UTC
(In reply to comment #4)
> Yan: which LO version are you using on Windows?
> 
> The problem seems to be "НеобходимоЗачетныхЕдиниц" is parsed as a double
> whereas it's a defined name (see bt)
> 
> I put in See Also fdo#75372 which seem to have the same problem.
> 
> Kohei/Markus/Eike: one for you?

I've just (an hour ago) download latest to windows, 4.2.5

I'm russian speaker, so the russificated templated is translated as НеобходимоЗачетныхЕдиниц=NecessaryCredits or NecesarryCompetitiveUnits. But I think it's just name of spreadsheet cell, so it's unimportant.
Comment 6 Julien Nabet 2014-06-20 22:47:32 UTC
Created attachment 101462 [details]
proposed patch

If it's a formula, we shouldn't call "rAttribs.getDouble", should we? (see proposed patch attached which makes LO not crash but didn't check if result was ok)
Comment 7 Commit Notification 2014-11-22 23:59:38 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37ac70c117a7b8b9ac66b583a793096c3ad87a11

make sure to check for formula first, fdo#80301

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-11-25 08:33:03 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2987635da7c46874c3d1b7979b70dec0de4b69b1&h=libreoffice-4-4

make sure to check for formula first, fdo#80301

It will be available in 4.4.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.