Bug 80315 - Other: Formulas are changing automatically
Summary: Other: Formulas are changing automatically
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2014-06-21 06:57 UTC by Seppo Jyrkinen
Modified: 2015-09-04 03:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:

Firs table "sato" there arte F column filled with # and "hehtaarisato" line 11 filled with "Virhe....." (79.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-21 06:57 UTC, Seppo Jyrkinen

Note You need to log in before you can comment on or make changes to this bug.
Description Seppo Jyrkinen 2014-06-21 06:57:48 UTC
Created attachment 101468 [details]
Firs table "sato" there arte F column filled with # and "hehtaarisato" line 11 filled with "Virhe....."

Shell address in a table changes automatically even if I haven't done any changes on that table
Original formula =SUMMA(C6:C10)/5
Formula a few days later =SUMMA(C6:H11)/5
Typical to this version is:
- only one thing changes, the shell address after double dot, like :C10 => :H11
- formula is situated inside the data-area which makes it impossible to calculate
- I haven't done any changes on that table (and I am the only person to use this computer)
An example is in my home pages www.jyrkinen.fi/asioita/Elintarviketilanne-testi.ods 
Originally this file has 6 tables and I've done a lot of changes with rows and columns. Tables has no links to each others. A few times has happened that my computer goes very slow and screen goes dark (not black), perhaps for 5 seconds and then everything goes fine. I haven't anyhow checked the whole file after jam problems. Some times I have also chosen the whole table by clicking the upper left corner to ordain Nimbus Mono L to whole table.

I'll make an another report about division problems. Might have a connection.

Operating System: Ubuntu
Version: release
Comment 1 Seppo Jyrkinen 2014-06-25 13:08:49 UTC
I corrected formulas yesterday and made two copies with different names. Today malfunctions are back, mostly same as before. A new version is, that formula is outside data-area which means that there is no ### neither Error:522 as before (or at least I haven't noticed such).

For example formula is in a shell E11 and yesterday it was =SUMMA(E6:E10)/5, but today formula is =SUMMA(E6:I10)/5. And because area E6:I10 has only numerical values, nothing gives a warning about problem.

This time there was no jamming with the computer.
Comment 2 Seppo Jyrkinen 2014-07-24 15:01:54 UTC
New information:

This problem is limited to formulas which has double dot : and I'm using Finnish Keyboard which goes ZXCVBNM;:_. 

In a shell F6 there is formula =SUMMA(C6:E6)/3 and problems several times, but in a shell C35 formula is =SUMMA(C6+C15+C26) and never any difficoulties.

Problems wakes up after I delete a whole row or a column. Next day there might be problems.
Comment 3 ign_christian 2014-07-24 15:16:29 UTC
Hi Seppo, your attached file is too complex & it's hard to analyze the problem. Could you provide simple steps to see the problem?

Have you tried LO and reset user profile?
Comment 4 Seppo Jyrkinen 2014-07-24 17:03:52 UTC
Hello Christian

More simple version: http://www.jyrkinen.fi/asioita/Elintarviketilanne-testi-2.ods
1-dimensional problem f.ex. in a shell sato.F5
2-dimensional problem f.ex. in a shell hehtaarisato.D11

Problem don't come out every time when I delete rows/columns. Usually I wake up to problem when I open the file next day.

I've tried only this LO Version:, translation ID: 420m0(Build:2)
Comment 5 ign_christian 2014-08-02 07:53:49 UTC
Your file is already screwed up. Without reproducible steps looks like nothing we can do to observe.

Please try again with LO or, and reset user profile. If problem still persist then please change status of this bug to UNCONFIRMED.

*) Escpecially we want to know the trigger for this:
> Original formula =SUMMA(C6:C10)/5
> Formula a few days later =SUMMA(C6:H11)/5
If you have suspicion regarding deletion, after you do a deletion then immediately save-close-reopen file. Remember what is the trigger if there is a change, then report here..
Comment 6 Timur 2014-12-30 18:28:45 UTC
Can you please check in Calc: Tools-Options-Calc-General whether you have "Expand references.." on?
Comment 7 Seppo Jyrkinen 2014-12-30 19:00:32 UTC
Does this help: http://www.jyrkinen.fi/asioita/elintarviketilanne-asetukset.png
Comment 8 QA Administrators 2015-07-18 17:35:58 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 9 QA Administrators 2015-09-04 03:01:18 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Message generated on: 2015-09-03