Bug 80316 - Other: Formulas overrules division part
Summary: Other: Formulas overrules division part
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-21 07:11 UTC by Seppo Jyrkinen
Modified: 2015-04-05 19:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (23.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-04-05 19:20 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Seppo Jyrkinen 2014-06-21 07:11:14 UTC
Shell formula has a division part, but Calc overrules this automatically - I haven't done any changes on that table.
Formula was =SUMMA(C6:E6)/3 and when I made it, this works correct. After a few days formula looks the same, but result is like =SUMMA(C6:E6)
This has happened only one time, but in a same table there was systemically several malfunctions. This is the same file and table as bug report 80315.
Originally this file has 6 tables and I've done a lot of changes with rows and columns. Tables has no links to each others. A few times has happened that my computer goes very slow and screen goes dark (not black), perhaps for 5 seconds and then everything goes fine. I haven't anyhow checked the whole file after jam problems. Some times I have also chosen the whole table by clicking the upper left corner to ordain Nimbus Mono L to whole table.

I've done an another report about shell address problems, Bug 80315. Might have a connection.

              
Operating System: Ubuntu
Version: 4.2.3.3 release
Comment 1 raal 2014-08-20 07:07:56 UTC
Setting as needinfo, see the comment 5 in bug 80315
Is this bug duplicate of the bug 80315?
Comment 2 QA Administrators 2015-04-01 14:46:55 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 Seppo Jyrkinen 2015-04-05 11:29:08 UTC
My English is not the best possible so details are a problem. I'm not sure if 80315 and 80316 are same problem, but very similar.
 
A problem still exist and I think I have found more info. If you add a horizontal line in the middle of calculation table, this changes formula. Reaction is very similar to bugs I informed earlier.

You can test with a small table: http://www.jyrkinen.fi/asioita/testi.ods
Formula in a shell E6 is =SUMMA(C6:D6) but if you add a line between b and c, the formula changes to =SUMMA(C13:D14) even if it shouldn't.
Comment 4 raal 2015-04-05 19:20:38 UTC
Created attachment 114637 [details]
test file

Hello,
I can not reproduce with your test file.
Version: 4.4.3.0.0+
Build ID: 3eba5eb1774ab621a1f0f4dcc7e82cce6c025b0a
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-03-27_09:07:12

Steps
- open file
- select row 5
- right click->Insert rows above
- formula is =SUM(C7:D7)

Please test with actual version of LO, http://www.libreoffice.org/download/libreoffice-fresh/
Seems to be fixed in actual version. LO 4.2 is EOL, no new fixes.
Closing bug as Worksforme, set again to unconfirmed if my steps are wrong, and you still see the error in actual version of LO. Thank you.