Bug Hunting Session
Bug 80321 - fileopen CSV text import dialog box pushes itself to the back about 75% of the time
Summary: fileopen CSV text import dialog box pushes itself to the back about 75% of th...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV-Dialog
  Show dependency treegraph
 
Reported: 2014-06-21 10:00 UTC by selden
Modified: 2017-07-20 19:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description selden 2014-06-21 10:00:24 UTC
After double-clicking (selecting) a CSV file in a Windows 7 Pro x64 Explorer window, about 75% of the time, LibreOffice's spreadsheet's initial text import dialog box pushes itself to the back, hiding behind other open windows. This is quite exasperating.

It should always push itself to the front.

(Apache OpenOffice has the same problem. I explicitly switched to LibreOffice in the hope that this problem wouldn't be present. But it is.)
Comment 1 Yousuf Philips (jay) (retired) 2014-06-21 11:30:55 UTC
I tried reproducing this on Windows 7 Pro 64-bit and didnt have much luck. Did this happen in previous versions like 4.1.6 or 4.2.4?
Comment 2 selden 2014-06-21 12:12:17 UTC
Sorry: I don't know about previous versions. I only started using LibreOffice this morning, after getting so frustrated with OpenOffice doing the same thing. I've only recently been doing a lot with .CSV files. 

(Having to respond with "OK" to that same text format query every time I open a .CSV is its own frustration, since I'm doing it so frequently. They're actually data files generated by analysis programs. Converting them to binary formats every time would be even worse.)
Comment 3 selden 2014-06-21 12:16:41 UTC
FWIW, I almost could be convinced that the "double click" used to select the file is being interpreted by the system as a "triple click" (with the 3rd click pulling the Explorer window to the front) except that I have not seen any other indications that such a thing (button mouse bouncing) is happening.

I'm using a Microsoft 5-button Intellimouse.
Comment 4 Yousuf Philips (jay) (retired) 2014-06-21 17:40:52 UTC
Well if you could possibly test it with another mouse, that would be helpful.
Comment 5 Maxim Monastirsky 2014-06-22 07:34:17 UTC
Does it happen only if libreoffice is already running? (In that case it's probably a duplicate of bug 32935)
Comment 6 selden 2014-06-22 09:56:15 UTC
You can close this ticket.
The problem was indeed in the mouse and went away when I replaced it. :(
I'm very sorry to have bothered you.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-22 15:57:54 UTC
Glad we were able to solve your problem. :)