Bug 80370 - Other: Crash when opening solver
Summary: Other: Crash when opening solver
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.5.0
Keywords: notBibisectable, regression
: 82086 84723 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-22 23:54 UTC by Christopher Chavez
Modified: 2015-12-17 10:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash report, 4.3.0.1 x86-64 (58.49 KB, text/plain)
2014-06-22 23:54 UTC, Christopher Chavez
Details
Crash report, 4.4.0.0alpha0 x86-64 (73.58 KB, text/x-log)
2014-09-26 01:12 UTC, Christopher Chavez
Details
Fragment of SAL_LOG=yes output (781 bytes, text/plain)
2015-01-29 07:58 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Chavez 2014-06-22 23:54:23 UTC
Created attachment 101546 [details]
Crash report, 4.3.0.1 x86-64

I am running OS X 10.9.3. I was originally going to check if the linear solver was available (it wasn't in 4.2.5.2 for example), but now when opening the solver (Tools -> Solver), even for an empty spreadsheet and regardless of enabling the JRE or not, it crashes. Attached is the crash report. Note that I used x86-64 "for 10.8 or higher".
Comment 1 Jorendc 2014-07-04 13:27:54 UTC
I fail to reproduce, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.5.2
Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5 also the x86-64 version.

Kind regards,
Joren
Comment 2 Jorendc 2014-07-04 13:30:45 UTC
I can reproduce using Mac OSX 10.9 with LibreOffice 4.3.0.2 r2.

Kind regards,
Joren
Comment 3 Markus Mohrhard 2014-07-18 17:21:35 UTC
Can't reproduce it on Linux 4-3 and master.
Comment 4 Marc Kaulisch 2014-07-18 19:04:27 UTC
can reproduce it with Windows 8.1 on 4.3.0.2 when Java is disabled.
I get the notification that Java should be enabled - and then crash

After next start I enabled java and Solver starts and ends without crash
Comment 5 Marc Kaulisch 2014-07-18 19:27:21 UTC
I cannot reproduce it anymore with 4.3.0.3 (Windows 8.1)
Comment 6 Christopher Chavez 2014-07-19 00:15:45 UTC
Still present as originally described with 4.3.0.3 (RC3), OS X x86-64 (running 10.9.4)
Comment 7 createdJustForThisBug 2014-08-02 17:53:38 UTC
It's also present in 4.3.0.4. Same details (10.9.4, x86-64)
Comment 8 retired 2014-08-03 13:20:44 UTC
*** Bug 82086 has been marked as a duplicate of this bug. ***
Comment 9 Markus Mohrhard 2014-08-15 22:30:02 UTC
Do the people who can report this issue run daily builds? The check for conformance according to the exception specification should only be enabled in developer builds (surely not in release builds).
Comment 10 Stormont 2014-09-25 06:29:58 UTC
(In reply to comment #9)
> Do the people who can report this issue run daily builds? The check for
> conformance according to the exception specification should only be enabled
> in developer builds (surely not in release builds).

I see this too, with the release build for 4.3.1.2, running on Win 7 64-bit.
Comment 11 Christopher Chavez 2014-09-26 00:48:11 UTC
(In reply to comment #9)
> Do the people who can report this issue run daily builds? The check for
> conformance according to the exception specification should only be enabled
> in developer builds (surely not in release builds).

I have tested again with master_nightlies~2014-09-25_11.30.29_LibreOfficeDev_4.4.0.0.alpha0_MacOS_x86-64 on OS X 10.9.5, and the issue persists. I don't know what you're referring to or where to find it, and whether it will appear in the diagnostic report generated by OS X or somewhere else (there is nothing printed to the terminal by running LibreOfficeDev.app/Contents/MacOS/soffice).
(I'm not a developer yet, sorry.)

Again, going off what was the case when this was reported, there is probably a regression somewhere between 4.2.5.2 (maybe even 4.2.6--c.f. bug 82086) and 4.3.0.1. I can't complete the bibisect anytime soon, someone else can go right ahead.
Comment 12 Christopher Chavez 2014-09-26 01:12:50 UTC
Created attachment 106883 [details]
Crash report, 4.4.0.0alpha0 x86-64
Comment 13 Dave Richards 2014-12-05 15:34:45 UTC
Unable to create a bibisect on Linux, sorry.  Cannot replicate the crash.
Comment 14 Matthew Francis 2014-12-06 13:07:26 UTC
Still occurs on OSX with LO 4.3.4.1 and recent 4.5 master.

There are older bibisect repositories for Mac but unfortunately they stop before this bug was introduced, so setting this to Whiteboard:notBibisectable for now.
Comment 15 Matthew Francis 2015-01-29 07:58:24 UTC
Created attachment 112904 [details]
Fragment of SAL_LOG=yes output

The attached fragment of SAL_LOG=yes output suggests that we are trying to load libCbc.3.dylib from the wrong place when Solver is invoked
Comment 16 Matthew Francis 2015-01-29 08:13:19 UTC
*** Bug 84723 has been marked as a duplicate of this bug. ***
Comment 17 Stephan Bergmann 2015-02-02 08:33:05 UTC
fixed on master towards LO 4.5 with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=f694ab5198587dcacd8c40c9095e7bc9435cbff2> "tdf#80370: Fix Mac OS X install names of external/{coinmp,lpsolve}"
Comment 18 Robinson Tryon (qubit) 2015-12-17 10:57:08 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]