Bug 80386 - EDITING: Poor performance when scolling imported pdf with images in it
Summary: EDITING: Poor performance when scolling imported pdf with images in it
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-06-23 10:05 UTC by Kevin Suo
Modified: 2014-11-26 08:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test pdf file (86.55 KB, application/pdf)
2014-06-23 10:05 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-06-23 10:05:18 UTC
Created attachment 101567 [details]
test pdf file

Steps to reproduce:
1. Open the attached test pdf with Draw;
2. Zoom the slide to 100%, and try to scroll up and down with the scroll bar.

Current Behaviour:
LibreOffice "freezes" for a while before the slide is srolled (not smooth).

OS: Windows XP SP3, 3.0GHz CPU, 2G RAM.
Version: 4.3.0.1
Comment 1 Kevin Suo 2014-06-23 10:05:58 UTC
Added bug 80385 (PDF Import: Poor image quanlity) as see also.
Comment 2 Firas Hanife 2014-06-23 14:01:49 UTC
Reproduced with 4.2.4.2, 4.2.5.2 and 4.3.0.1 on openSUSE.
The issue is not present on 4.1.6.2.

Draw is not responsive at all while scrolling (the hardware is not the issue, I'm on quadcore i3770 + ssd + amd 7870hd).

Changing Status to NEW.
Comment 3 Alexandr 2014-07-15 15:39:48 UTC
I partially reproduce the bug with LibreOffice 4.2.5 from Debian Wheezy backports x86_64: scrolling is extremely slow, but Draw does not freeze. Scrolling is perfect in LibreOffice 4.3.0.2 on Debian Jessie. I remember that the issue was awful and scrolling after zoom was impossible for most of (all?) pdf with earlier 4.3 versions. 

Please, try LibreOffice 4.3.0.2 or later.
Comment 4 Kevin Suo 2014-11-26 08:27:05 UTC
Works for me in Win 7 X64, scrolling is perfect.
I don't use Win XP anymore. Thus mark as WORKSFORME.

@Alexandr: Thanks for testing.
Comment 5 Kevin Suo 2014-11-26 08:27:40 UTC
(In reply to Kevin Suo from comment #4)
The version I tested was 4.3.4.1 release.