Bug Hunting Session
Bug 80393 - Deleting sheet on spreadsheet cause a crash
Summary: Deleting sheet on spreadsheet cause a crash
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-23 12:35 UTC by Pär Helenius
Modified: 2017-01-26 13:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The file is weather statistic for the first half of year 2014. Size is about 4,5 Mb. Spreadsheet contains of 27 sheet v 1 - v 26 and a linksheet. (304 bytes, text/plain)
2014-06-23 12:55 UTC, Pär Helenius
Details
File is zipped and only 3,667 MB (77 bytes, text/plain)
2014-06-23 14:13 UTC, Pär Helenius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pär Helenius 2014-06-23 12:35:18 UTC
I have a spreadsheet containing statistics for the weather in the firts half year of 2014 (week 1 - 26)
To continnue with the next half year I copied this spreadsheet and tried to delete sheets of weeks 1 - 25. Then the system crasched.
I tried again deleting only the first week (v 1), again a crash.

When I tried with OpenOffice 4.2 it worked, but slowely.

I want to do this because every sheet contains both of cells and diagrams. I have not found another way to copy a diagram from a sheet to another.

Regards 
Pär Helenius
Comment 1 Pär Helenius 2014-06-23 12:55:11 UTC
Created attachment 101588 [details]
The file is weather statistic for the first half of year 2014. Size is about 4,5 Mb.  Spreadsheet contains of 27 sheet v 1  - v 26 and a linksheet.
Comment 2 Firas Hanife 2014-06-23 13:20:07 UTC
Hello  Pär Helenius,
thanks for the report.

The file you added on OneDrive is not accessible. Could you provide a copy using Dropbox or any other cloud storage system and add a link to it? You can also try to .zip it and see if you can upload it.
Otherwise we won't be able to find/fix your issue.
Comment 3 Pär Helenius 2014-06-23 14:13:14 UTC
Created attachment 101594 [details]
File is zipped and only 3,667 MB
Comment 4 Firas Hanife 2014-06-23 14:15:10 UTC
Send me the file by e-mail (click on my name).
Comment 5 Firas Hanife 2014-06-23 14:18:30 UTC
The problem is not your file, but the way you link it. We are not allowed to access the file, only you can with your private profile.
I suggest you to send me the file as an attachment (not link) with an e-mail and I'll proceed attaching it to the report.

Thanks
Comment 6 Firas Hanife 2014-06-23 14:25:48 UTC
Here is the file to test with:
https://www.dropbox.com/s/a4ocxbmprxdkt4m/80393-TestingFile.zip

Setting status back to UNCONFIRMED.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-24 01:06:51 UTC
Dear Par,

Can you please tell us which version of windows your on and how much ram do you have.
Comment 8 V Stuart Foote 2014-06-24 02:08:07 UTC
On Windows 7 sp1, 64-bit us-EN
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

High memory use 300K+ but no issue with deletion of single sheet, or spans of sheets up to 10 sheets. But deleting just 6 sheets with a gap I did get a crash.

With a large selection a gap in the sheets being deleted seems to trigger a crash. Guess that could be loss of reference.

Selecting and deleting ~15 weeks, then attempting to save the calc document does consistently cause an unrecoverable hang.

Setting new.
Comment 9 Yousuf Philips (jay) (retired) 2014-06-24 04:24:42 UTC
On Windows 7 with LibO 4.2.4, it crashed after deleting sheet 7 starting from sheet 1. Each sheet i deleted caused LibO to increase the cpu to 50% on the 2 core cpu for 5 to 10 seconds and at the time of crashing LibO had reached 324.5mbs of memory.
Comment 10 Yousuf Philips (jay) (retired) 2014-06-24 04:44:56 UTC
On Linux Mint with LibO 4.2.5, the file loaded and soffice.bin took up 161mb when i reached sheet 1 for deleting it. after okaying the delete, LibO froze for possibly 5 minutes and during that time 1 of the 2 cpus was running at 100% and soffice.bin was eating away at more and more ram until it got to 692mb when it unfroze. Deleting sheet 2, had the same effect with the cpu and soffice.bin eat up 1.1gb before it unfroze, which also took awhile. I didnt continue after that.
Comment 11 Pär Helenius 2014-06-24 07:45:04 UTC
Hi 
I run WSindows 7 SP1 64 bit on a machine Acer aspire 5552g with a processor AMD Phenom II X3 N830, 4 GB DDR3 memory.
In the beginning I had default settings on Workmemory in settings. Then I sat it up to max and no difference.

I started to delete weeks 1 - 25. It worked at the first time quite well but when I saved the file it crashed.
Next time I opened the crasced file, rebuilt it and there were all 26 weeks. I tried again but cose only weeks 1 - 4. It took a while, almost the same time (not weth any measuring clock) as at the first time, but when saveing, crasch. Thel I tried only deleting week 1, crash.
Comment 12 QA Administrators 2015-12-20 16:21:40 UTC Comment hidden (obsolete)
Comment 13 QA Administrators 2017-01-03 19:51:18 UTC Comment hidden (obsolete)
Comment 14 Xisco Faulí 2017-01-26 11:10:51 UTC
@Jay, Could you try to reproduce this bug in master again and see if the crash is still reproducible ?
Comment 15 Yousuf Philips (jay) (retired) 2017-01-26 13:11:56 UTC
Loading and deleting sheets seem to be fine now.

Version: 5.3.0.1.0+
Build ID: d1b8074ffe4b945a41e3ad9e1fb43332d78d73fb
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-5-3, Time: 2017-01-10_23:02:10
Locale: en-US (en_US.UTF-8); Calc: group