Download it now!
Bug 80409 - FILEOPEN: Opening a file changes its modification date attribute (just opening, no action performed on the document)
Summary: FILEOPEN: Opening a file changes its modification date attribute (just openin...
Status: RESOLVED DUPLICATE of bug 75467
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-23 14:53 UTC by Adriano Belletti
Modified: 2014-08-25 09:23 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example worksheet which demonstrates the bug. (Macros have to be activated) (26.57 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-24 12:05 UTC, marc-henning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adriano Belletti 2014-06-23 14:53:41 UTC
Problem description:
Opening a file changes its modification date attribute.

Steps to reproduce:
1. open an XLS file with libreoffice with an aged modification time attribute

Current behavior:
the XLS file is opened and its mtime attribute is changed to now, without any saving action performed by the user.

Expected behavior:
the XLS file is opened, but its mtime attribute doesn't change, unless it is saved by the user.


* I suspect this behavior is common for other file type, and perhaps not only for spreadsheet.

(MacOS 10.6.8)
Operating System: Mac OS X
Version: 4.2.5.2 release
Comment 1 marc-henning 2014-08-24 12:05:27 UTC
Created attachment 105196 [details]
Example worksheet which demonstrates the bug. (Macros have to be activated)

This file contains a macro which provides of a function to insert the last modification date and time to the worksheet.
Comment 2 marc-henning 2014-08-24 12:10:46 UTC
I guess the bug here is very similar to the one found in Microsoft Excel (KB826741):

This problem occurs because when you open an Excel workbook, Excel writes the name of the current user to the header of the file. This is necessary so that other users receive the "file in use" notification. The operating system then updates the last modified date. 

There is a binary difference between the file contents before you open and close an Excel workbook without saving it and after you open and close an Excel workbook without saving it.
Comment 3 Adriano Belletti 2014-08-25 09:23:26 UTC

*** This bug has been marked as a duplicate of bug 75467 ***