Bug 80418 - FILESAVE: Grouped columns not shown when saving as .xlsx
Summary: FILESAVE: Grouped columns not shown when saving as .xlsx
Status: RESOLVED DUPLICATE of bug 64613
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-23 18:28 UTC by Guillermo Cotone
Modified: 2014-06-24 02:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (4.61 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-06-23 18:28 UTC, Guillermo Cotone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillermo Cotone 2014-06-23 18:28:52 UTC
Created attachment 101602 [details]
sample file

Problem description: 
When using the group/ungroup feature for columns, if the file is saved as .xlsx with column range grouped(collapsed) then after reopening the file, columns will be gone.
No folding button and ctrl+F2 won't work. Content can be still accessed through format->Column->show.
Looks like Collapsed="true" needs to be set.

If the file is open with Microsoft Office, it will suggest to repair the file due to improper  column naming and result in data lose.


Steps to reproduce:
1. Create a file with a few columns and group them.
2. Save the file as xlsx.
3. Open the file.

Current behavior:
Columns are hidden but not folded.

Expected behavior:
Folded columns/rows with the appropriate buttons/menus.

              
Operating System: Debian
Version: 4.2.4.2 release
Comment 1 ign_christian 2014-06-24 02:28:41 UTC

*** This bug has been marked as a duplicate of bug 64613 ***